Bug 104583 - mesa 17.3.1 seems to be crashing Firefox on i965
Summary: mesa 17.3.1 seems to be crashing Firefox on i965
Status: RESOLVED DUPLICATE of bug 104214
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-11 16:40 UTC by robsmith11
Modified: 2018-01-13 06:11 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description robsmith11 2018-01-11 16:40:04 UTC
I don't have the technical expertise to report this properly, but my own experience (after upgrading mesa to 17.3.1) and the crashes reported by other users of Firefox, it seems that 17.3.1 has introduced a bug that occasionally will cause Firefox to crash on i965 hardware:

https://crash-stats.mozilla.com/signature/?product=Firefox&version=59.0a1&signature=i965_dri.so%400x41cfa4&date=%3E%3D2017-02-04T16%3A15%3A06.000Z&date=%3C2018-01-11T16%3A15%3A06.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1#summary

Just a wild guess, but maybe it's related to this change?
https://github.com/maurossi/mesa/commit/c798b07981aba2e48561a7c1d51c04d300123b54
Comment 1 Elizabeth 2018-01-11 16:54:48 UTC
Hello RobSmith,
Could you share your cpu info, graphics, distro and desktop enviroment? Also could you take a time to find a way to reliably trigger this? It will be really helpful to find a root-cause.
Thank you.
Comment 2 Evangelos Foutras 2018-01-12 07:47:58 UTC
Most likely a duplicate of bug 104214. See comment 29 there for a patch if you want to test the fix.
Comment 3 robsmith11 2018-01-13 06:11:48 UTC
Thanks, it does appear to have been a duplicate.

*** This bug has been marked as a duplicate of bug 104214 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.