Bug 104618 - [snb] GPU HANG: ecode 6:0:0xf288fff8, in DDNet (Teeworlds)
Summary: [snb] GPU HANG: ecode 6:0:0xf288fff8, in DDNet (Teeworlds)
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-13 16:40 UTC by Boris Bobrov
Modified: 2019-09-25 19:07 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump (904.42 KB, text/plain)
2018-01-13 16:40 UTC, Boris Bobrov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Bobrov 2018-01-13 16:40:07 UTC
Created attachment 136711 [details]
GPU crash dump

While playing teeworlds i got this:

[ 1501.671523] [drm] GPU HANG: ecode 6:0:0xf288fff8, in DDNet [7405], reason: Hang on render ring, action: reset
[ 1501.671524] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 1501.671525] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 1501.671525] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 1501.671525] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 1501.671526] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 1501.671551] drm/i915: Resetting chip after gpu hang
[ 1556.672304] drm/i915: Resetting chip after gpu hang
[ 1623.707401] drm/i915: Resetting chip after gpu hang
[ 1652.697277] drm/i915: Resetting chip after gpu hang
Comment 1 Elizabeth 2018-01-23 19:46:48 UTC
Hello Boris, is this reproducible? What mesa version are you using? What distro and desktop environment? Is this over steam?? Thank you.
Comment 2 Boris Bobrov 2018-01-23 21:00:29 UTC
(In reply to Elizabeth from comment #1)
> Hello Boris, is this reproducible? What mesa version are you using? What
> distro and desktop environment? Is this over steam?? Thank you.

Hi! This is always reproducible, it starts to appear after 5-10 minutes. Mesa probably 13.0.6-1+b2 from Debian. I use Debian and KDE. The game was downloaded directly from https://ddnet.tw/, x86_64 binary.

libdrm-intel1 is 2.4.74-1, i have tried downgrading it to 2.4.58-2, will check if it helps.
Comment 3 Mark Janes 2018-01-23 21:15:17 UTC
Hi Boris,

Mesa has many fixes since version 13.  Could you try the 17.3 stable release?
Comment 4 Boris Bobrov 2018-01-31 10:32:59 UTC
Right now i have downgraded to debian-oldstable 10.3.2-1+deb8u, and can't reproduce that issue. I will test latest stable release, but only in a couple of weeks, sorry.
Comment 5 Marina Chernish 2018-08-08 07:43:03 UTC
Hi Boris,

I've tried to reproduce this issue on following configuration:

Ubuntu 16.04.4
Kernel 14.15.0; 14.9.0
CPU: Intel Core i5-2520M
Teeworlds (DDNet): 10.8.6 x86_64; 11.3.1 x86_64
mesa: 13.0.6; 18.2.0

and didn't succeed. Teeworlds works fine with no hangs or interrupts on the mentioned mesa version as well as on the newest 18.2.0 one.
I've tried the latest version of game and approximately that you have that time (according to date of this issue).

Could you please look if the newest mesa is also works good for you?
Comment 6 Marina Chernish 2018-08-08 08:26:28 UTC
(In reply to Marina Chernish from comment #5)
> Hi Boris,
> 
> I've tried to reproduce this issue on following configuration:
> 
> Ubuntu 16.04.4
> Kernel 14.15.0; 14.9.0
> CPU: Intel Core i5-2520M
> Teeworlds (DDNet): 10.8.6 x86_64; 11.3.1 x86_64
> mesa: 13.0.6; 18.2.0
> 
> and didn't succeed. Teeworlds works fine with no hangs or interrupts on the
> mentioned mesa version as well as on the newest 18.2.0 one.
> I've tried the latest version of game and approximately that you have that
> time (according to date of this issue).
> 
> Could you please look if the newest mesa is also works good for you?

Some corrections to my comment:

Kernel versions: 4.15.0; 4.9.0 were used.
DRI: Intel(R) Sandybridge.
Comment 7 GitLab Migration User 2019-09-25 19:07:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1675.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.