Bug 104625 - semicolon after if
Summary: semicolon after if
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Thomas Hellström
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-14 18:54 UTC by Grazvydas Ignotas
Modified: 2018-03-08 03:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grazvydas Ignotas 2018-01-14 18:54:59 UTC
9d81ab73768db6647c116f4710f7a93d8d41e3b1 adds this:

+      if (blit_info->src.resource->format != blit_info->src.format ||
+          blit_info->dst.resource->format != blit_info->dst.format ||
+          !util_is_format_compatible(src_desc, dst_desc));

which looks wrong and does nothing if I read it right. Perhaps something else was intended?
Comment 1 Thomas Hellström 2018-01-15 11:56:40 UTC
Thanks. This looks like a leftover debug hack.
Comment 2 Timothy Arceri 2018-03-08 03:40:23 UTC
Fixed by:

author	Thomas Hellstrom <thellstrom@vmware.com>
commit	80c31f7837cd319910d94d780f5048de6cce0adb

svga: Fix a leftover debug hack

Fix what appears to be a leftover debug hack.
The hack would force the driver to take a different blit path; possibly,
although unverified, reverting to software blits.

Tested using piglit tests/quick. No related regressions.

Cc: "17.2 17.3 18.0" <mesa-stable@lists.freedesktop.org>
Fixes: 9d81ab7376 (svga: Relax the format checks for copy_region_vgpu10 somewhat)
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=104625
Reported-by: Grazvydas Ignotas <notasas@gmail.com>
Signed-off-by: Thomas Hellstrom <thellstrom@vmware.com>
Reviewed-by: Brian Paul <brianp@vmware.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.