Bug 104647 - [snb] GPU hang on ThinkPad X220 while playing Quake on Fedora 27
Summary: [snb] GPU hang on ThinkPad X220 while playing Quake on Fedora 27
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-16 00:20 UTC by robotdruid
Modified: 2018-05-18 12:01 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU hang from /sys/class/drm/card0/error (38.46 KB, text/plain)
2018-01-16 00:20 UTC, robotdruid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robotdruid 2018-01-16 00:20:32 UTC
Created attachment 136743 [details]
GPU hang from /sys/class/drm/card0/error

The game locks up (screen freezes).

"journalctl -b" shows a GPU hang.

GNOME on Xorg. Wayland disabled in with WaylandEnable=false in /etc/gdm/custom.conf

The ThinkPad X220 laptop is connected via DisplayPort to an Acer V273HL HDMI monitor over a DisplayPort->HDMI adapter. The built-in laptop screen is turned off and the lid is closed.

Game was downloaded/installed in a regular user account using the standalone client installer at http://nquake.com (containing ezquake3.0.1-linux64-update.tar).
Comment 1 Elizabeth 2018-01-23 20:07:57 UTC
Hello Robotdruid, what mesa version are you using? Is this always reproducible? Thanks.
Comment 2 vadym 2018-05-15 12:05:10 UTC
Can't reproduce this bug on:

    Linux Mint 18.3 (Kernel 4.16.0-041600-generic)
    Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
    Intel(R) Sandybridge Mobile  (0x126)
    Mesa 18.1.0-devel (git-108e50c)
    nQuake as described on Bugzilla, added only Hi-res textures.

Played single player for around 30 minutes and nothing happened, game operates as expected.

Also tried the same on KBL and didn't see any bugs there as well.
Comment 3 robotdruid 2018-05-18 10:25:40 UTC
(In reply to Elizabeth from comment #1)
> Hello Robotdruid, what mesa version are you using? Is this always
> reproducible? Thanks.

Sadly, the person I used to play against now has bad RSI so we no longer play. Also, I changed distro.

That said:
    - I had experienced the problem on multiple distros
    - It is not always reproducible, regardless of distro

I'm happy for this bug to be closed. I'm also happy to do some more testing on my current setup for you if you really need the data. Please let me know if so.

(In reply to vadym from comment #2)
> Can't reproduce this bug on:
> 
>     Linux Mint 18.3 (Kernel 4.16.0-041600-generic)
>     Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
>     Intel(R) Sandybridge Mobile  (0x126)
>     Mesa 18.1.0-devel (git-108e50c)
>     nQuake as described on Bugzilla, added only Hi-res textures.
> 
> Played single player for around 30 minutes and nothing happened, game
> operates as expected.
> 
> Also tried the same on KBL and didn't see any bugs there as well.

I can confirm that I've played for hours without the bug being triggered. As above, it is not always reproducible.
Comment 4 Francesco Balestrieri 2018-05-18 12:01:29 UTC
Thanks for getting back to us. I will close this based on your feedback.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.