Bug 104685 - [polaris10] amdgpu 0000:01:00.0: swiotlb buffer is full
Summary: [polaris10] amdgpu 0000:01:00.0: swiotlb buffer is full
Status: RESOLVED DUPLICATE of bug 104082
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-18 14:14 UTC by Vedran Miletić
Modified: 2018-01-18 15:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vedran Miletić 2018-01-18 14:14:54 UTC
The GPU is:

01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580] [1002:aaf0]

I'm using BOOT_IMAGE=/boot/vmlinuz-4.15.0-0.rc8.git1.1.fc28.x86_64 root=UUID=fcbff019-0fbb-41ba-885d-438e196bc269 ro selinux=0 rhgb quiet audit=0 amdgpu.dc=1 amdgpu.dc_log=1 LANG=en_US.UTF-8

Normal desktop work got me:

[ 1230.223709] amdgpu 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 1230.223722] swiotlb: coherent allocation failed for device 0000:01:00.0 size=2097152
[ 1230.223725] CPU: 2 PID: 1674 Comm: Xwayland Not tainted 4.15.0-0.rc8.git1.1.fc28.x86_64 #1
[ 1230.223726] Hardware name: Transtec AG    /B85M-E, BIOS 3507 07/21/2017
[ 1230.223727] Call Trace:
[ 1230.223732]  dump_stack+0x85/0xbf
[ 1230.223736]  swiotlb_alloc_coherent+0xe0/0x150
[ 1230.223743]  ttm_dma_pool_get_pages+0x218/0x620 [ttm]
[ 1230.223752]  ttm_dma_populate+0x24d/0x340 [ttm]
[ 1230.223758]  ttm_tt_bind+0x23/0x50 [ttm]
[ 1230.223762]  ttm_bo_handle_move_mem+0x58c/0x5c0 [ttm]
[ 1230.223770]  ttm_bo_validate+0x19c/0x1b0 [ttm]
[ 1230.223775]  ? copy_page_regs+0x1d/0xe0
[ 1230.223780]  ttm_bo_init_reserved+0x46b/0x510 [ttm]
[ 1230.223809]  amdgpu_bo_do_create+0x1b0/0x4f0 [amdgpu]
[ 1230.223827]  ? amdgpu_fill_buffer+0x300/0x300 [amdgpu]
[ 1230.223849]  amdgpu_bo_create+0x50/0x2b0 [amdgpu]
[ 1230.223870]  amdgpu_gem_object_create+0x7f/0x110 [amdgpu]
[ 1230.223889]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1230.223904]  amdgpu_gem_create_ioctl+0x1e8/0x280 [amdgpu]
[ 1230.223923]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1230.223934]  drm_ioctl_kernel+0x59/0xb0 [drm]
[ 1230.223942]  drm_ioctl+0x2d5/0x370 [drm]
[ 1230.223957]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1230.223962]  ? __pm_runtime_resume+0x54/0x90
[ 1230.223966]  ? trace_hardirqs_on_caller+0xed/0x180
[ 1230.223983]  amdgpu_drm_ioctl+0x49/0x80 [amdgpu]
[ 1230.223987]  do_vfs_ioctl+0xa2/0x6d0
[ 1230.223992]  ? __fget+0x125/0x210
[ 1230.223995]  SyS_ioctl+0x74/0x80
[ 1230.224000]  entry_SYSCALL_64_fastpath+0x25/0x9c
[ 1230.224002] RIP: 0033:0x7f9fc317a877
[ 1230.224003] RSP: 002b:00007ffdbf6e0038 EFLAGS: 00000246
[ 1236.389537] amdgpu 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 1236.389541] swiotlb: coherent allocation failed for device 0000:01:00.0 size=2097152
[ 1236.389543] CPU: 6 PID: 1674 Comm: Xwayland Not tainted 4.15.0-0.rc8.git1.1.fc28.x86_64 #1
[ 1236.389545] Hardware name: Transtec AG    /B85M-E, BIOS 3507 07/21/2017
[ 1236.389546] Call Trace:
[ 1236.389552]  dump_stack+0x85/0xbf
[ 1236.389556]  swiotlb_alloc_coherent+0xe0/0x150
[ 1236.389564]  ttm_dma_pool_get_pages+0x218/0x620 [ttm]
[ 1236.389573]  ttm_dma_populate+0x24d/0x340 [ttm]
[ 1236.389579]  ttm_tt_bind+0x23/0x50 [ttm]
[ 1236.389583]  ttm_bo_handle_move_mem+0x58c/0x5c0 [ttm]
[ 1236.389591]  ttm_bo_validate+0x19c/0x1b0 [ttm]
[ 1236.389598]  ? copy_page_regs+0x1d/0xe0
[ 1236.389603]  ttm_bo_init_reserved+0x46b/0x510 [ttm]
[ 1236.389635]  amdgpu_bo_do_create+0x1b0/0x4f0 [amdgpu]
[ 1236.389665]  ? amdgpu_fill_buffer+0x300/0x300 [amdgpu]
[ 1236.389686]  amdgpu_bo_create+0x50/0x2b0 [amdgpu]
[ 1236.389707]  amdgpu_gem_object_create+0x7f/0x110 [amdgpu]
[ 1236.389726]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1236.389741]  amdgpu_gem_create_ioctl+0x1e8/0x280 [amdgpu]
[ 1236.389759]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1236.389771]  drm_ioctl_kernel+0x59/0xb0 [drm]
[ 1236.389778]  drm_ioctl+0x2d5/0x370 [drm]
[ 1236.389804]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1236.389809]  ? __pm_runtime_resume+0x54/0x90
[ 1236.389814]  ? trace_hardirqs_on_caller+0xed/0x180
[ 1236.389842]  amdgpu_drm_ioctl+0x49/0x80 [amdgpu]
[ 1236.389846]  do_vfs_ioctl+0xa2/0x6d0
[ 1236.389852]  ? __fget+0x125/0x210
[ 1236.389855]  SyS_ioctl+0x74/0x80
[ 1236.389860]  entry_SYSCALL_64_fastpath+0x25/0x9c
[ 1236.389863] RIP: 0033:0x7f9fc317a877
[ 1236.389864] RSP: 002b:00007ffdbf6e0038 EFLAGS: 00000246
[ 1280.781784] amdgpu 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 1280.781788] swiotlb: coherent allocation failed for device 0000:01:00.0 size=2097152
[ 1280.781791] CPU: 3 PID: 1674 Comm: Xwayland Not tainted 4.15.0-0.rc8.git1.1.fc28.x86_64 #1
[ 1280.781793] Hardware name: Transtec AG    /B85M-E, BIOS 3507 07/21/2017
[ 1280.781795] Call Trace:
[ 1280.781803]  dump_stack+0x85/0xbf
[ 1280.781808]  swiotlb_alloc_coherent+0xe0/0x150
[ 1280.781816]  ttm_dma_pool_get_pages+0x218/0x620 [ttm]
[ 1280.781825]  ttm_dma_populate+0x24d/0x340 [ttm]
[ 1280.781831]  ttm_tt_bind+0x23/0x50 [ttm]
[ 1280.781835]  ttm_bo_handle_move_mem+0x58c/0x5c0 [ttm]
[ 1280.781843]  ttm_bo_validate+0x19c/0x1b0 [ttm]
[ 1280.781849]  ? copy_page_regs+0x1d/0xe0
[ 1280.781854]  ttm_bo_init_reserved+0x46b/0x510 [ttm]
[ 1280.781905]  amdgpu_bo_do_create+0x1b0/0x4f0 [amdgpu]
[ 1280.781935]  ? amdgpu_fill_buffer+0x300/0x300 [amdgpu]
[ 1280.781978]  amdgpu_bo_create+0x50/0x2b0 [amdgpu]
[ 1280.782031]  amdgpu_gem_object_create+0x7f/0x110 [amdgpu]
[ 1280.782062]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1280.782085]  amdgpu_gem_create_ioctl+0x1e8/0x280 [amdgpu]
[ 1280.782126]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1280.782140]  drm_ioctl_kernel+0x59/0xb0 [drm]
[ 1280.782154]  drm_ioctl+0x2d5/0x370 [drm]
[ 1280.782182]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1280.782189]  ? __pm_runtime_resume+0x54/0x90
[ 1280.782197]  ? trace_hardirqs_on_caller+0xed/0x180
[ 1280.782224]  amdgpu_drm_ioctl+0x49/0x80 [amdgpu]
[ 1280.782231]  do_vfs_ioctl+0xa2/0x6d0
[ 1280.782239]  ? __fget+0x125/0x210
[ 1280.782245]  SyS_ioctl+0x74/0x80
[ 1280.782253]  entry_SYSCALL_64_fastpath+0x25/0x9c
[ 1280.782256] RIP: 0033:0x7f9fc317a877
[ 1280.782259] RSP: 002b:00007ffdbf6e0038 EFLAGS: 00000246
[ 1282.842744] amdgpu 0000:01:00.0: swiotlb buffer is full (sz: 2097152 bytes)
[ 1282.842748] swiotlb: coherent allocation failed for device 0000:01:00.0 size=2097152
[ 1282.842752] CPU: 2 PID: 1674 Comm: Xwayland Not tainted 4.15.0-0.rc8.git1.1.fc28.x86_64 #1
[ 1282.842754] Hardware name: Transtec AG    /B85M-E, BIOS 3507 07/21/2017
[ 1282.842756] Call Trace:
[ 1282.842763]  dump_stack+0x85/0xbf
[ 1282.842769]  swiotlb_alloc_coherent+0xe0/0x150
[ 1282.842779]  ttm_dma_pool_get_pages+0x218/0x620 [ttm]
[ 1282.842788]  ttm_dma_populate+0x24d/0x340 [ttm]
[ 1282.842798]  ttm_tt_bind+0x23/0x50 [ttm]
[ 1282.842804]  ttm_bo_handle_move_mem+0x58c/0x5c0 [ttm]
[ 1282.842818]  ttm_bo_validate+0x19c/0x1b0 [ttm]
[ 1282.842828]  ? copy_page_regs+0x1d/0xe0
[ 1282.842837]  ttm_bo_init_reserved+0x46b/0x510 [ttm]
[ 1282.842887]  amdgpu_bo_do_create+0x1b0/0x4f0 [amdgpu]
[ 1282.842913]  ? amdgpu_fill_buffer+0x300/0x300 [amdgpu]
[ 1282.842934]  amdgpu_bo_create+0x50/0x2b0 [amdgpu]
[ 1282.842954]  amdgpu_gem_object_create+0x7f/0x110 [amdgpu]
[ 1282.842978]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1282.843002]  amdgpu_gem_create_ioctl+0x1e8/0x280 [amdgpu]
[ 1282.843033]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1282.843047]  drm_ioctl_kernel+0x59/0xb0 [drm]
[ 1282.843060]  drm_ioctl+0x2d5/0x370 [drm]
[ 1282.843087]  ? amdgpu_gem_object_close+0x210/0x210 [amdgpu]
[ 1282.843094]  ? __pm_runtime_resume+0x54/0x90
[ 1282.843102]  ? trace_hardirqs_on_caller+0xed/0x180
[ 1282.843130]  amdgpu_drm_ioctl+0x49/0x80 [amdgpu]
[ 1282.843134]  do_vfs_ioctl+0xa2/0x6d0
[ 1282.843139]  ? __fget+0x125/0x210
[ 1282.843143]  SyS_ioctl+0x74/0x80
[ 1282.843148]  entry_SYSCALL_64_fastpath+0x25/0x9c
[ 1282.843150] RIP: 0033:0x7f9fc317a877

This is the same machine as in bug 104611, so the rest of the dmesg is the same.
Comment 1 Alex Deucher 2018-01-18 14:41:02 UTC

*** This bug has been marked as a duplicate of bug 104082 ***
Comment 2 Vedran Miletić 2018-01-18 15:01:15 UTC
Whoops. First time observed here, thought it was rare, should have searched. Sorry.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.