Bug 104689 - [skl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg
Summary: [skl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg
Status: RESOLVED DUPLICATE of bug 104411
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-18 21:21 UTC by Mika Tiainen
Modified: 2018-01-25 18:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error content (40.30 KB, text/plain)
2018-01-18 21:21 UTC, Mika Tiainen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mika Tiainen 2018-01-18 21:21:33 UTC
Created attachment 136837 [details]
/sys/class/drm/card0/error content

X hangs reproducibly when changing a Xterm window with remote SSH login to a screen window running rtorrent. After hanging cursor moves but nothing else works and after maybe 30s X session dies and returns to login screen.

Hardware: Lenove T460s laptop with:
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)

WM is awesome, OS Debian unstable running kernel 4.15.0-rc8-amd64 (also happens with 4.14.13) and Mesa 17.3.2. Kernel log shows:

[   44.810470] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [802], reason: Hang on rcs0, action: reset
[   44.810472] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[   44.810472] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[   44.810473] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[   44.810473] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[   44.810474] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[   44.810480] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[   52.801525] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[   60.801746] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[   68.801981] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[   76.802204] i915 0000:00:02.0: Resetting rcs0 after gpu hang
lines 803-830/830 (END)
Comment 1 Mika Tiainen 2018-01-20 15:52:00 UTC
Upgraded to Mesa 17.3.3, still hangs.
Comment 2 Elizabeth 2018-01-23 20:34:08 UTC
Hello Mika, I didn't get quite right the steps to reproduce, could you list them more clearly? I want to try to reproduce the issue, so I need debian, awesome xterm, openssh and rtorrent, right?
Comment 3 Mika Tiainen 2018-01-24 18:46:56 UTC
Hi,

I experimented some more, and found an easier way to reproduce. The key seems to be running under screen in an xterm, doesn't have to a remote host. Without running software under screen hangs don't happen.

Starting aptitude usually causes a hang right at startup, or if not then when quitting. I have also had a few hangs just when doing random things in a screen terminal window.
Comment 4 Mark Janes 2018-01-24 19:02:13 UTC
Hi Mika,

I can't reproduce this on my KBL machine.  If you have a solid way to reproduce, then bisecting mesa in git will likely guarantee a prompt fix.

for example, see https://bugs.freedesktop.org/show_bug.cgi?id=104411

You should also try the patches for that hang to see if they fix the issue you experience.
Comment 5 Kenneth Graunke 2018-01-25 08:30:54 UTC
The patches landed in Mesa master.  If you can, please try upgrading to Mesa master.  Note that you'll need X to pick up the new Mesa, which usually means replacing your system i965_dri.so.
Comment 6 Mika Tiainen 2018-01-25 17:43:10 UTC
Confirmed fixed with i965_dri.so built from git master. Thanks!
Comment 7 Mark Janes 2018-01-25 18:09:16 UTC

*** This bug has been marked as a duplicate of bug 104411 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.