Bug 104776 - The choice of the maximum shadows will be followed by a crash after a while
Summary: The choice of the maximum shadows will be followed by a crash after a while
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-24 20:34 UTC by mrchebik
Modified: 2018-06-01 21:19 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrchebik 2018-01-24 20:34:53 UTC
I have Intel HD Graphics 5500, when I choose maximum graphics of shadows (any game, i.e. Dota 2), after couple of seconds or minutes, I get the hanged picture.

I used 17.2.8, 17.3.0, 18.0.0-rc2.

Also, tried with Vulkan or without.
With Vulkan, Dota 2 run with middle shadows and advanced water.
With OpenGL 4.5, I run without shadows and advanced water.
Advanced water also influences to hanged picture, but Vulkan fixes this.

I have this error:
'i965: failed to submit batchbuffer: input/output error'

--
It is interesting that when was 'memory leak' with Vulkan (17.3.0), I can play with maximum graphics of shadows.
Comment 1 mrchebik 2018-01-24 20:48:53 UTC
> I used 17.2.8, 17.3.0, 18.0.0-rc2.

Now, I use 17.3.1
Comment 2 mrchebik 2018-01-28 17:36:51 UTC
I'm tried version 11.2.2, and I don't get hanged picture (test duration more than 10 minutes).

Also, I noticed, that 11.2.2 better than 17.3.1 to 2-4 FPS.
Comment 3 Andriy Khulap 2018-01-29 15:05:27 UTC
I am unable to reproduce this on:
- Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz
- Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2)  (0x191b)
- Ubuntu 16.04 LTS, Kernel 4.13.0-32-generic
- Mesa 17.2.5 (git ae52410bf08a)
- Mesa 18.1.0-devel (git d0343bef6680)

Tried the Dota 2 game from Steam. Set maximum graphics options including highest shadows and advanced water checked.
No hangs during basic tutorial, played up to 10 min each run.

Also tried latest 18.1.0-devel (git d0343bef6680) built with --with-vulkan-drivers=intel and -vulkan enabled in the Dota 2 steam launch options. No graphical issues also.
Comment 4 mrchebik 2018-01-30 14:20:33 UTC
I think, it's need identical system to reproduce, I use Intel Core i5-5200U.
How I can to see more detailed information about crash?

Also, I noticed, that at Mesa 17.3.1 in Vulkan, I can meet 'memory leak', but not always it happens.
Comment 5 Tapani Pälli 2018-02-01 07:34:02 UTC
very similar report in IRC, this is with older GEN though:

--- 8< ---
12:21 < cocody> An application freezes and lags with mesa when anti-aliasing is enabled AND specific screen resolutions are used.
12:21 < cocody> Using OpenGL. I occasionally get a warning message: i965: Failed to submit batch buffer: Input/output error
12:21 < cocody> Is this a known problem?
14:11 < cocody> mesa 17.3.3.2 with i5-2540M . The application is warzone2100, in which the problem occurs after starting a game. The culprit are these two lines: 
                https://github.com/Warzone2100/warzone2100/blob/master/lib/sdl/main_sdl.cpp#L1265
--- 8< ---
Comment 6 Tapani Pälli 2018-02-01 09:31:05 UTC
mrchebik, what do you mean by 'memory leak', does this refer to some other existing bug?
Comment 7 mrchebik 2018-02-01 14:27:55 UTC
I meant leakage of RAM. With Vulkan, each 1-2 minutes increases on several Mb in the RAM. To clean with means of a game (Dota 2), it hasn't turned out to clean (via the console, various commands).

It is necessary after each match, to re-enter the game.
Comment 8 Denis 2018-05-29 08:07:40 UTC
Tried to reproduce this issue on SandyBridge:

    Linux Mint 18.3 (Kernel 4.16.0-041600-generic)
    Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
    Intel(R) Sandybridge Mobile  (0x126)
    Mesa 17.2.8, 17.3.0, 18.0.0-rc2

Set all settings to maximum (except grass and v-sync, they were unavailable). Game became a slideshow but didn't crash, no graphical artifacts were seen.

Also tested Warzone 2100 game with the same setups and also found no issues.
Comment 9 mrchebik 2018-06-01 21:19:45 UTC
Thanks for help!
At 18.1 and 18.1.1 - I don't notice this issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.