Bug 104822 - [snb] GPU hang ecode 6:0:0x85fffffc, in gnome-shell [1047]
Summary: [snb] GPU hang ecode 6:0:0x85fffffc, in gnome-shell [1047]
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-28 20:50 UTC by Sumit Anantwar
Modified: 2019-09-25 19:08 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
GP Crash Dump (28.09 KB, text/plain)
2018-01-28 20:50 UTC, Sumit Anantwar
Details
Power Supply Specs (1.50 MB, image/jpeg)
2018-01-29 07:28 UTC, Sumit Anantwar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Anantwar 2018-01-28 20:50:49 UTC
Created attachment 137010 [details]
GP Crash Dump

GPU Hang was observed, and the below explanation was found in dmesg.
GPU crash dump is attached.

[Jan28 22:39] [drm] GPU HANG: ecode 6:0:0x85fffffc, in gnome-shell [1047], reason: Hang on rcs0, action: reset
[  +0.000002] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  +0.000000] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  +0.000001] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  +0.000000] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  +0.000001] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  +0.000052] i915 0000:00:02.0: Resetting chip after gpu hang
Comment 1 Robert Wahlstedt 2018-01-29 01:18:06 UTC
Hello, I think I’ve seen this before when the GPU was not able to get enough watts from the power supply. The log indicates the GPU was able to move on. Was this the case. There are brown outs based on insufficient power from a power company. If you see a lot of these please invest in a Unterruptable power supply from a relyable company such as ApC or cyberpower. What is the specs of the power supply if you don’t mind me asking. If this error persists we can walk you through how to enable IOMMU should this be an option in the bios.

Definition from Wikipedia
“In computing, an input–output memory management unit (IOMMU) is a memory management unit (MMU) that connects a direct-memory-access–capable (DMA-capable) I/O bus to the main memory. Like a traditional MMU, which translates CPU-visible virtual addresses to physical addresses, the IOMMU maps device-visible virtual addresses (also called device addresses or I/O addresses in this context) to physical addresses”

Is this a physical or virtual machine context.

Cheers, Rob Wahl
Comment 2 Sumit Anantwar 2018-01-29 07:28:24 UTC
Created attachment 137015 [details]
Power Supply Specs
Comment 3 Sumit Anantwar 2018-01-29 07:38:57 UTC
Hello Rob,
Thanks for the reply.
This is a physical machine. I use VMs almost daily, but at that moment no VM was active.
I have placed the PSU spec image in the attachments.
This could be the first time this has happened.
I say "could", because this was the first time the system hung without having any GPU intensive tasks running, or this was the first time I cared to look into the "dmesg" log.
Thank you for pointing out IOMMU, will search more about it.

Best,
Sumit
Comment 4 Elizabeth 2018-03-14 23:27:14 UTC
Hello Sumit, new mesa 17.3.6 release fixed various gpu hangs reported with games and DEs, could you try it if issue still reproducible? Thank you.
Comment 5 Vitalii Para 2018-06-23 08:57:37 UTC
try add in .drirc (it fix for me):
<driconf>
    <device screen="0" driver="i965">
        <application name="java" executable="java">
            <option name="mesa_no_error" value="true" />
            <option name="always_flush_batch" value="true" />
        </application>
    </device>
</driconf>

In my case it was an error in Batch Buffer.

Mesa 17.3.9
Linux localhost 4.14.44-desktop-2.mga6 #1 SMP Mon May 28 22:35:45 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

where java write your application name
Comment 6 GitLab Migration User 2019-09-25 19:08:09 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1681.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.