Bug 104890 - Zalgo present in Mesa 18.0rc3
Summary: Zalgo present in Mesa 18.0rc3
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-31 20:36 UTC by Mark Janes
Modified: 2018-09-27 12:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
misrendered pixels at top of page (994.76 KB, application/octet-stream)
2018-01-31 20:36 UTC, Mark Janes
Details
disable blorp texture upload (1.37 KB, patch)
2018-02-23 21:34 UTC, Mark Janes
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Janes 2018-01-31 20:36:40 UTC
Created attachment 137094 [details]
misrendered pixels at top of page

Recently I have notice some rendering artifacts when running Firefox
on Mesa 18.0rc3.  It shows up as a rectangular block of misrendered
pixels, in a checkerboard pattern.  It is hard to catch, but I managed
to record my desktop with the rendering.  See attached.

I'm running:

 - Linux 4.14.0-3
 - ̂ͧ̌̿ͣͥM̓̌ͫ͗e̒̃̈́̈́ͫs̅̏a ̄̇ͯ͑18.0͂rͩ͌ͧc͆͌̈́ͣͮ̂3͒̆
 - KBL GT2
 - F̌̏̑i͐ͤ̔ͪȓ͆̍̃̔eͮ͒͆ͩf̔̍̔͂͑oͤ͗ͪx̄͑͒̂̂̃ 52.5

If anyone has seen something similar, Please help. by finding a
reproducible case that we can use to bisect.  I usually see it on our
Jenkins page hopefully the Nezperdian hive-mind of c͗ͥͩh̑͋ͪaos̃̊̐̋ is not
in the lab.

My shader crache is enabled but He who Waits Behind The Wall will not
permit.  ͗͑̊i͑ͮ͛ͬsͤ̉̌̎̒ ͧt̾͊h̅̋̀ͪa̓̂͂͌t̾ blood?

ͥ̚ZĂ̋̐͒Lͦ̔ͭGͭO!ͥͥͧ̊
Comment 1 Kenneth Graunke 2018-01-31 21:31:22 UTC
I too experience this issue on Kabylake GT2.  However, I'm uncertain of why you decided to call us.  Everyone knows the correct people to call are the Ghostbusters.

Thanks for the report!
Comment 2 Mark Janes 2018-02-09 00:13:55 UTC
Reproduces on firefox 58 and firefox 52.
Comment 3 Mark Janes 2018-02-09 21:20:04 UTC
I see this corruption with Mesa 17.3 but not 17.2.
Comment 4 Mark Janes 2018-02-10 00:27:03 UTC
Jason asked me to check d6d0ac95d5d77bd18b2064c3ed9aad70cf38cb6f, the last good commit before copy-image tests failed.  I could see the distortion at that commit.
Comment 5 Mark Janes 2018-02-10 00:41:14 UTC
This corruption seems easier to reproduce using a google docs spreadsheet.  As you mouse over elements, the artifacts appear.
Comment 6 Mark Janes 2018-02-16 01:17:29 UTC
This is likely to be related to firefox's layers.acceleration.force-enabled setting.  Both Ken and myself had gpu rendering enabled, which is not the default setting.
Comment 7 Nanley Chery 2018-02-21 22:31:15 UTC
Are you able to reproduce this with INTEL_DEBUG=norbc? 

I haven't been able to reproduce this after trying for several days on the following system config:
* HSW (doesn't have CCS_E)
* mesa-git
* layers.acceleration.force-enabled = true
Comment 8 Mark Janes 2018-02-22 01:54:32 UTC
I have not been able to reproduce this with norbc.
Comment 9 Mark Janes 2018-02-22 14:28:51 UTC
Lionel found this user experiencing the same thing:
https://twitter.com/ebassi/status/966614066881073152
Comment 10 Emmanuele Bassi (:ebassi) 2018-02-22 14:35:28 UTC
Hi, I'm a Firefox 58 user on Intel Kabylake (Dell XPS 9360) tweeting rendering bugs, AMA.

 - Fedora 27
 - Linux 4.15.3-300.fc27.x86_64
 - Firefox 58.0.2, with layers.acceleration.force-enabled set to true
 - Mesa 17.3.4
Comment 11 Mark Janes 2018-02-23 21:34:28 UTC
Created attachment 137564 [details] [review]
disable blorp texture upload

Jason Ekstrand looked at a the way Firefox renders a problematic page in FrameRetrace.  He suggested disabling blorp texture upload.

I have been running with this patch today, and have not seen any artifacts.
Comment 12 vadym 2018-03-05 18:03:14 UTC
Able to reproduce it several times but there is no reliable test procedure for this. I recorded apitrace with this bug but on replay it is gone. 

My setup info:
OS: Ubuntu 16.04 LTS 64 bit
Firefox: 58.0.2 (64-bit)
Mesa: 18.1.0-devel (git-33633690aa)
CPU: Intel® Core™ i7-8550U CPU @ 1.80GHz × 8 
GPU: Intel® UHD Graphics 620 (Kabylake GT2)
Comment 13 Mark Janes 2018-03-06 00:41:32 UTC
*** Bug 105332 has been marked as a duplicate of this bug. ***
Comment 14 Andriy Khulap 2018-03-12 07:58:30 UTC
I'm using Firefox as a main browser and didn't see any artifacts until enabling "layers.acceleration.force-enabled" setting. With this option enabled, I'm seeing rare artifacts when switching mail filters in gmail (but they are mostly black, not pink).
Firefox 52.6.0 (64-bit) and Mesa 17.3.3 from Debian testing.

I think this confirms Comment 6.
Comment 15 Jason Ekstrand 2018-03-14 05:21:55 UTC
Good news everyone!  I think I figured out how to reliably reproduce zalgo!  In particular, if you make a new firefox window that's relatively small and then maximize and unmaximize it, you can get zalgo during the resize.  This may or may not be the same zalgo but it definitely looks like CCS corruption.
Comment 16 Kenneth Graunke 2018-03-14 21:37:49 UTC
Removing from Mesa 18.0 blockers list as discussed on IRC and elsewhere.
Comment 17 Andriy Khulap 2018-03-16 11:56:25 UTC
Jason, unfortunately this method doesn't work for me.
I'm experiencing random corruptions, mostly on pages itself, independent of their complexity. Corruptions are rare, but come in packs (like for several seconds) so in my case they looks related to some background process and not the page itself.
Comment 18 vadym 2018-03-19 16:24:35 UTC
Reverting following commit fixes zalgo issue for me: 

commit 157faa407f51829fb8b2d2af723547dc8a0d3849
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Wed May 31 17:53:34 2017 -0700

    i965/tex: Use blorp texture upload for all CCS_E textures
    
    This improves the FillTex benchmark in GLBench 2.7 by 30% on my Broxton.
    On Ken's Broxton which only has single-channel ram, it improves by 210%.
    
    v2 (Ken): Check mt->aux_usage == ISL_AUX_USAGE_CCS_E rather than using
              intel_miptree_is_lossless_compressed().
    
    Reviewed-by: Topi Pohjolainen <topi.pohjolainen@intel.com>
    Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>

Can anyone else check it please ?

Also I tried a patch in 105351 Bug https://bugs.freedesktop.org/attachment.cgi?id=138163. Issue looks quite similar, but that patch didn't help.
Comment 19 Mark Janes 2018-03-19 17:12:16 UTC
Vadym, based on resolution of a similar bug, this may be a bug in firefox.

I was unable to see Zalgo with this patch from bug 105332:
https://bugs.freedesktop.org/attachment.cgi?id=138120

Can you try that patch and confirm that it fixes firefox as well?  I've not seen corruption but as we all know it is hard to reproduce.
Comment 20 Andriy Khulap 2018-03-22 15:16:08 UTC
Tested:
- Reverting commit 157faa407f51829fb8b2d2af723547dc8a0d3849
- patch from bug 105332: https://bugs.freedesktop.org/attachment.cgi?id=138120

And both methods are solving the issue for me.
Comment 21 Tapani Pälli 2018-05-28 04:58:04 UTC
I'm resolving this as NOTOURBUG. Apparently this is/was a Firefox issue using same texture with multiple GL contexts and not handling synchronization properly.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.