Bug 105004 - Mesa causes Unity3d Game Editor Crash
Summary: Mesa causes Unity3d Game Editor Crash
Status: RESOLVED DUPLICATE of bug 99781
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: 17.3
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-07 18:08 UTC by Rafał
Modified: 2018-02-07 19:08 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Editor Logs and Xorg (35.49 KB, application/zip)
2018-02-07 18:08 UTC, Rafał
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał 2018-02-07 18:08:26 UTC
Created attachment 137218 [details]
Editor Logs and Xorg

When I open Unity3d on empty or casual project, Editor crash and close itself or work only max a few minutes. I wrote to unity team but they say that is issue with mesa driver. I add 4 logs from unity crash and one from xorg. I think it is something wrong with this lines:

[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Unityyy: ../../src/xcb_io.c:259: poll_for_event: Warunek zapewnienia `!xcb_xlib_threads_sequence_lost' nie został spełniony.
/home/builduser/buildslave/unity/build/Editor/Platform/Linux/UsbDevices.cpp:UsbDevicesQuery




PC Specs
Intel i3 2330m 2,2GHz HT
Intel HD 3000 OpenGL 3.3 OpenGL ES 3.0
8GB RAM
Desktop Environment - Mate (also repeatable on LXQT)
Mesa from stable Padoka PPa 17.3.2 (I has also bug on older even 17.0)
Comment 1 Nicholas Miell 2018-02-07 19:08:53 UTC

*** This bug has been marked as a duplicate of bug 99781 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.