Bug 105081 - (regression) pdftocairo damages this PDF when converting to PS or PDF
Summary: (regression) pdftocairo damages this PDF when converting to PS or PDF
Status: RESOLVED DUPLICATE of bug 94615
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-13 19:51 UTC by Alex Korobkin
Modified: 2018-07-06 15:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
isandlsmissing.pdf (59.16 KB, application/pdf)
2018-02-13 19:52 UTC, Alex Korobkin
Details
is-cairo53.pdf (48.73 KB, application/pdf)
2018-02-13 19:53 UTC, Alex Korobkin
Details
is-cairo53.ps (77.25 KB, application/postscript)
2018-02-13 19:53 UTC, Alex Korobkin
Details
is-cairo24.pdf (48.62 KB, application/pdf)
2018-02-13 19:53 UTC, Alex Korobkin
Details
is-cairo24.ps (76.66 KB, application/postscript)
2018-02-13 19:53 UTC, Alex Korobkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Korobkin 2018-02-13 19:51:10 UTC
This seemingly valid PDF gets curiously broken, when converted by pdftocairo into level 3 PS or PDF, letters i and l are missing from the result. 

Cairo 1.14.12, poppler-utils 0.53.0, both commands produce a resulting PDF or PS where letters i and l are missing:

pdftocairo -ps -level3 isandlsmissing.pdf is-cairo53.ps
pdftocairo -pdf isandlsmissing.pdf is-cairo53.pdf

Same commands produce correct files on Ubuntu 14.04, cairo 1.13.1, poppler-utils 0.24.5.

pdftocairo -ps -level3 isandlsmissing.pdf is-cairo24.ps
pdftocairo -pdf isandlsmissing.pdf is-cairo24.pdf

Original PDF was validated with Adobe Pro DC, no syntax errors found. Here is the report. 

Preflight Summary Report for: isandlsmissing.pdf
Profile: Report PDF syntax issues (Processed pages 1 to 1)
Results (Summary): No problems found

File name: "isandlsmissing.pdf"
PDF version number: "1.7"
File size (KB): 59.2
Creator: "PDFium"
Created: "2/13/2018 2:48 PM"
Trapping: "Unknown"
Preflight, 15.2.0 (199)
Acrobat version: 18.90


Also attached are PDF and PS results produced by pdftocairo version 0.24.5 (is-cairo24.ps, pdf) and version 0.53.0 (is-cairo53.pdf,ps)
Comment 1 Alex Korobkin 2018-02-13 19:52:49 UTC
Created attachment 137328 [details]
isandlsmissing.pdf
Comment 2 Alex Korobkin 2018-02-13 19:53:09 UTC
Created attachment 137329 [details]
is-cairo53.pdf
Comment 3 Alex Korobkin 2018-02-13 19:53:22 UTC
Created attachment 137330 [details]
is-cairo53.ps
Comment 4 Alex Korobkin 2018-02-13 19:53:36 UTC
Created attachment 137331 [details]
is-cairo24.pdf
Comment 5 Alex Korobkin 2018-02-13 19:53:48 UTC
Created attachment 137332 [details]
is-cairo24.ps
Comment 6 Alex Korobkin 2018-02-28 16:38:16 UTC
Reproduced on Debian testing (buster), poppler 0.61.1, cairo 1.14.10.
Comment 7 Alex Korobkin 2018-07-05 19:15:47 UTC
Perhaps someone could have a quick look at this weird bug?
Comment 8 Jason Crain 2018-07-05 19:33:05 UTC
(In reply to Alex Korobkin from comment #7)
> Perhaps someone could have a quick look at this weird bug?

Try it with cairo version >= 1.15.4. It could be https://bugs.freedesktop.org/show_bug.cgi?id=94615 .
Comment 9 Alex Korobkin 2018-07-06 15:49:15 UTC
Thanks so much, Jason! That was it. 
I backported a patch for my 1.14.12 from https://bugs.launchpad.net/ubuntu/+source/cairo/+bug/1734092

and it fixed the issue.

*** This bug has been marked as a duplicate of bug 94615 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.