Bug 105107 - [BAT] igt@gem_exec_suspend@basic-s3 - incomplete - timeout/system hang ?
Summary: [BAT] igt@gem_exec_suspend@basic-s3 - incomplete - timeout/system hang ?
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Don Hiatt
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-15 07:05 UTC by Marta Löfstedt
Modified: 2019-08-28 11:45 UTC (History)
2 users (show)

See Also:
i915 platform: ILK
i915 features: power/suspend-resume


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2018-02-15 07:05:07 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3774/fi-ilk-m540/igt@gem_exec_suspend@basic-s3.html

run.log:
running: igt/gem_exec_suspend/basic-s3

[107/288] skip: 26, pass: 81 \        
FATAL: command execution failed
...
CI_IGT_test runtime 228 seconds
Rebooting fi-ilk-m540

Last dmesg:
<4>[  180.691764] Setting dangerous option reset - tainting kernel
<7>[  180.694466] [IGT] gem_exec_suspend: starting subtest basic-S3
<6>[  181.438453] PM: suspend entry (deep)

Looks like it never came up after suspend.
Comment 1 Marta Löfstedt 2018-04-17 14:57:38 UTC
Check if it is still in BAT
Comment 2 Marta Löfstedt 2018-04-18 06:16:24 UTC
reproduced:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4056/fi-ilk-m540/igt@gem_exec_suspend@basic-s3.html

setting priority to high since it is ILK
Comment 3 Lakshmi 2018-09-04 09:55:19 UTC
This issue occurred 3 months ago last time ago. Before that, it used to occur once in a week. With CI DRM the occurrence gap was 200 rounds or 1 month gap. So, we keep this bug open for few more weeks or at least 1 month, then this bug can think of closing this bug.
Comment 4 Anshuman Gupta 2018-11-12 12:04:22 UTC
I have observed similar issue on ICL H/W while running IGT ./ksm_psr.
ICL H/W never came up after suspend.
Comment 5 CI Bug Log 2019-02-12 10:10:56 UTC
The CI Bug Log issue associated to this bug has been updated.

### New filters associated

* fi-ilk-650: suspend tests - incomplete
  - https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_213/fi-ilk-650/igt@kms_cursor_crc@cursor-256x256-suspend.html
Comment 6 CI Bug Log 2019-02-12 11:36:25 UTC
A CI Bug Log filter associated to this bug has been updated:

{- fi-ilk-650: suspend tests - incomplete -}
{+ fi-ilk-650: suspend tests - incomplete +}

New failures caught by the filter:

* https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_217/fi-ilk-650/igt@kms_flip@2x-flip-vs-suspend.html
Comment 7 Don Hiatt 2019-02-20 22:16:34 UTC
Other than the systems just dying, I'm not sure how these last two failures are related. (1) Crashes waking up from S3, but (2) wakes up completely only to die later on.

The logs in comments #1,2 are not accessible.


 
(1)
"<6>[  310.084205] ACPI: Waking up from system sleep state S3"
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_217/fi-ilk-650/dmesg25.log

(2)
"<7>[  176.693274] [drm:verify_single_dpll_state.isra.105 [i915]] PCH DPLL A"
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_213/fi-ilk-650/dmesg6.log
Comment 8 Don Hiatt 2019-02-21 18:15:25 UTC
This appears to be isolated to ICL and it occurs after suspend tests. One run doesn’t seem to come out of suspend, while the later comes out but resets later on down the road.

I wonder if it might be the watchdog kicking in too early, or not being kicked in time to prevent a reset.
Comment 9 Don Hiatt 2019-02-21 18:19:30 UTC
(In reply to Don Hiatt from comment #8)
> This appears to be isolated to ICL and it occurs after suspend tests. One
> run doesn’t seem to come out of suspend, while the later comes out but
> resets later on down the road.
> 
> I wonder if it might be the watchdog kicking in too early, or not being
> kicked in time to prevent a reset.

Meant to say, ILK.
Comment 10 Don Hiatt 2019-02-25 19:54:30 UTC
This has not been seeing for over 33 days, dropping priority and will monitor.
Comment 11 Don Hiatt 2019-06-03 17:34:23 UTC
Closing as this bug has not been seen in well over 3 months.
Comment 12 Martin Peres 2019-08-28 11:45:25 UTC
Thanks, it indeed looks like has been fixed.
Comment 13 CI Bug Log 2019-08-28 11:45:34 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.