Bug 105138 - Dell TB16 audio volume too low
Summary: Dell TB16 audio volume too low
Status: RESOLVED NOTOURBUG
Alias: None
Product: PulseAudio
Classification: Unclassified
Component: alsa (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: pulseaudio-bugs
QA Contact: pulseaudio-bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-16 22:23 UTC by Costa Tsaousis
Modified: 2018-02-20 07:50 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Costa Tsaousis 2018-02-16 22:23:48 UTC
Hi,

I have a dell xps 9560 + dell tb16 running an updated fedora 27.

The problem is that 100% volume on tb16 usb audio, is like 5% of the internal speaker.

I verified that this commit https://github.com/pulseaudio/pulseaudio/commit/c8851db8b223019415ddde15262722160f53f0c4 (rules.d line and tb16 config file), are present on my system. Still the volume is too low.

When booting the same system into Windows, the tb16 usb audio volume is perfectly normal, loud and clear.

Referred to this Bugzilla by https://bugzilla.redhat.com/show_bug.cgi?id=1492344

Thanks!
Comment 1 Tanu Kaskinen 2018-02-17 06:46:44 UTC
This sounds like pulseaudio isn't configuring the alsa mixer settings properly. The current configuration for TB16 doesn't seem to be doing anything with the mixer.

What does "amixer -cX" print? Replace X with the card index. You can see the card index in /proc/asound/cards.
Comment 2 Costa Tsaousis 2018-02-18 15:48:30 UTC
Hi, thank you for responding.

$ cat /proc/asound/cards 
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xed128000 irq 143
 1 [Audio          ]: USB-Audio - USB Audio
                      Generic USB Audio at usb-0000:0e:00.0-1.5, high speed


$ amixer -c1
Simple mixer control 'Mic',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 127
  Front Left: Capture 99 [78%] [16.00dB] [on]
  Front Right: Capture 99 [78%] [16.00dB] [on]
Simple mixer control 'Extension Unit',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Loudness',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]


On card 0, we have a lot more:

$ amixer -c0
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 127
  Mono: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 117 [92%] [-5.00dB] [off]
  Front Right: Playback 117 [92%] [-5.00dB] [off]
Simple mixer control 'Headphone Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 28 [90%] [7.50dB] [off]
  Front Right: Playback 28 [90%] [7.50dB] [off]
Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 127
  Mono:
  Front Left: Playback 127 [100%] [0.00dB] [on]
  Front Right: Playback 127 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 127
  Front Left: Capture 93 [73%] [13.00dB] [on]
  Front Right: Capture 93 [73%] [13.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 60 [50%] [0.00dB]
  Front Right: Capture 60 [50%] [0.00dB]
Simple mixer control 'Headset Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Headset Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Internal Mic',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [on]
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Comment 3 Tanu Kaskinen 2018-02-19 13:36:47 UTC
The USB device don't seem to have any playback volume controls. It only has two switches, "Extension Unit" and "Loudness", and the loudness switch is already on, so I'd guess PulseAudio can't really do anything about the low volume.

You can anyway try with "alsamixer -c1" what those two switches do. In case you're not familiar with alsamixer, here are the important keys: left and right arrows move between elements, and the 'm' key toggles the selected switch on and off. Esc exits alsamixer.
Comment 4 Costa Tsaousis 2018-02-19 14:55:34 UTC
thanks!

I can control the volume though. It just doesn't get high enough. And on windows it works as expected, so there should be something that controls the volume there.

Do you believe this a driver problem?
Any ideas what I should do now to fix this issue?
Comment 5 Tanu Kaskinen 2018-02-19 14:59:13 UTC
You can control the volume, because PulseAudio implements software volume, but PulseAudio can't do anything to increase the maximum volume.

You should try what those two switches in the mixer do. If they don't do anything useful, then this seems like a driver problem. Here are some instructions about reporting alsa bugs: http://alsa-project.org/main/index.php/Bug_Tracking
Comment 6 Costa Tsaousis 2018-02-19 15:10:47 UTC
Thanks again! You are very helpful!

The extension unit switch cannot be switched on/off - it stays off no matter what I do.

The loudness switch can be switched on/off, but it doesn't seem to affect anything.

btw, I noticed that if I boot to windows, increase the volume and reboot to Linux, then on Linux I have higher max volume (up to the volume set by Windows) - but as you said, this works because of the software volume implementation of pulseaudio.

I'll attempt to open an issue at alsa-project.org!

Thanks!
Comment 7 Costa Tsaousis 2018-02-19 15:27:15 UTC
Opened https://bugzilla.kernel.org/show_bug.cgi?id=198825


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.