Bug 105146 - [kbl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg
Summary: [kbl] GPU HANG: ecode 9:0:0x85dffffb, in Xorg
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-17 13:12 UTC by Pit N.
Modified: 2019-09-25 19:08 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
crash dump (52.18 KB, text/plain)
2018-02-17 13:12 UTC, Pit N.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pit N. 2018-02-17 13:12:49 UTC
Created attachment 137417 [details]
crash dump

X crashes. Last action was opening a tab inside browser.

Greets, Pit


logs::

    Feb 17 13:27:15 ferdi2 kernel: [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1181], reason: Hang on rcs0, action: reset
    Feb 17 13:27:15 ferdi2 kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
    Feb 17 13:27:15 ferdi2 kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
    Feb 17 13:27:15 ferdi2 kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
    Feb 17 13:27:15 ferdi2 kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
    Feb 17 13:27:15 ferdi2 kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
    Feb 17 13:27:15 ferdi2 kernel: i915 0000:00:02.0: Resetting rcs0 after gpu hang
    Feb 17 13:27:23 ferdi2 kernel: i915 0000:00:02.0: Resetting rcs0 after gpu hang
    Feb 17 13:27:31 ferdi2 kernel: i915 0000:00:02.0: Resetting rcs0 after gpu hang
    Feb 17 13:27:39 ferdi2 kernel: i915 0000:00:02.0: Resetting rcs0 after gpu hang

    Feb 17 13:27:47 ferdi2 kernel: i915 0000:00:02.0: Resetting rcs0 after gpu hang


    Feb 17 13:27:47 ferdi2 su[18019]: pam_unix(su:session): session closed for user XYZ
    Feb 17 13:27:47 ferdi2 at-spi-bus-launcher[1978]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
    Feb 17 13:27:47 ferdi2 at-spi-bus-launcher[1978]:       after 46470 requests (46470 known processed) with 0 events remaining.
    Feb 17 13:27:47 ferdi2 pulseaudio[2060]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
    Feb 17 13:27:47 ferdi2 pulseaudio[2060]:       after 17 requests (17 known processed) with 0 events remaining.
    Feb 17 13:27:47 ferdi2 su[3603]: pam_unix(su:session): session closed for user XYZ
    Feb 17 13:27:47 ferdi2 su[17587]: pam_unix(su:session): session closed for user XYZ

system info::
    $ uname -a
    Linux ferdi2 4.15.0 #1 SMP Thu Feb 1 23:12:21 CET 2018 x86_64 GNU/Linux

    $ dpkg -l | grep mesa
    ii  libegl-mesa0:amd64                            17.3.3-1                              amd64        free implementation of the EGL API -- Mesa vendor library
    ii  libegl1-mesa:amd64                            17.3.3-1                              amd64        transitional dummy package
    ii  libgl1-mesa-dev:amd64                         17.3.3-1                              amd64        free implementation of the OpenGL API -- GLX development files
    ii  libgl1-mesa-dri:amd64                         17.3.3-1                              amd64        free implementation of the OpenGL API -- DRI modules
    ii  libgl1-mesa-glx:amd64                         17.3.3-1                              amd64        transitional dummy package
    ii  libglapi-mesa:amd64                           17.3.3-1                              amd64        free implementation of the GL API -- shared library
    ii  libgles2-mesa:amd64                           17.3.3-1                              amd64        transitional dummy package
    ii  libglu1-mesa:amd64                            9.0.0-2.1                             amd64        Mesa OpenGL utility library (GLU)
    ii  libglu1-mesa-dev:amd64                        9.0.0-2.1                             amd64        Mesa OpenGL utility library -- development files
    ii  libglx-mesa0:amd64                            17.3.3-1                              amd64        free implementation of the OpenGL API -- GLX vendor library
    ii  libosmesa6:amd64                              17.3.3-1                              amd64        Mesa Off-screen rendering extension
    ii  libwayland-egl1-mesa:amd64                    17.3.3-1                              amd64        implementation of the Wayland EGL platform -- runtime
    ii  mesa-common-dev:amd64                         17.3.3-1                              amd64        Developer documentation for Mesa
    ii  mesa-utils                                    8.3.0-5                               amd64        Miscellaneous Mesa GL utilities
    ii  mesa-va-drivers:amd64                         17.3.3-1                              amd64        Mesa VA-API video acceleration drivers
    ii  mesa-vdpau-drivers:amd64                      17.3.3-1                              amd64        Mesa VDPAU video acceleration drivers

    $ dpkg -l | grep xserver-xorg
    ii  xserver-xorg                                  1:7.7+19                              amd64        X.Org X server
    ii  xserver-xorg-core                             2:1.19.6-1                            amd64        Xorg X server - core server
    ii  xserver-xorg-input-all                        1:7.7+19                              amd64        X.Org X server -- input driver metapackage
    ii  xserver-xorg-input-libinput                   0.26.0-1                              amd64        X.Org X server -- libinput input driver
    ii  xserver-xorg-input-wacom                      0.34.99.1-1                           amd64        X.Org X server -- Wacom input driver
    ii  xserver-xorg-legacy                           2:1.19.6-1                            amd64        setuid root Xorg server wrapper
    ii  xserver-xorg-video-all                        1:7.7+19                              amd64        X.Org X server -- output driver metapackage
    ii  xserver-xorg-video-amdgpu                     1.4.0-1                               amd64        X.Org X server -- AMDGPU display driver
    ii  xserver-xorg-video-ati                        1:7.10.0-1                            amd64        X.Org X server -- AMD/ATI display driver wrapper
    ii  xserver-xorg-video-fbdev                      1:0.4.4-1+b5                          amd64        X.Org X server -- fbdev display driver
    ii  xserver-xorg-video-intel                      2:2.99.917+git20171229-1              amd64        X.Org X server -- Intel i8xx, i9xx display driver
    ii  xserver-xorg-video-nouveau                    1:1.0.15-2                            amd64        X.Org X server -- Nouveau display driver
    ii  xserver-xorg-video-qxl                        0.1.5-2                               amd64        X.Org X server -- QXL display driver
    ii  xserver-xorg-video-radeon                     1:7.10.0-1                            amd64        X.Org X server -- AMD/ATI Radeon display driver
    ii  xserver-xorg-video-vesa                       1:2.3.4-1+b2                          amd64        X.Org X server -- VESA display driver
    ii  xserver-xorg-video-vmware                     1:13.2.1-1+b1                         amd64        X.Org X server -- VMware display driver

    cpuinfo:
    cpu family      : 6
    model           : 142
    model name      : Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
    stepping        : 9
    microcode       : 0x7c
Comment 1 Kenneth Graunke 2018-02-17 21:10:40 UTC
Please try Mesa 17.3.4.
Comment 2 Simon 2018-02-21 21:37:08 UTC
Hopefully this may help.

I've had the same issue since an upgrade to Mesa 17.3.4. This was easily and consistently reproducible when using NetBeans 8.2, opening a file browser and clicking on an empty area of the horizontal scroll bar so as to get the file browser to jump further along the files list. Every time I tried this it would consistently cause the screen to hang, the mouse would work but nothing else responded. After a couple of minutes I would be dropped out of the desktop andf back to the login manager. Running dmesg gave me not much more than the following:

[ 5072.768779] [drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [11414], reason: Hang on rcs0, action: reset
[ 5072.768785] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[ 5086.777610] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[ 5096.761705] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[ 5104.761736] i915 0000:00:02.0: Resetting rcs0 after gpu hang
[ 5112.761783] i915 0000:00:02.0: Resetting rcs0 after gpu hang

I tried all of the Intel driver fixes posted around various forums across the internet but nothing worked, the only thing that has finally stopped this was downgrading to Mesa 17.3.2.

After the downgrade to Mesa 17.3.2 I can no longer reproduce this error. 

This is an Arch Linux system with the latest vanilla 4.14.20 kernel running the Plasma (KDE) desktop.
Comment 3 Simon 2018-02-21 22:02:21 UTC
Addendum to the above: 
Interestingly using Mesa 17.3.3-2 doesn't hang my system either, so for me at least something in 17.3.4 has actually caused the GPU to hang even when I have intel_iommu set to disabled.
Comment 4 Mark Janes 2018-02-21 23:28:08 UTC
Unfortunately, we've just realized that one of the fixes for GPU hangs could not be applied to the latest 17.3 release.  This issue is likely to be resolved in the 18.0 release candidate, and should be addressed in the next 17.3 release.

If you are able, please attempt to reproduce this on 18.0rc4, or mesa master.
Comment 5 GitLab Migration User 2019-09-25 19:08:42 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1690.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.