Bug 105169 - [kbl] GPU HANG: ecode 9:0:0x85df3cff caused by Mesa 17.3.4-1 (debian)
Summary: [kbl] GPU HANG: ecode 9:0:0x85df3cff caused by Mesa 17.3.4-1 (debian)
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-20 01:39 UTC by Theodore Ts'o
Modified: 2019-09-25 19:09 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Contents of /sys/class/drm/card0/error (48.20 KB, text/plain)
2018-02-20 01:39 UTC, Theodore Ts'o
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Theodore Ts'o 2018-02-20 01:39:01 UTC
Created attachment 137449 [details]
Contents of /sys/class/drm/card0/error

Kernel: 4.14.0-3-amd64 (debian) as well as 4.15.3+ext4 patches
Distribution: Debian testing
Hardware: 2018 XPS 13 (model 9370) with 4k display
Display connector: DisplayPort

Reproduced by: upgrading to the latest Mesa packages in Debian testing (17.3.4-1), and then starting emacs-x11.   Reverting to Mesa packages version 17.3.3-1 makes the problem go away.  J'accuse, libmesa!

Mesa packages involved (debian names):

libegl1-mesa_17.3.4-1_amd64.deb
libegl-mesa0_17.3.4-1_amd64.deb
libgbm1_17.3.4-1_amd64.deb
libgl1-mesa-dri_17.3.4-1_amd64.deb
libgl1-mesa-glx_17.3.4-1_amd64.deb
libglapi-mesa_17.3.4-1_amd64.deb
libglx-mesa0_17.3.4-1_amd64.deb
libwayland-egl1-mesa_17.3.4-1_amd64.deb
mesa-va-drivers_17.3.4-1_amd64.deb
mesa-vdpau-drivers_17.3.4-1_amd64.deb

Dmesg:

Feb 19 14:07:00 cwcc kernel: [ 1740.829003] [drm] GPU HANG: ecode 9:0:0x85df3cff, in Xorg [1098], reason: Hang on rcs0, action: reset
Feb 19 14:07:00 cwcc kernel: [ 1740.829111] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Feb 19 14:07:00 cwcc kernel: [ 1740.829112] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Feb 19 14:07:00 cwcc kernel: [ 1740.829113] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Feb 19 14:07:00 cwcc kernel: [ 1740.829114] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Feb 19 14:07:00 cwcc kernel: [ 1740.829115] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Feb 19 14:07:00 cwcc kernel: [ 1740.829123] i915 0000:00:02.0: Resetting rcs0 after gpu hang
Feb 19 14:07:08 cwcc kernel: [ 1748.819899] i915 0000:00:02.0: Resetting rcs0 after gpu hang

Note: also filed as Debian bug #890866
Comment 1 Elizabeth 2018-02-22 17:41:45 UTC
Hello Theodore, could you try mesa 18.0.0.rc4? I believe that this may be related to this issue: https://bugs.freedesktop.org/show_bug.cgi?id=104578#c18.
Comment 2 Theodore Ts'o 2018-02-24 19:31:31 UTC
I've been running 18.0.0~rc4-1 from Debian experimental and the problem seems to be resolved, thanks!

It also appears that the GPU hang was occasionally triggering on 17.3.3.  It's just hat 17.3.4 was causing emacs to be able to trigger it extremely reliably on my system.

I haven't seen any GPU hangs since installing 18.0.0-rc4, so I'm cautiously optimistic.

Thanks!!
Comment 3 Elizabeth 2018-03-14 23:05:02 UTC
Hello Theodore, were you able to verify that this issue was fixed by 18.0.0-rc4 at all?
Comment 4 GitLab Migration User 2019-09-25 19:09:28 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1693.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.