Bug 105189 - [CI] igt@kms_flip@(2x-)?flip-vs-expired-vblank(-interruptible)? - fail - Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
Summary: [CI] igt@kms_flip@(2x-)?flip-vs-expired-vblank(-interruptible)? - fail - Fail...
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 105707 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-21 11:43 UTC by Martin Peres
Modified: 2018-11-01 16:42 UTC (History)
2 users (show)

See Also:
i915 platform: BXT, CFL, GLK, HSW, SKL
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-02-21 11:43:14 UTC
(kms_flip:21732) CRITICAL: Test assertion failure function run_test_step, file kms_flip.c:711:
(kms_flip:21732) CRITICAL: Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
(kms_flip:21732) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest 2x-flip-vs-expired-vblank failed.

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4275/shard-hsw6/igt@kms_flip@2x-flip-vs-expired-vblank.html
Comment 1 Martin Peres 2018-02-21 17:16:40 UTC
Same error on the -interruptible version of the subtest:

(kms_flip:28103) CRITICAL: Test assertion failure function run_test_step, file kms_flip.c:711:
(kms_flip:28103) CRITICAL: Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
(kms_flip:28103) CRITICAL: Last errno: 4, Interrupted system call
Subtest 2x-flip-vs-expired-vblank-interruptible failed.

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4280/shard-hsw7/igt@kms_flip@2x-flip-vs-expired-vblank-interruptible.html
Comment 2 Martin Peres 2018-02-26 11:01:16 UTC
Also seen on APL

(kms_flip:2267) CRITICAL: Test assertion failure function run_test_step, file kms_flip.c:711:
(kms_flip:2267) CRITICAL: Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
(kms_flip:2267) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest flip-vs-expired-vblank failed.

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4293/shard-apl3/igt@kms_flip@flip-vs-expired-vblank.html
Comment 3 Marta Löfstedt 2018-04-17 10:40:25 UTC
*** Bug 105707 has been marked as a duplicate of this bug. ***
Comment 4 Martin Peres 2018-05-28 10:27:41 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_38/fi-glk-j4005/igt@kms_flip@flip-vs-expired-vblank.html

(kms_flip:1296) CRITICAL: Test assertion failure function run_test_step, file ../tests/kms_flip.c:711:
(kms_flip:1296) CRITICAL: Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
(kms_flip:1296) CRITICAL: Last errno: 25, Inappropriate ioctl for device


https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_39/fi-hsw-4770r/igt@kms_flip@flip-vs-expired-vblank.html

(kms_flip:1351) CRITICAL: Test assertion failure function run_test_step, file ../tests/kms_flip.c:711:
(kms_flip:1351) CRITICAL: Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
(kms_flip:1351) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest flip-vs-expired-vblank failed.


https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_43/fi-cfl-s3/igt@kms_flip@flip-vs-expired-vblank.html

(kms_flip:1607) CRITICAL: Test assertion failure function run_test_step, file ../tests/kms_flip.c:711:
(kms_flip:1607) CRITICAL: Failed assertion: timercmp(&reply.ts, &o->flip_state.last_ts, ==)
(kms_flip:1607) CRITICAL: Last errno: 25, Inappropriate ioctl for device
Subtest flip-vs-expired-vblank failed.
Comment 5 Martin Peres 2018-11-01 16:42:09 UTC
Used to happen every 10 runs, not seen since CI_DRM_4598_full (3 months / 1202 runs ago). Closing!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.