Bug 105203 - Update to 1.10.0 makes cursor "vibrate" when using touchpad
Summary: Update to 1.10.0 makes cursor "vibrate" when using touchpad
Status: RESOLVED DUPLICATE of bug 104828
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 08:20 UTC by Yvan Masson
Modified: 2018-02-23 22:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yvan Masson 2018-02-22 08:20:30 UTC
Hi,

I am using Debian testing on a Dell E7440, which just switched libinput from 1.9.4-2 to 1.10.0-1. When I touch the touchpad, without moving the finger, the cursor vibrates. It does not depend on the pressure. Cursor does not move much, but it makes it difficult to click on precise areas.

Do not hesitate to ask if you need more information.

Best regards,
Yvan

$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer:13                     	id=6	[slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:13            	id=7	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ xwayland-keyboard:13                    	id=8	[slave  keyboard (3)]

$ xinput list-props 2
Device 'Virtual core pointer':
	Device Enabled (119):	1
	Coordinate Transformation Matrix (121):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
$ xinput list-props 4
Device 'Virtual core XTEST pointer':
	Device Enabled (119):	1
	Coordinate Transformation Matrix (121):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	XTEST Device (238):	1
$ xinput list-props 6
Device 'xwayland-pointer:13':
	Device Enabled (119):	1
	Coordinate Transformation Matrix (121):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (244):	0
	Device Accel Constant Deceleration (245):	1.000000
	Device Accel Adaptive Deceleration (246):	1.000000
	Device Accel Velocity Scaling (247):	10.000000

$ udevadm info /sys/class/input/event2
P: /devices/platform/i8042/serio1/input/input2/event2
N: input/event2
S: input/by-path/platform-i8042-serio-1-event-mouse
E: DEVLINKS=/dev/input/by-path/platform-i8042-serio-1-event-mouse
E: DEVNAME=/dev/input/event2
E: DEVPATH=/devices/platform/i8042/serio1/input/input2/event2
E: ID_BUS=i8042
E: ID_INPUT=1
E: ID_INPUT_HEIGHT_MM=43
E: ID_INPUT_TOUCHPAD=1
E: ID_INPUT_TOUCHPAD_INTEGRATION=internal
E: ID_INPUT_WIDTH_MM=95
E: ID_PATH=platform-i8042-serio-1
E: ID_PATH_TAG=platform-i8042-serio-1
E: ID_SERIAL=noserial
E: LIBINPUT_DEVICE_GROUP=11/2/8:isa0060/serio1
E: LIBINPUT_MODEL_ALPS_TOUCHPAD=1
E: LIBINPUT_MODEL_FIRMWARE_VERSION=310
E: MAJOR=13
E: MINOR=66
E: SUBSYSTEM=input
E: USEC_INITIALIZED=50227224

$ cat /sys/class/dmi/id/modalias
dmi:bvnDellInc.:bvrA22:bd10/18/2017:svnDellInc.:pnLatitudeE7440:pvr00:rvnDellInc.:rn091TRH:rvrA00:cvnDellInc.:ct9:cvr:
Comment 1 Peter Hutterer 2018-02-22 22:30:35 UTC

*** This bug has been marked as a duplicate of bug 104828 ***
Comment 2 Yvan Masson 2018-02-23 16:49:44 UTC
Sorry for the duplicate, I just learnt the word "wobbly".

Thanks for the time and work,
Yvan
Comment 3 Peter Hutterer 2018-02-23 22:05:08 UTC
look for the term 'jitter' too, that's the more technical term. I just like "wobbly" :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.