Bug 105208 - [regression] (e5ff036c67 st/dri: Add support for BGR[A/X]1010102 formats) broke the mouse in mutter/shell
Summary: [regression] (e5ff036c67 st/dri: Add support for BGR[A/X]1010102 formats) bro...
Status: RESOLVED NOTOURBUG
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 12:31 UTC by Yanko Kaneti
Modified: 2018-03-16 16:54 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yanko Kaneti 2018-02-22 12:31:04 UTC
Bisected a problem with this commit

e5ff036c67 st/dri: Add support for BGR[A/X]1010102 formats

That broke the mouse input in mutter/shell in Fedora rawhide.

I am clueless as to why.

See:
https://bugzilla.redhat.com/show_bug.cgi?id=1547691
Comment 1 Daniel Stone 2018-02-22 13:01:38 UTC
The ultimate root cause is that Mutter expects all its configs are 8bpc, but asks EGL for 'anything at least 1bpc' through eglChooseConfigs, which is explicitly specified to return deeper channels if available; i.e. 10bpc must be preferred to 8bpc if available.

The way it handles mouse input is that it renders the scene with every surface as its own solid colour, reads back to find out what colour is at the current mouse position, and maps that back to a surface. It's unaware of 10bpc when doing so, and so the colour never matches back to any surface.

Since quite a few places are broken in the same way, I'm suspecting we should probably change the allow_rgb10_configs default to false, at least until we can get some of the worst offenders fixed.
Comment 2 Emil Velikov 2018-02-22 14:13:02 UTC
Marek put forward a request about fixing gnome-shell/mutter although it never got a reply from Dave or Jonas.

https://lists.freedesktop.org/archives/mesa-dev/2017-September/168921.html
Comment 3 Marek Olšák 2018-02-23 12:32:18 UTC
There is no need to disable 10bit support completely. We can add a workaround into drirc for gnome-shell and mutter.
Comment 4 Mario Kleiner 2018-02-24 16:32:44 UTC
Jonas has completed some work to fix this in Mutter:

https://gitlab.gnome.org/GNOME/mutter/issues/2

https://gitlab.gnome.org/GNOME/mutter/merge_requests/36
Comment 5 Yanko Kaneti 2018-03-16 16:54:57 UTC
As far as mutter/shell go this bug is fixed there. I'll close.

If somebody needs to continue the "flip the 10-bit default" discussion, perhaps its better if it continues somewhere else.

Thanks


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.