Bug 105213 - [SUMO][TURKS] Alien: Isolation rendering artifacts
Summary: [SUMO][TURKS] Alien: Isolation rendering artifacts
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact: Default DRI bug account
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-22 20:50 UTC by russianneuromancer
Modified: 2018-02-23 20:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Alien: Isolation rendering on TURKS with Mesa git (804.08 KB, image/png)
2018-02-22 20:50 UTC, russianneuromancer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description russianneuromancer 2018-02-22 20:50:40 UTC
Created attachment 137537 [details]
Alien: Isolation rendering on TURKS with Mesa git

Hi!

With Mesa 18.1~git180219165200.f78fe98 in Alien: Isolation there is rendering artifacts - please look into attached screenshot. Issue is reproducible on Radeon HD 6620G and 6650M. 
Graphical settings is all set to minimal, all visual effects is disabled.

Kubuntu 17.10 x86_64, Linux 4.15.5
Comment 1 russianneuromancer 2018-02-23 06:12:28 UTC
By the way this issue looks like bug 100387, but I not sure if cause is the same.
Comment 2 Gert Wollny 2018-02-23 09:06:11 UTC
On BARTS this looks fine with 4562a7b0e82bf664b30 (2018-02-23). Do you have any output from logs? On my Cedar based card I get "CS shader rejected" - and then the GPU to lock up (In any case, on that card even starting up the game is already only a slide show).
Comment 3 Gert Wollny 2018-02-23 09:20:31 UTC
I might have been wrong, it is certain that eb96ba722ee7 worked, but checking out above commit after following Darius Spitznagel hint [1]

Disable it in the prefereces file in ~/.local/share/feral-interactive/AlienIsolation like below...

<value name="EnableShaderWarmer" type="integer">0</value>

I wasn't even able to start the game, because I got an LLVM error. Will bisect now ...

[1] https://bugs.freedesktop.org/show_bug.cgi?id=104654#c8
Comment 4 Gert Wollny 2018-02-23 10:16:30 UTC
Well, after a clean reboot  4562a7b0e82bf664 works fine on BART. I guess the crash with the CEDAR card somehow triggered an instability that was responsible for the problems starting AI later (I use both cards in a dual head with separate X-screens setup).
Comment 5 russianneuromancer 2018-02-23 20:20:04 UTC
I retested game on Mesa build 4562a7b0e82bf664, this time with "MESA_GL_VERSION_OVERRIDE=4.3 MESA_GLSL_VERSION_OVERRIDE=430 %command%" launch option in Steam settings - issue is no longer reproducible.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.