Bug 105287 - X server requires "randrproto >= 1.6.0", but git head of randrproto is still at 1.5.0
Summary: X server requires "randrproto >= 1.6.0", but git head of randrproto is still ...
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: Other All
: high critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL: https://lists.x.org/archives/xorg-ann...
: 105295 (view as bug list)
Depends on:
Reported: 2018-02-28 10:28 UTC by Eero Tamminen
Modified: 2018-06-04 07:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Eero Tamminen 2018-02-28 10:28:19 UTC
X server requires randrproto >= 1.6.0:

However, latest available git version of randrproto is 1.5.0:

Comment 1 Michel Dänzer 2018-02-28 10:31:38 UTC
You need to use https://cgit.freedesktop.org/xorg/proto/xorgproto now.
Comment 2 Eero Tamminen 2018-02-28 11:28:54 UTC
I see.  Thanks.

Having pointer in randrproto git to newly required xorgproto (and nothing else), would have been helpful.

Xserver depending on specific version of xorgproto (which provides now all these headers), instead of there being separate pgkconfig file & check for each of the headers, would IMHO make this transition a lot clearer to everybody who doesn't follow X mailing lists.

(Google searches on randrproto 1.6 returning hits to Keith's patches, which update randrproto to 1.6.0 instead of xorgproto, does not help.)
Comment 3 Alan Coopersmith 2018-02-28 18:22:34 UTC
*** Bug 105295 has been marked as a duplicate of this bug. ***
Comment 4 David Ronis 2018-03-01 20:43:48 UTC
I built and installed xorgproto, reinstalled xserver and tried building.   I get the same error (in fact grepping the xerver tree for xorgproto trns up nothing).
Comment 5 markus 2018-06-02 18:21:13 UTC
I also get the same error; in fact this is why I logged in just now, after I tried to compile xorg-server and failed.

I built xorgproto-2018.4 into /usr/ prefix. No error was reported.

The comment by Michel Dänzer is appreciated but I do not think it is enough (to provide information as to what we have to do in order to compile it).

If randrproto is indeed outdated, yet xorgproto is the successor, then perhaps the configure check could prioritize on xorgproto, for systems where the user may have both randrproto and xorgproto compiled.
Comment 6 Eero Tamminen 2018-06-04 07:39:15 UTC
Check that it really got installed there and all expected files are there, and that you had configured your build environment so that X server configure finds them (check you config.log).

Xorgproto is the repository name, it provides exactly the same pkgconfig things as the separate projects did, as you can see:

(It's a great change, earlier there were a dozen different repos one needed to pull and build which was ridiculous as they each contained just a header, now one needs to pull & build just one repo to get up to date versions of those pkgconfig & header files.)

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.