Bug 1053 - Ugly artifacts when using composite with Openbox, Enlightenment, XFCE, FVWM
Summary: Ugly artifacts when using composite with Openbox, Enlightenment, XFCE, FVWM
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high blocker
Assignee: Xorg Project Team
QA Contact:
Depends on:
Blocks: 351
  Show dependency treegraph
Reported: 2004-08-11 21:05 UTC by Aaron Gyes
Modified: 2004-08-27 21:18 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

Screenshot (92.18 KB, image/jpeg)
2004-08-11 21:10 UTC, Aaron Gyes
no flags Details
Screenshot (enlightenment, ATI Radeon 9600) (107.18 KB, image/png)
2004-08-21 10:04 UTC, hiroki yumeta
no flags Details
Screenshot (XFCE4, Radeon) (44.72 KB, image/png)
2004-08-23 04:17 UTC, hiroki yumeta
no flags Details

Description Aaron Gyes 2004-08-11 21:05:40 UTC
This happens with both the proprietary NVIDIA drivers and the open source nv
driver. I get this after running xcompmgr -nc (or any other valid parameters).
It's mostly jumbled text, but there are other problems too. Screenshot attatched.
Comment 1 Aaron Gyes 2004-08-11 21:10:02 UTC
Created attachment 615 [details]
Comment 2 chris jones 2004-08-12 06:48:50 UTC
I have the same problem, using NVIDIA drivers. 
Comment 3 Aaron Gyes 2004-08-15 19:06:04 UTC
Looking further and talking to Keith on IRC I have discovered that this only
happens in OpenBox (3.2). Switching to MetaCity apparantly fixes it.
Comment 4 Aaron Plattner 2004-08-15 21:58:53 UTC
Same problem here, also using nvidia drivers and Openbox 3.2. 
Comment 5 hiroki yumeta 2004-08-21 10:04:13 UTC
Created attachment 701 [details]
Screenshot (enlightenment, ATI Radeon 9600)

I have the same problem, but I'm using [on both computers] ATI cards. One is
ATI mobility Radeon 9600, the other computer has an ATI Rage 128. In addition
to the artefacts (I have them in all WM's), I found another (maybe related)
error using Enlightenment. There when dragging the transparent window leaves a
kind of trace (can be seen on my screenshot).
Comment 6 hiroki yumeta 2004-08-22 05:46:38 UTC
I can confirm this bug for FVWM, Enlightenment, XFCE4, PWM, Waimea.
Comment 7 michal kaczmarski 2004-08-23 03:28:25 UTC
I have the same problem here :( with enlightenment 0.16.7 and nvidia drivers 6111
Comment 8 hiroki yumeta 2004-08-23 04:17:16 UTC
Created attachment 711 [details]
Screenshot (XFCE4, Radeon)

Excuse me, sending another screenshot, but I notices, that XFCE's panel is
affected, too. With the screenshot I hope you can see what happens, describing
it would be difficult.
Anyway, I made a mistake, PWM is NOT affected.
I hope this bug will get fixed °°
Comment 9 Jason Faulkner 2004-08-23 14:35:50 UTC
I can confirm this bug for FluxBox .9.9 -- right now I have it all disabled, so
no screenshot, but the menu does the same thing it does in the first screenshot,
among other things.
Comment 10 Adam Jackson 2004-08-24 15:31:47 UTC
bug #1095 may be related.  i dub thee a blocker.
Comment 11 Roc Vallès Domènech 2004-08-25 03:55:10 UTC
Happens with icewm here, also. (rc2, nvidia driver)
Comment 12 Niek v/d Maas 2004-08-27 03:20:53 UTC
I can confirm this with fluxbox 0.9.9.
It only happens when xcompmgr is running.
Comment 13 Eric Anholt 2004-08-27 14:13:05 UTC
Fluxbox was reported to be fixed with the fix to bug #1101, at least, so I'm
marking fixed this unless new information comes up.
Comment 14 Aaron Gyes 2004-08-27 22:00:23 UTC
That fixed the corruptions and such, but I still get some weirdness in Openbox
that I don't get in Metacity.

In metacity, if I run xcompmgr, all the current windows that are open will
instantly have shadows and all is good. In Openbox, all open windows will
dissapear. Their process is still running, but the windows do not appear in
tasklists and seemingly do not exist. Once I start up a few apps they will have
shadows and such. When I finally kill xcompmgr (I need to killall it because the
terminal I used to start it has "dissapeared") all the windows I opened since
starting xcompmgr will dissapear. The original windows from before running it 
are still lost.
Comment 15 hiroki yumeta 2004-08-28 14:12:40 UTC
well, the problem with the window borders is fixed (i just compiled the
cvs-version one hour ago). BUT i still have the same error with the XFCE4-Panel
(can be seen in my second (XFCE-) screenshot). Windows borders ok, XFCE-Panel not.
Is this problem related? or not? I think it's related...
Comment 16 hiroki yumeta 2004-08-28 14:18:18 UTC
ok. i just checked it with Enlightenment. and I still have the bug, that when
moving a window, it gets multiplied. so even if i move it i can see it where it
was before and where it is now. (@see my first/enlightenment-screenshot)
but window borders are OK.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.