Bug 105318 - [kbl] GPU HANG: ecode 9:0:0xfffffffe, in Compositor (Gnome!)
Summary: [kbl] GPU HANG: ecode 9:0:0xfffffffe, in Compositor (Gnome!)
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 17.3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: taijian
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-01 20:24 UTC by taijian
Modified: 2018-03-12 18:11 UTC (History)
2 users (show)

See Also:
i915 platform: KBL
i915 features: GPU hang


Attachments
gpu crash dump (44.69 KB, text/plain)
2018-03-01 20:24 UTC, taijian
Details
relevant dmesg output (79.96 KB, text/plain)
2018-03-01 20:24 UTC, taijian
Details
relevant output of #lspci -vv (41.34 KB, text/plain)
2018-03-01 20:26 UTC, taijian
Details
relevant glxinfo (25.22 KB, text/plain)
2018-03-02 19:32 UTC, taijian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description taijian 2018-03-01 20:24:25 UTC
Created attachment 137734 [details]
gpu crash dump

While trying to debug #104064 I came across a gpu hang issue. Dmesg output instructed me to open a new bug here, so that's what I'm doing. The gpu crash dump is attached here, dmesg and lspci follow.

I have seen #104545 and my linux-firmware does include the patch mentioned there, however, the bug is still happening.
Comment 1 taijian 2018-03-01 20:24:59 UTC
Created attachment 137735 [details]
relevant dmesg output
Comment 2 taijian 2018-03-01 20:26:03 UTC
Created attachment 137736 [details]
relevant output of #lspci -vv
Comment 3 Mark Janes 2018-03-02 16:54:21 UTC
please verify that you are using mesa 17.3.6, or mark as a duplicate of 104411.
Comment 4 taijian 2018-03-02 19:32:05 UTC
Created attachment 137760 [details]
relevant glxinfo

Yeah, I am on 17.3.6, so the fix you mentioned in the other thread does not fix this.

However, this bug only occurs under *very* specific circumstances, please see in this bug report: https://bugs.freedesktop.org/show_bug.cgi?id=104064, specifically post https://bugs.freedesktop.org/show_bug.cgi?id=104064#c24.

Maybe you guys could team up with the AMD people to figure out which module this belongs to?
Comment 5 taijian 2018-03-12 18:11:23 UTC
OK, seems that a combination of what Harry from AMD did to their kernel driver and the update to mesa 18.1-git solved this, so closing...


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.