Bug 105456 - [CI][SHARDS] igt@kms_panel_fitting@* - fail - Test assertion failure function igt_display_commit_atomic -Failed assertion: ret == 0
Summary: [CI][SHARDS] igt@kms_panel_fitting@* - fail - Test assertion failure function...
Status: REOPENED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Maarten Lankhorst
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-12 11:58 UTC by Marta Löfstedt
Modified: 2019-04-29 08:02 UTC (History)
1 user (show)

See Also:
i915 platform: BXT, CFL, CNL, GLK, ILK, KBL, SKL
i915 features: display/atomic


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2018-03-12 11:58:04 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-drrs/igt@kms_panel_fitting@atomic-fastset.html
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3903/fi-cnl-y3/igt@kms_panel_fitting@atomic-fastset.html
	

(kms_panel_fitting:2915) igt-kms-CRITICAL: Test assertion failure function igt_display_commit_atomic, file igt_kms.c:3121:
(kms_panel_fitting:2915) igt-kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:2915) igt-kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:2915) igt-kms-CRITICAL: error: -22 != 0
Subtest atomic-fastset failed.
Comment 1 Marta Löfstedt 2018-03-13 07:02:22 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_3915/shard-glkb4/igt@kms_panel_fitting@legacy.html

(kms_panel_fitting:2153) igt_kms-CRITICAL: Test assertion failure function igt_primary_plane_commit_legacy, file ../lib/igt_kms.c:2498:
(kms_panel_fitting:2153) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:2153) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:2153) igt_kms-CRITICAL: error: -22 != 0
Subtest legacy failed.
Comment 2 Marta Löfstedt 2018-03-13 07:16:02 UTC
This looks like the first occurrence on the GLK issue:

https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4349/shard-glkb2/igt@kms_panel_fitting@legacy.html

IGT-Version: 1.22-g8732f0ac (x86_64) (Linux: 4.16.0-rc4-CI-CI_DRM_3911+ x86_64)

it passed on:
IGT-Version: 1.22-g7da16024 (x86_64) (Linux: 4.16.0-rc4-CI-CI_DRM_3911+ x86_64)

this patch was for example merged:
commit 3df9f713602342d13a7b4cf6873addd2105b8153
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Thu Feb 22 13:37:10 2018 +0100

    tests/kms_panel_fitting: Test cleanups.
Comment 3 Maarten Lankhorst 2018-03-13 09:30:15 UTC
I can only say that kms_panel_fitting.legacy as it is now is supposed to fail on GLK. The test is trying to use panel fitting and scaling on pipe C, which is not allowed because they have to share scalers. On other pipes for gen9 there are always 2 scalers, but pipe C has one.

I have no idea why this was working before, but it shouldn't have been.

atomic-fastset fails because of confusion between modes:
https://patchwork.freedesktop.org/series/39841/
Comment 4 Marta Löfstedt 2018-03-15 14:16:59 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-cfl-s2/igt@kms_panel_fitting@legacy.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-cfl-u/igt@kms_panel_fitting@legacy.html


(kms_panel_fitting:2840) igt_kms-CRITICAL: Test assertion failure function igt_primary_plane_commit_legacy, file ../lib/igt_kms.c:2498:
(kms_panel_fitting:2840) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:2840) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:2840) igt_kms-CRITICAL: error: -22 != 0
Subtest legacy failed.
Comment 5 Marta Löfstedt 2018-03-16 07:44:18 UTC
More data coming from shards testlist run on BAT machines:

(kms_panel_fitting:3019) igt_kms-CRITICAL: Test assertion failure function igt_primary_plane_commit_legacy, file ../lib/igt_kms.c:2498:
(kms_panel_fitting:3019) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:3019) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:3019) igt_kms-CRITICAL: error: -22 != 0
Subtest legacy failed.

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-bxt-dsi/igt@kms_panel_fitting@legacy.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-glk-1/igt@kms_panel_fitting@legacy.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-kbl-r/igt@kms_panel_fitting@legacy.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6600u/igt@kms_panel_fitting@legacy.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-skl-6700hq/igt@kms_panel_fitting@legacy.html
Comment 6 Marta Löfstedt 2018-03-19 08:14:31 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_2/fi-ilk-m540/igt@kms_panel_fitting@atomic-fastset.html

(kms_panel_fitting:2162) igt_kms-CRITICAL: Test assertion failure function igt_display_commit_atomic, file ../lib/igt_kms.c:3122:
(kms_panel_fitting:2162) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:2162) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:2162) igt_kms-CRITICAL: error: -22 != 0
Subtest atomic-fastset failed.
Comment 7 Marta Löfstedt 2018-03-20 11:52:17 UTC
https://patchwork.freedesktop.org/patch/210589/
Comment 8 Marta Löfstedt 2018-03-27 10:03:00 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_7/fi-cfl-s3/igt@kms_panel_fitting@legacy.html

(kms_panel_fitting:1790) igt_kms-CRITICAL: Test assertion failure function igt_primary_plane_commit_legacy, file ../lib/igt_kms.c:2601:
(kms_panel_fitting:1790) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:1790) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:1790) igt_kms-CRITICAL: error: -22 != 0
Subtest legacy failed.
Comment 9 Maarten Lankhorst 2018-05-24 09:05:13 UTC
commit 8a26e0e9d99c7f1231250471d11f7decb0ad3d99 (HEAD, origin/master, origin/HEAD)
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Wed Mar 14 11:47:30 2018 +0100

    tests/kms_panel_fitting: Make test pass on gen9's pipe C
Comment 10 Martin Peres 2018-06-14 14:44:23 UTC
(In reply to Maarten Lankhorst from comment #9)
> commit 8a26e0e9d99c7f1231250471d11f7decb0ad3d99 (HEAD, origin/master,
> origin/HEAD)
> Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
> Date:   Wed Mar 14 11:47:30 2018 +0100
> 
>     tests/kms_panel_fitting: Make test pass on gen9's pipe C

Sorry for the delay. The problems have not been fixed and are still visible every single run...

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_62/fi-skl-6600u/igt@kms_panel_fitting@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_62/fi-bxt-dsi/igt@kms_panel_fitting@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_62/fi-cfl-s3/igt@kms_panel_fitting@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_62/fi-cfl-u2/igt@kms_panel_fitting@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_62/fi-kbl-7560u/igt@kms_panel_fitting@legacy.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_62/fi-kbl-r/igt@kms_panel_fitting@legacy.html

(kms_panel_fitting:2930) igt_kms-CRITICAL: Test assertion failure function igt_primary_plane_commit_legacy, file ../lib/igt_kms.c:2701:
(kms_panel_fitting:2930) igt_kms-CRITICAL: Failed assertion: ret == 0
(kms_panel_fitting:2930) igt_kms-CRITICAL: Last errno: 22, Invalid argument
(kms_panel_fitting:2930) igt_kms-CRITICAL: error: -22 != 0
Comment 11 Maarten Lankhorst 2018-08-29 11:27:39 UTC

*** This bug has been marked as a duplicate of bug 106606 ***
Comment 12 Martin Peres 2018-09-07 17:34:59 UTC
(In reply to Maarten Lankhorst from comment #11)
> 
> *** This bug has been marked as a duplicate of bug 106606 ***

Are they really the same issue? :o
Comment 13 Lakshmi 2018-10-23 12:40:55 UTC
Closed as duplicate.
Comment 14 Martin Peres 2019-03-08 15:49:01 UTC
(In reply to Martin Peres from comment #12)
> (In reply to Maarten Lankhorst from comment #11)
> > 
> > *** This bug has been marked as a duplicate of bug 106606 ***
> 
> Are they really the same issue? :o

Reopening since we did not get any answer and the duplication makes no sense to me.
Comment 15 CI Bug Log 2019-04-18 09:04:12 UTC
A CI Bug Log filter associated to this bug has been updated:

{- all machines: igt@kms_panel_fitting@(legacy|atomic-fastest) - Test assertion failure function legacy/atomic Failed assertion: ret == 0 -}
{+ all machines: igt@kms_panel_fitting@(legacy|atomic-fastest) - fail/dmesg-fail Test assertion failure function legacy/atomic Failed assertion: ret == 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_256/fi-hsw-peppy/igt@kms_panel_fitting@legacy.html
Comment 16 Martin Peres 2019-04-23 12:58:46 UTC
Bumping the priority since this happens also on shards!
Comment 17 CI Bug Log 2019-04-23 13:04:33 UTC
A CI Bug Log filter associated to this bug has been updated:

{- all machines: igt@kms_panel_fitting@(legacy|atomic-fastest) - fail/dmesg-fail Test assertion failure function legacy/atomic Failed assertion: ret == 0 -}
{+ ILK BYT BSW HSW SKL BXT KBL CFL GLK WHL: igt@kms_panel_fitting@(legacy|atomic-fastest) - fail/dmesg-fail Test assertion failure function legacy/atomic Failed assertion: ret == 0 +}

 No new failures caught with the new filter
Comment 18 CI Bug Log 2019-04-29 08:02:33 UTC
A CI Bug Log filter associated to this bug has been updated:

{- ILK BYT BSW HSW SKL BXT KBL CFL GLK WHL: igt@kms_panel_fitting@(legacy|atomic-fastest) - fail/dmesg-fail Test assertion failure function legacy/atomic Failed assertion: ret == 0 -}
{+ ILK BYT BSW HSW SKL BXT KBL CFL GLK CML WHL: igt@kms_panel_fitting@(legacy|atomic-fastest) - fail/dmesg-fail Test assertion failure function legacy/atomic Failed assertion: ret == 0 +}

New failures caught by the filter:

  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_266/fi-cml-u/igt@kms_panel_fitting@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_267/fi-cml-u/igt@kms_panel_fitting@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_268/fi-cml-u/igt@kms_panel_fitting@legacy.html
  * https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_269/fi-cml-u/igt@kms_panel_fitting@legacy.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.