Bug 105568 - [HD 4000, Mesa 18]: TrackMania Nations Forever in Wine spams "GL_INVALID_OPERATION in glUseProgram(program 60 not linked)" after upgrade from Mesa 17.2.2 to 18.0-rc4
Summary: [HD 4000, Mesa 18]: TrackMania Nations Forever in Wine spams "GL_INVALID_OPER...
Status: RESOLVED DUPLICATE of bug 105426
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL: http://store.steampowered.com/app/110...
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-03-16 22:49 UTC by QwertyChouskie
Modified: 2018-04-07 20:35 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description QwertyChouskie 2018-03-16 22:49:44 UTC
After upgrading to Ubuntu 18.04 (with Mesa 18.0-rc4) from Ubuntu 17.10 (with Mesa 17.2.2), TrackMania Nations Forever causes the following errors to be spammed:

0097:err:d3d:wined3d_debug_callback 0x1add58: "GL_INVALID_OPERATION in glGetUniformLocation(program not linked)".

and

0097:err:d3d:wined3d_debug_callback 0x1add58: "GL_INVALID_OPERATION in glUseProgram(program 60 not linked)".

This causes small graphics glitches with a lower shader model set in the game's options, and just a black screen with cursor in a higher shader model selected.

Ubuntu 18.04 (beta), upgraded from 17.10
Linux 4.15
Mesa 18.0-rc4
Intel HD 4000, i5-3340M
Wine-staging 3.3 from https://repos.wine-staging.com/alesliehughes/
Steam version of game (http://store.steampowered.com/app/11020/TrackMania_Nations_Forever/), though also can be downloaded from http://trackmaniaforever.com/nations/

lshw:

 *-cpu
      description: CPU
      product: Intel(R) Core(TM) i5-3340M CPU @ 2.70GHz
      vendor: Intel Corp.
      physical id: 27
      bus info: cpu@0
      version: Intel(R) Core(TM) i5-3340M CPU @ 2.70GHz
      slot: SOCKET 0
      size: 1578MHz
      capacity: 3800MHz
      width: 64 bits
      clock: 100MHz
      capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts cpufreq
      configuration: cores=2 enabledcores=2 threads=4
Comment 1 Tapani Pälli 2018-03-19 07:14:05 UTC
Mesa 17.2 -> 18.0 is pretty big jump, any chance you could try if 17.3 release works or bisect the failure? Problem clearly is that some shader program fails to link.
Comment 2 vono 2018-03-19 19:04:29 UTC
Hi,

I have the same problem with World Of Warcraft, also on Ubuntu Bionic Beaver 18.04 LTS amd64 (beta), but with an Radeon RX-560:

0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glGetUniformLocation(program not linked)".
message repeated 487 times: [ 0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glGetUniformLocation(program not linked)".]
0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glUseProgram(program 6 not linked)".
0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glGetUniformLocation(program not linked)".
message repeated 11 times: [ 0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glGetUniformLocation(program not linked)".]
0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glUseProgram(program 6 not linked)".
0039:err:d3d:wined3d_debug_callback 0x177338: "GL_INVALID_OPERATION in glGetUniformLocation(program not linked)".
[...] 273250 more lines like theses follows in syslog.

On this game I simply don't see some models (seems to be the MD2 based one) like characters/game objects...

glxInfo:
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: Radeon RX 560 Series (POLARIS11 / DRM 3.23.0 / 4.15.0-12-generic, LLVM 5.0.1) (0x67ff)
    Version: 18.0.0
    Accelerated: yes
    Video memory: 4065MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 4065 MB, largest block: 4065 MB
    VBO free aux. memory - total: 4092 MB, largest block: 4092 MB
    Texture free memory - total: 4065 MB, largest block: 4065 MB
    Texture free aux. memory - total: 4092 MB, largest block: 4092 MB
    Renderbuffer free memory - total: 4065 MB, largest block: 4065 MB
    Renderbuffer free aux. memory - total: 4092 MB, largest block: 4092 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 4065 MB
    Total available memory: 8159 MB
    Currently available dedicated video memory: 4065 MB
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 560 Series (POLARIS11 / DRM 3.23.0 / 4.15.0-12-generic, LLVM 5.0.1)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.0-rc4
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

lshw:
     *-cpu
          product: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
          vendor: Intel Corp.
          physical id: 1
          bus info: cpu@0
          size: 1875MHz
          capacity: 2668MHz
          width: 64 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm pti tpr_shadow vnmi flexpriority ept vpid dtherm ida cpufreq


Note: On my stable OS (Ubuntu 16.04 LTS amd64), this bug do not exists.
Downgrading to Mesa 17.* on Ubuntu 18.04 ... is complicated!
Comment 3 vono 2018-03-19 19:21:38 UTC
Probably a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=105426
Comment 4 vono 2018-03-22 19:07:32 UTC
It is fixed for me with mesa 18.0.0-rc5
Comment 5 Tapani Pälli 2018-03-23 06:04:57 UTC
Thanks for testing, assuming duplicate for bug #105426

*** This bug has been marked as a duplicate of bug 105426 ***
Comment 6 QwertyChouskie 2018-04-07 20:35:28 UTC
Confirmed fixed in 18.0-rc5.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.