Bug 105581 - [CI] igt@kms_plane_lowres@pipe-[a|b]-tiling-[none|x] - fail - Test assertion failure function igt_assert_plane_visible - Failed assertion: visible == visibility
Summary: [CI] igt@kms_plane_lowres@pipe-[a|b]-tiling-[none|x] - fail - Test assertion ...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-19 06:58 UTC by Marta Löfstedt
Modified: 2019-11-13 16:18 UTC (History)
2 users (show)

See Also:
i915 platform: BYT, SNB
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2018-03-19 06:58:46 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-snb-2520m/igt@kms_plane_lowres@pipe-b-tiling-x.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-snb-2520m/igt@kms_plane_lowres@pipe-b-tiling-none.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-snb-2520m/igt@kms_plane_lowres@pipe-a-tiling-x.html
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_1/fi-snb-2520m/igt@kms_plane_lowres@pipe-a-tiling-none.html


(kms_plane_lowres:1723) igt_kms-CRITICAL: Test assertion failure function igt_assert_plane_visible, file ../lib/igt_kms.c:1603:
(kms_plane_lowres:1723) igt_kms-CRITICAL: Failed assertion: visible == visibility
(kms_plane_lowres:1723) igt_kms-CRITICAL: Last errno: 9, Bad file descriptor
(kms_plane_lowres:1723) igt_kms-CRITICAL: error: 1 != 0
Subtest pipe-B-tiling-x failed.
Comment 3 Martin Peres 2018-09-14 12:32:38 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_110/fi-snb-2520m/igt@kms_plane_lowres@pipe-a-tiling-x.html

Starting subtest: pipe-A-tiling-x
(kms_plane_lowres:1130) igt_kms-CRITICAL: Test assertion failure function igt_assert_plane_visible, file ../lib/igt_kms.c:1626:
(kms_plane_lowres:1130) igt_kms-CRITICAL: Failed assertion: visible == visibility
(kms_plane_lowres:1130) igt_kms-CRITICAL: Last errno: 9, Bad file descriptor
(kms_plane_lowres:1130) igt_kms-CRITICAL: error: 1 != 0
Subtest pipe-A-tiling-x failed.

<3> [79.466838] [drm:drm_crtc_add_crc_entry] *ERROR* Overflow of CRC buffer, userspace reads too slow.
Comment 4 Matt Roper 2019-08-19 23:26:24 UTC
This test puts a canary plane in the bottom left corner of the screen, then switches to a smaller mode in which the plane is now fully offscreen; if the driver still reports the plane as on-screen after the modeset then the test fails.

I believe the failures here arise from test's fallback logic when it can't find a suitable mode on the connector's modelist (e.g., because it's something like an eDP panel that only has a single mode listed) --- the test uses a fixed 1024x768 mode in that case.  However the test doesn't actually check to ensure 1024x768 is truly small enough to ensure the plane is offscreen.  If the panel was originally running with something like 1366x768 (which some of our CI machines are), then a plane in the bottom left corner will still be visible after switching to 1024x768.

I'm testing out a possible fix on trybot; will update tomorrow if it actually solves the problem here.
Comment 5 Matt Roper 2019-08-21 16:21:11 UTC
Proposed fix was submitted here:

https://patchwork.freedesktop.org/series/65485/#rev1
Comment 6 Mika Kahola 2019-08-27 10:39:26 UTC
Back in the day, when the test was written, there were no real reason why 1024x768 resolution was selected. It was readily available in igt_kms.c as a function and the same resolution were used in other tests as well. 

We could easily use smaller 640x480 resolution, which should be small enough that most of the problematic platforms would be tested instead of skipping. However, this doesn't change the fact that we should test if the resolution is small enough to ensure the plane will be offscreen.
Comment 7 Matt Roper 2019-08-30 23:04:03 UTC
Fix merged.
Comment 8 swathi.dhanavanthri 2019-11-13 16:18:40 UTC
reproduction rate was 100% 2 months 2 weeks ago(drmtip 354), not seen in the last 46 runs, so archiving this
Comment 9 CI Bug Log 2019-11-13 16:18:53 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.