Bug 105626 - [GT218][Regression] BUG: unable to handle kernel NULL pointer dereference at 0000000000000040
Summary: [GT218][Regression] BUG: unable to handle kernel NULL pointer dereference at ...
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Nouveau Project
QA Contact: Xorg Project Team
Depends on:
Reported: 2018-03-20 14:28 UTC by Philip Raets
Modified: 2019-12-04 09:37 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:

journalctl (80.64 KB, text/x-log)
2018-03-20 14:28 UTC, Philip Raets
no flags Details
dmesg (60.90 KB, text/plain)
2018-03-22 14:49 UTC, Philip Raets
no flags Details

Description Philip Raets 2018-03-20 14:28:53 UTC
Created attachment 138225 [details]

Nouveau crashes from time to time, it happens when I open some jpg-files, tiff-files, when I maximize windows, when I am developing in Android Studio, ... It happens randomly, but a few times a day. I can login with ssh through my phone (because my desktop is not responding to anything, I can only move the mouse cursor around), and then force a reboot (which I don't like, because of running virtual machines and unsaved work)

I've tried the patched kernel from openSUSE, but it still crashes.

My system is an up to date openSUSE Tumbleweed x86_64

Attached is my last boot log from "journalctl -k -b -1"


Comment 2 Takashi Iwai 2018-03-20 14:39:16 UTC
The tested kernel already contains the mentioned fix.
This bug was created newly just because it asked so there.
Comment 3 Takashi Iwai 2018-03-20 14:40:14 UTC
(In reply to Takashi Iwai from comment #2)
> This bug was created newly just because it asked so there.

Err, I meant, this bug entry was created newly just because it was asked so in Bug 105174.
Comment 4 Philip Raets 2018-03-22 14:49:30 UTC
Created attachment 138286 [details]

Today I installed kernel 4.16rc6 from opensuse Kernel Head, but my desktop already froze 5 times today.

Attached is dmesg log
Comment 5 Pierre Moreau 2018-03-22 15:07:45 UTC
I’ll try to reproduce on my Tesla cards during the weekend (if I manage to solve some other issues first).
Are you using X or Wayland?
Comment 6 Philip Raets 2018-03-22 15:58:36 UTC
I am using X

praets@PRAETS:~> loginctl show-session 1 -p Type
Comment 7 Pierre Moreau 2018-03-26 11:08:58 UTC
I don’t have a GT218 to try on, and my tests on a GT200 were not conclusive as I was unable to reproduce the bug; I tried opening a bunch of windows, resize and maximize them, open some png files and run OpenGL games.
I’ll try to look at the patches that were merged in 4.15, see if I can spot an error there, but I won’t be able to help much more than that. If you could bisect the kernel to identify the faulty commit, that would be really helpful.
Comment 8 Philip Raets 2018-03-27 08:48:08 UTC
I updated tumbleweed to snapshot 20180324 (https://lists.opensuse.org/opensuse-factory/2018-03/msg00615.html) which contains updates for Mesa and I've updated the kernel to the latest build on openSUSE:

praets@PRAETS:~> uname -a
Linux PRAETS.boma.local 4.16.0-rc6-3.g2539ea5-default #1 SMP PREEMPT Sun Mar 25 11:36:35 UTC 2018 (2539ea5) x86_64 x86_64 x86_64 GNU/Linux

So far I haven't had any crashes anymore, tried opening a lot of photo's, switching windows, maximizing windows, ... 

So far so good
Comment 9 Martin Peres 2019-12-04 09:37:04 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/driver/xf86-video-nouveau/issues/413.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.