Bug 105655 - [GLK] HDMI hotplug between 4K@60 and 4K@30 monitors *ERROR* Failed to read TMDS config: -6 & *ERROR* Set TMDS ratio failed
Summary: [GLK] HDMI hotplug between 4K@60 and 4K@30 monitors *ERROR* Failed to read TM...
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-21 10:41 UTC by Antony Chen
Modified: 2018-05-08 06:44 UTC (History)
3 users (show)

See Also:
i915 platform: GLK
i915 features: display/HDMI


Attachments
dmesg with drm.debug=0xe (128.45 KB, text/plain)
2018-03-22 12:03 UTC, Antony Chen
no flags Details
dmesg when unplug and plug HDMI cable (156.72 KB, text/plain)
2018-04-20 11:14 UTC, Antony Chen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antony Chen 2018-03-21 10:41:41 UTC
Environment:
Mainboard: Intel RVB
BIOS: AMI
OS: Ubuntu 17.10
Monitors: ViewSonic VP2780-4K (A), ASUS PB287Q (B)
TV: LG 49UJ630T (C)

A and C support 4K@60, B support 4K@30

My steps:
1. Plug A or C and bootup
2. After OS finishes booting, unplug HDMI cable in console mode
Then dmesg shows the error messages:
[drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read TMDS config: -6
[drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed

3. Plug B
Then there is not signal to B, and dmesg shows the error messages above again.

4. Unplug B and Plug A or C, then A or C display normally.


I also do some tests when I start X:
1. Plug A and bootup
2. sudo xinit
3. unplug HDMI cable and plug B, there is not signal to B
4. xrandr --output HDMI1 --off
Then dmesg shows the error messages:
[drm:drm_scdc_set_high_tmds_clock_ratio [drm_kms_helper]] *ERROR* Failed to read TMDS config: -6
[drm:intel_hdmi_handle_sink_scrambling [i915]] *ERROR* Set TMDS ratio failed

5. xrandr --output HDMI1 --auto
Then there is not signal to B, and dmesg shows the error messages above again.

In the second testing, if I use C to replace A, then there IS signal to B in the 5th step.
Comment 1 Antony Chen 2018-03-21 10:45:08 UTC
AMI BIOS version: 5.13_VEB_1AUAJ018
Comment 2 Elizabeth 2018-03-21 15:21:18 UTC
Hi, could you attach full dmesg with drm.debug=0xe parameter on grub, from boot and with the error messages captured? Thank you.
Comment 3 Antony Chen 2018-03-22 12:03:17 UTC
Created attachment 138280 [details]
dmesg with drm.debug=0xe
Comment 4 Antony Chen 2018-03-22 12:05:00 UTC
Unplug HDMI cable (ViewSonic VP2780-4K (A)) on the 105 second.
Plug HDMI cable (ASUS PB287Q (B)) on the 128 second.
Comment 5 Jani Saarinen 2018-03-22 13:29:44 UTC
Reference: https://patchwork.freedesktop.org/patch/212118/
Comment 6 Jani Saarinen 2018-03-26 10:34:19 UTC
Looks same as in bugs.freedesktop.org/show_bug.cgi?id=105644
Comment 7 Jani Saarinen 2018-03-29 07:11:43 UTC
First of all. Sorry about spam.
This is mass update for our bugs. 

Sorry if you feel this annoying but with this trying to understand if bug still valid or not.
If bug investigation still in progress, please ignore this and I apologize!

If you think this is not anymore valid, please comment to the bug that can be closed.
If you haven't tested with our latest pre-upstream tree(drm-tip), can you do that also to see if issue is valid there still and if you cannot see issue there, please comment to the bug.
Comment 8 Antony Chen 2018-03-30 02:39:40 UTC
It still shows the same error messages after patching from comment 5.
And there is still no signal to the 4K@30 monitor after the steps.
Comment 9 Antony Chen 2018-04-20 02:24:38 UTC
The last drm I used is: drm-intel-next-2018-02-21, with Kernel 4.14.14
Comment 10 Jani Saarinen 2018-04-20 05:46:44 UTC
HI, fix was merged to drm-tip: https://cgit.freedesktop.org/drm-tip/commit/?id=277ab5abc68df2f6f8fac7a46e50105b6648f432

Please try that out. After this not seen on CI. See: https://bugs.freedesktop.org/show_bug.cgi?id=105644

*** This bug has been marked as a duplicate of bug 105644 ***
Comment 11 Jani Saarinen 2018-04-20 10:58:46 UTC
Closing, please re-open if seeing issues still.
Comment 12 Antony Chen 2018-04-20 11:11:25 UTC
I use the last drm-tip today, there is still no signal on monitor B:
Monitor A support 4K@60
Monitor B support 4K@30

My steps:
1. Plug A and bootup
2. After OS finishes booting, unplug HDMI cable in console mode
3. Plug B
=> There is no signal on monitor B.
Comment 13 Antony Chen 2018-04-20 11:14:27 UTC
Created attachment 138947 [details]
dmesg when unplug and plug HDMI cable

Unplug HDMI cable on the 74 second, and plug it on the 91 second.
Comment 14 Jani Saarinen 2018-04-24 07:15:20 UTC
And you added logs from those plug-ins / out's with full dmesg with drm.debug=0xe?

Ville, any advice here?
Comment 15 Ville Syrjala 2018-04-25 14:09:51 UTC
Fixed with

commit 7c7163c4f94198c595e640669954c8a1a292c506
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Tue Apr 24 16:02:50 2018 +0300

    drm/edid: Reset more of the display info
Comment 16 Jani Saarinen 2018-04-26 07:11:43 UTC
Reporter, please verify.
Comment 17 Jani Saarinen 2018-04-26 10:48:28 UTC
Thanks, closing.
Comment 18 Piotr Kasp. 2018-05-07 14:23:35 UTC
its looks like is not fully fixed, when you trying inject EDID same error appear

here full log on drm-tip from yesterday
http://ix.io/19FZ
Comment 19 Ville Syrjala 2018-05-07 14:45:02 UTC
(In reply to Piotr Kasp. from comment #18)
> its looks like is not fully fixed, when you trying inject EDID same error
> appear

If you inject a HDMI 2.0 EDID on a 1.x display you will get this. Totally expected.
Comment 20 Piotr Kasp. 2018-05-07 14:47:22 UTC
that HDMI 2.0 and cable HDMI 2.0 and NUC gemmini lake with HDMI 2.0

TV Samsung QLED 4k HDR, Q7
Comment 21 Ville Syrjala 2018-05-07 14:55:08 UTC
(In reply to Piotr Kasp. from comment #20)
> that HDMI 2.0 and cable HDMI 2.0 and NUC gemmini lake with HDMI 2.0
> 
> TV Samsung QLED 4k HDR, Q7

Hmm. Looks like a broken display and/or flaky connection then.
Comment 22 Piotr Kasp. 2018-05-07 14:56:30 UTC
on kaby lake works fine, and if I'm not trying inject EDID also I didn't getting this issue. so are we sure ?
Comment 23 Piotr Kasp. 2018-05-07 15:01:17 UTC
here log with same setup TV, cables, kernel version - just not incjecting EDID
http://ix.io/19FW

(there is other issue already raported but like you see issue *ERROR* Failed to read TMDS is not appear)
Comment 24 Ville Syrjala 2018-05-07 15:03:47 UTC
(In reply to Piotr Kasp. from comment #23)
> here log with same setup TV, cables, kernel version - just not incjecting
> EDID
> http://ix.io/19FW

Attach the logs pls.

> 
> (there is other issue already raported but like you see issue *ERROR* Failed
> to read TMDS is not appear)

KBL doesn't support HDMI 2.0 natively, so it won't be taking this codepath.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.