Bug 105675 - Lenovo Yoga 11S touchpad is numb and unresponsive with libinput 1.10.3
Summary: Lenovo Yoga 11S touchpad is numb and unresponsive with libinput 1.10.3
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-22 03:41 UTC by Daniel van Vugt
Modified: 2018-04-09 05:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel van Vugt 2018-03-22 03:41:55 UTC
Lenovo Yoga 11S touchpad is numb and unresponsive with libinput 1.10.3

Actually it starts out very jittery, but soon switches mode and becomes numb and unresponsive (hysteresis margin feels too big maybe).

Workaround: xserver-xorg-input-synaptics works fine and has neither problem.
Comment 1 Daniel van Vugt 2018-03-22 03:45:11 UTC
Note that libinput 1.10.1 performed much better the jitter problem was less annoying than the lack of response in 1.10.3.
Comment 2 Peter Hutterer 2018-03-22 07:42:33 UTC
try cherry-picking ea7498ef971350454db9c78b9ba160e7d6bb455b, or, ideally - try master please.
Comment 3 Daniel van Vugt 2018-03-28 03:34:32 UTC
Master (commit 93dfd0fa5) works well.

And cherry-picking commit ea7498ef into 1.10 also solves it.
Comment 4 Peter Hutterer 2018-04-02 23:07:41 UTC

*** This bug has been marked as a duplicate of bug 105108 ***
Comment 5 Daniel van Vugt 2018-04-03 01:46:40 UTC
This is not a duplicate of bug 105108, which is why I logged it separately.
Comment 6 Daniel van Vugt 2018-04-03 01:48:27 UTC
This is a regression in libinput 1.10.2/1.10.3, I think caused by the fix for bug 105108.
Comment 7 Daniel van Vugt 2018-04-03 01:49:04 UTC
The required fix here is to backport commit ea7498ef to libinput 1.10
Comment 8 Peter Hutterer 2018-04-09 05:39:57 UTC
bab4ca0274405a9d97c6a950bdc8f7f9275278aa is in 1.10.4 now


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.