Bug 105681 - [CI] igt@kms_frontbuffer_tracking@* - FBC disabled: underrun detected
Summary: [CI] igt@kms_frontbuffer_tracking@* - FBC disabled: underrun detected
Status: RESOLVED DUPLICATE of bug 107724
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Juha-Pekka Heikkilä
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
: 105685 (view as bug list)
Depends on:
Blocks: 105980
  Show dependency treegraph
 
Reported: 2018-03-22 07:25 UTC by Marta Löfstedt
Modified: 2019-04-08 11:37 UTC (History)
3 users (show)

See Also:
i915 platform: CNL, ICL, KBL
i915 features: display/FBC


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2018-03-22 07:25:55 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_5/fi-kbl-7500u/igt@kms_frontbuffer_tracking@fbc-2p-scndscrn-spr-indfb-draw-mmap-wc.html

(kms_frontbuffer_tracking:1284) WARNING: fbc_is_enabled()?
FBC disabled: underrun detected
(kms_frontbuffer_tracking:1284) CRITICAL: Test assertion failure function do_status_assertions, file ../tests/kms_frontbuffer_tracking.c:1748:
(kms_frontbuffer_tracking:1284) CRITICAL: Failed assertion: fbc_is_enabled(IGT_LOG_WARN)
(kms_frontbuffer_tracking:1284) CRITICAL: FBC disabled
Subtest fbc-2p-scndscrn-spr-indfb-draw-mmap-wc failed.
Comment 6 Maarten Lankhorst 2018-04-04 11:12:03 UTC
Kernel side:

https://patchwork.freedesktop.org/patch/213383/

IGT change:

https://patchwork.freedesktop.org/series/40801/
Comment 7 Maarten Lankhorst 2018-04-11 07:49:17 UTC
IGT:

commit aed2030ea1eeda27299db8994b329d3063559805                                                                                                                                                                                                                     
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>                                                                                                                                                                                                       
Date:   Wed Mar 28 11:56:04 2018 +0200                                                                                                                                                                                                                              
                                                                                                                                                                                                                                                                    
    lib/igt_kms: Reset FIFO underruns on first commit after init()/reset().                                                                                                                                                                                         
                                                                             

Kernel:

commit d52ad9cb9d6d3b696d6b7ad20a381a8f5520ea03
Author: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Date:   Wed Mar 28 12:05:26 2018 +0200

    drm/i915: Add debugfs file to clear FIFO underruns.
Comment 8 Marta Löfstedt 2018-04-11 08:33:24 UTC
IGT fix integrated to IGT_4420, since this hasn't been seen on shards it will take drmtip runs to verify.
Comment 9 Marta Löfstedt 2018-04-11 11:43:59 UTC
kernel fix was integrated to CI_DRM_4041, 

IGT_4420 was based on CI_DRM_4042, so all runs after should have both fixes.
Comment 10 Marta Löfstedt 2018-04-12 10:10:44 UTC
This is looking good on drmtip17 I will close
Comment 11 Martin Peres 2018-04-20 13:17:21 UTC
Seen on drmtip_22: https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_22/fi-cnl-y3/igt@kms_fbcon_fbt@fbc.html

(kms_fbcon_fbt:1295) CRITICAL: Test assertion failure function subtest, file ../tests/kms_fbcon_fbt.c:243:
(kms_fbcon_fbt:1295) CRITICAL: Failed assertion: feature->wait_until_enabled(drm.fd)
Subtest fbc failed.
**** DEBUG ****
(kms_fbcon_fbt:1295) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
[...]
(kms_fbcon_fbt:1295) igt_debugfs-DEBUG: Opening debugfs directory '/sys/kernel/debug/dri/0'
(kms_fbcon_fbt:1295) DEBUG: FBC status: FBC disabled: underrun detected
Comment 12 Maarten Lankhorst 2018-08-08 18:28:09 UTC
*** Bug 105685 has been marked as a duplicate of this bug. ***
Comment 13 Jani Saarinen 2018-11-07 12:25:58 UTC
Not seen lately?
Comment 14 Lakshmi 2018-11-08 07:43:44 UTC
Last seen this issue on drmtip_128 (3 weeks, 2 days / 304 runs ago), the frequency of this bug is in between 2 days~2 weeks. 
We can wait for few more weeks before we close this bug.
Comment 15 Jani Saarinen 2018-11-14 12:25:28 UTC
Seen again a lot.
Comment 16 Jani Saarinen 2018-12-17 14:15:59 UTC
This is also seen a lot on ICL. Eg: https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_5323/shard-iclb3/igt@kms_fbcon_fbt@fbc-suspend.html
Comment 17 Jani Saarinen 2018-12-17 14:17:02 UTC
Is this duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=107724?
Comment 18 Jose Roberto de Souza 2019-02-13 22:10:30 UTC
With the current workaround for https://bugs.freedesktop.org/show_bug.cgi?id=107724 looks like we only have CRC mismatch errors for FBC tests but it will be replaced by other workaround so lets keep it open until final fix for general underruns is found.
Comment 19 Jani Saarinen 2019-03-05 11:36:17 UTC
Final wa was merged on https://cgit.freedesktop.org/drm-tip/commit/?id=c384afe35200f090b10ff5b4e8c7e6ea6a54eb19.
Resolving as not seen on 2 full runs.
Comment 20 Martin Peres 2019-03-08 15:47:44 UTC
(In reply to Jani Saarinen from comment #19)
> Final wa was merged on
> https://cgit.freedesktop.org/drm-tip/commit/
> ?id=c384afe35200f090b10ff5b4e8c7e6ea6a54eb19.
> Resolving as not seen on 2 full runs.

Seen again on drmtip_239 which should have the WA:

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_239/fi-icl-u3/igt@kms_fbcon_fbt@fbc.html

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_239/fi-icl-u2/igt@kms_fbcon_fbt@fbc.html
Comment 21 CI Bug Log 2019-04-08 11:29:12 UTC
A CI Bug Log filter associated to this bug has been updated:

{- All machine: all tests - dmesg-fail - FBC disabled: underrun detected / CPU pipe [ABC] FIFO underrun -}
{+ ICL: all tests - dmesg-fail - FBC disabled: underrun detected / CPU pipe [ABC] FIFO underrun +}

 No new failures caught with the new filter
Comment 22 CI Bug Log 2019-04-08 11:29:59 UTC
The CI Bug Log issue associated to this bug has been updated.

### Removed filters

* All machines: all tests - FBC disabled: underrun detected (added on 1 year ago)
Comment 23 Martin Peres 2019-04-08 11:34:13 UTC
(In reply to CI Bug Log from comment #22)
> The CI Bug Log issue associated to this bug has been updated.
> 
> ### Removed filters
> 
> * All machines: all tests - FBC disabled: underrun detected (added on 1 year
> ago)

and

(In reply to CI Bug Log from comment #21)
> A CI Bug Log filter associated to this bug has been updated:
> 
> {- All machine: all tests - dmesg-fail - FBC disabled: underrun detected /
> CPU pipe [ABC] FIFO underrun -}
> {+ ICL: all tests - dmesg-fail - FBC disabled: underrun detected / CPU pipe
> [ABC] FIFO underrun +}
> 
>  No new failures caught with the new filter

This bug has been fixed on all platforms, except ICL.

However, this issue is known on ICL (bug 107724), so let's close this bug and mark duplicate of 107724.

*** This bug has been marked as a duplicate of bug 107724 ***
Comment 24 CI Bug Log 2019-04-08 11:37:32 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.