Bug 105836 - xdg-open not setting default handler for x-scheme-handler/magnet
Summary: xdg-open not setting default handler for x-scheme-handler/magnet
Status: RESOLVED MOVED
Alias: None
Product: Portland
Classification: Unclassified
Component: xdg-utils (show other bugs)
Version: 1.1.0 rc3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Portland Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-31 20:54 UTC by boojum
Modified: 2019-02-16 13:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boojum 2018-03-31 20:54:51 UTC
I'm on Arch Linux with xdg-utils 1.1.2.


Expected behaviour:

Opening a magnet link with xdg-open will open that link in the default bittorrent application.


Actual behaviour:

Opening a magnet link with xdg-open opens the link with the browser. Probably not the same as bug 96472, in my case $BROWSER variable is not set and xdg-mime query comes back empty.


Steps to reproduce:

1. Set the default handler for magnet links: xdg-mime default rtm.desktop x-scheme-handler/magnet

1a. Check if 1 was set succesfully:
$ cat ~/.config/mimeapps.list
[Default Applications]
x-scheme-handler/magnet=rtm.desktop

1b. Make sure that $BROWSER is not set:
$ echo $BROWSER

2. xdg-mime query is coming back up empty:
$ xdg-mime query default x-scheme-handler/magnet
 
3. Run `xdg-open magnet:?xt=foo`.

4. The magnet link will be opened by the browser instead of the default application for magnet links.

Various blog posts suggested that the issue *might* be due to the xdg-open not recognising DE properly - sadly, my shell-fu is not up to the task to asses it. For what it's worth, I'm using a tiling wm instead of full-blown DE.
Comment 1 GitLab Migration User 2019-02-16 13:39:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xdg/xdg-utils/issues/124.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.