Bug 105910 - Graphical artifacts on unresponsible surfaces on AMD Radeon RX 570
Summary: Graphical artifacts on unresponsible surfaces on AMD Radeon RX 570
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
Depends on:
Reported: 2018-04-05 18:51 UTC by Ivan Chebykin
Modified: 2019-01-04 17:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Example of artifacts (1.12 MB, image/gif)
2018-04-05 18:51 UTC, Ivan Chebykin
no flags Details
Artifacts when window is opening (618.58 KB, image/gif)
2018-04-05 18:52 UTC, Ivan Chebykin
no flags Details
Xeyes render artifacts instead of background (160.43 KB, image/gif)
2018-04-05 18:53 UTC, Ivan Chebykin
no flags Details
dmesg full log (106.18 KB, text/x-log)
2018-04-05 18:53 UTC, Ivan Chebykin
no flags Details
glxinfo (106.03 KB, text/x-log)
2018-04-05 18:53 UTC, Ivan Chebykin
no flags Details
Xorg log (28.88 KB, text/plain)
2018-04-05 18:54 UTC, Ivan Chebykin
no flags Details

Description Ivan Chebykin 2018-04-05 18:51:40 UTC
Created attachment 138627 [details]
Example of artifacts


I want to report some graphical artifacts with AMD Radeon RX 570 card.

I've been noticing some random artifacts when I open/resize/close windows.
I was able to narrow down this problem to mesa surfaces updating. For instance
if i suspend program with such surface and try to resize it, I will see these artifacts. So I think there is a moment between receiving resize event and updating surface when driver somehow render those artifacts.

I'm using Arch Linux with i3, but I was able to reproduce this bug on wayland
by resizing alacritty terminal emulator.




libva-mesa-driver 17.3.7-1
mesa 17.3.7-1
mesa-vdpau 17.3.7-1
xf86-video-amdgpu 18.0.1-1
Comment 1 Ivan Chebykin 2018-04-05 18:52:32 UTC
Created attachment 138628 [details]
Artifacts when window is opening
Comment 2 Ivan Chebykin 2018-04-05 18:53:05 UTC
Created attachment 138629 [details]
Xeyes render artifacts instead of background
Comment 3 Ivan Chebykin 2018-04-05 18:53:36 UTC
Created attachment 138630 [details]
dmesg full log
Comment 4 Ivan Chebykin 2018-04-05 18:53:54 UTC
Created attachment 138631 [details]
Comment 5 Ivan Chebykin 2018-04-05 18:54:26 UTC
Created attachment 138632 [details]
Xorg log
Comment 6 Ivan Chebykin 2018-05-07 11:14:45 UTC
I think it's not just mesa, but some drivers issue.
Comment 7 Ivan Chebykin 2018-05-07 11:16:12 UTC
Also still happens on linux 4.16 and mesa 18.0.2.
Comment 8 drpastah 2018-12-25 15:36:21 UTC
I'm also having graphical artifacts with i3. I have an amd rx 580. Here's a thread with the issues I was getting: https://bbs.archlinux.org/viewtopic.php?id=242727

I have also tried taking out my rx 580 card out of my computer and uninstalled AMDGPU and tried running i3 through my iGPU, i7-7700k CPU. I still had graphical artifacts when I tried that.

Here is a vid of the artifacting:
Comment 9 Michel Dänzer 2018-12-28 17:17:43 UTC
At least with xeyes, this is expected with i3, see https://github.com/i3/i3/issues/2742#issuecomment-433304928 and later comments.

I suspect it could be similar with VirtualBox.

The issue with alacritty on Wayland is probably different, maybe in Xwayland, or if it uses the Wayland protocol directly, maybe one of the known issues described on https://github.com/jwilm/alacritty => https://github.com/tomaka/winit/issues/306 .

Anyway, I don't see clear evidence of a driver bug here.
Comment 10 Michel Dänzer 2019-01-04 17:29:36 UTC
Things are increasingly pointing to this being an i3 bug. It creates a cairo surface with cairo_xcb_surface_create and copies from that to its parent window. But according to /usr/include/cairo/cairo.h, cairo doesn't initialize the contents of a surface created with cairo_xcb_surface_create, so i3 needs to initialize them explicitly.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.