Bug 106023 - [CI] igt@gem_ppgtt@blt-vs-render-* - incomplete - system hang/timeout ?
Summary: [CI] igt@gem_ppgtt@blt-vs-render-* - incomplete - system hang/timeout ?
Status: CLOSED DUPLICATE of bug 106887
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: Other All
: high normal
Assignee: Andi
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-13 06:02 UTC by Marta Löfstedt
Modified: 2019-03-08 15:40 UTC (History)
1 user (show)

See Also:
i915 platform: CFL, KBL, SKL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marta Löfstedt 2018-04-13 06:02:58 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4048/shard-kbl2/igt@gem_ppgtt@blt-vs-render-ctx0.html

run.log:
running: igt/gem_ppgtt/blt-vs-render-ctx0

[33/75] skip: 16, pass: 17 /             
FATAL: command execution failed
...
Completed CI_IGT_test CI_DRM_4048/shard-kbl2/20 : FAILURE
CI_IGT_test runtime 656 seconds
Rebooting shard-kbl2


last dmesg:
<6>[  212.863962] Console: switching to colour frame buffer device 240x67
<6>[  212.974802] Console: switching to colour dummy device 80x25
<7>[  212.974851] [IGT] gem_ppgtt: executing
Comment 2 Marta Löfstedt 2018-04-18 06:28:05 UTC
This looks like a regression and/or context leak issue that started with drmtip_18, setting priority to highest
Comment 3 Marta Löfstedt 2018-04-18 06:55:49 UTC
Highest due to CFL-u
Comment 4 Marta Löfstedt 2018-04-19 06:56:30 UTC
KBL-shards so far 6 runs consecutively:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4060/shard-kbl1/igt@gem_ppgtt@blt-vs-render-ctx0.html

to:
https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4066/shard-kbl6/igt@gem_ppgtt@blt-vs-render-ctx0.html

Also, note that all runs above have same IGT version, so maybe context leak.
Comment 5 Marta Löfstedt 2018-04-19 07:23:36 UTC
the drmtip_18 occurences from Comment 1 have the same IGT version and thus testlist as:

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4048/shard-kbl2/igt@gem_ppgtt@blt-vs-render-ctx0.html

from the Description comment.
Comment 7 Francesco Balestrieri 2018-07-02 10:28:06 UTC
Last seen one week ago, with 134 / 490 runs (27.3%)
Comment 8 Andi 2018-10-17 13:43:41 UTC
Hi Marta,

could you please test again with the latest drm-tip?
I executed the gem_ppgtt/blt-vs-render-ctx0 test and passes. I tested on a KBL.

Thanks,
Andi
Comment 9 Lakshmi 2018-10-26 15:36:23 UTC

*** This bug has been marked as a duplicate of bug 106887 ***
Comment 10 CI Bug Log 2019-03-08 15:40:07 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.