Bug 106103 - [CI] igt@kms_* - fail - Timed out: Opening crc fd, which waits for first CRC.
Summary: [CI] igt@kms_* - fail - Timed out: Opening crc fd, which waits for first CRC.
Status: CLOSED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: high normal
Assignee: Dhinakaran Pandiyan
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-17 12:54 UTC by Martin Peres
Modified: 2018-09-07 16:44 UTC (History)
2 users (show)

See Also:
i915 platform: ALL
i915 features: display/PSR


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-04-17 12:54:33 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_22/fi-cnl-psr/igt@kms_frontbuffer_tracking@psr-1p-offscren-pri-indfb-draw-pwrite.html * 150

IGT-Version: 1.22-g8b77704d (x86_64) (Linux: 4.17.0-rc1-gac35105865ed-drmtip_22+ x86_64)
FBC last action not supported
Can't test DRRS: Not supported.
Timed out: Opening crc fd, which waits for first CRC.
Subtest psr-1p-offscren-pri-indfb-draw-mmap-wc: FAIL (14.862s)
Comment 1 Martin Peres 2018-04-17 12:55:25 UTC
Bumping the priority to highest, because otherwise, we lose all coverage on cnl-psr for frontbuffer_tracking!
Comment 2 Marta Löfstedt 2018-04-18 07:17:57 UTC
(In reply to Martin Peres from comment #1)
> Bumping the priority to highest, because otherwise, we lose all coverage on
> cnl-psr for frontbuffer_tracking!

Martin is this display/PSR & CRC related?
Comment 3 Martin Peres 2018-04-18 07:30:53 UTC
(In reply to Marta Löfstedt from comment #2)
> (In reply to Martin Peres from comment #1)
> > Bumping the priority to highest, because otherwise, we lose all coverage on
> > cnl-psr for frontbuffer_tracking!
> 
> Martin is this display/PSR & CRC related?

Yeah, quite likely given how only this one is affected.
Comment 4 Dhinakaran Pandiyan 2018-05-24 00:17:09 UTC
Needs a kernel fix to not wait for CRC's when PSR is enabled.
Comment 5 James Ausmus 2018-06-19 22:52:18 UTC
Martin - Same question here - "idle run" only, and how often?
Comment 6 Martin Peres 2018-06-19 23:13:30 UTC
(In reply to James Ausmus from comment #5)
> Martin - Same question here - "idle run" only, and how often?

On every idle run, this produces hundreds of failures on fi-cnl-psr. 

It also affects BAT in almost every run (which would warrant HIGHEST if there wasn't that many of these :s). Here is an example:

 - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4338/fi-hsw-4200u/igt@kms_frontbuffer_tracking@basic.html
 - https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4337/fi-hsw-peppy/igt@kms_frontbuffer_tracking@basic.html

Now, I don't see the logic with de-prioritising issues found in "idle runs". They may not be part of the problem of noise in CI, but it that does not make them less relevant to the users. I know PSR is disabled by default, but plenty of users do enable it anyway: https://www.google.fi/search?ei=wo0pW8GfO8Od6ATUg5KQCw&q=i915.enable_psr%3D1&oq=i915.enable_psr%3D1&gs_l=psy-ab.3..0j0i10i30k1.2350.3905.0.4294.5.5.0.0.0.0.239.759.0j4j1.5.0....0...1c.1.64.psy-ab..0.5.757...0i7i10i30k1j0i13k1.0.ULXDYBTGlIc
Comment 7 Dhinakaran Pandiyan 2018-06-29 21:31:28 UTC
(In reply to Martin Peres from comment #6)
> (In reply to James Ausmus from comment #5)
> > Martin - Same question here - "idle run" only, and how often?
> 
> On every idle run, this produces hundreds of failures on fi-cnl-psr. 
> 
> It also affects BAT in almost every run (which would warrant HIGHEST if
> there wasn't that many of these :s). Here is an example:
> 
>  -
> https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4338/fi-hsw-4200u/
> igt@kms_frontbuffer_tracking@basic.html
>  -
> https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4337/fi-hsw-peppy/
> igt@kms_frontbuffer_tracking@basic.html
> 
Wrong links? Not sure why you think these two failures are PSR related.

Result: dmesg-fail
[  399.553943] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe A
[  399.554300] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun

> Now, I don't see the logic with de-prioritising issues found in "idle runs".
> They may not be part of the problem of noise in CI, but it that does not
> make them less relevant to the users. I know PSR is disabled by default, but
> plenty of users do enable it anyway:
> https://www.google.fi/search?ei=wo0pW8GfO8Od6ATUg5KQCw&q=i915.
> enable_psr%3D1&oq=i915.enable_psr%3D1&gs_l=psy-ab.3..0j0i10i30k1.2350.3905.0.
> 4294.5.5.0.0.0.0.239.759.0j4j1.5.0....0...1c.1.64.psy-ab..0.5.757...
> 0i7i10i30k1j0i13k1.0.ULXDYBTGlIc
Comment 8 Dhinakaran Pandiyan 2018-07-14 22:05:24 UTC
Is this issue still seen? Looks like cnl-psr is not in CI anymore.
Comment 9 Dhinakaran Pandiyan 2018-07-19 21:26:15 UTC
PSR is in the right stage for us to look at CRC errors. If this is still happening, I'd like to take a look at the logs.
Comment 10 Martin Peres 2018-07-20 10:36:36 UTC
(In reply to Dhinakaran Pandiyan from comment #9)
> PSR is in the right stage for us to look at CRC errors. If this is still
> happening, I'd like to take a look at the logs.

Sure thing! CI Bug Log is your best place to get this information (just click on the reproduction rate link). However, the filing is just terrible for this bug and it catches a lot of unrelated issues (no idea how it came to that state :o).

I'll work on it next week to sort this mess :o In the mean time, I will close it as INVALID because it is just worthless in this state.
Comment 11 Martin Peres 2018-09-07 16:44:09 UTC
(In reply to Martin Peres from comment #10)
> (In reply to Dhinakaran Pandiyan from comment #9)
> > PSR is in the right stage for us to look at CRC errors. If this is still
> > happening, I'd like to take a look at the logs.
> 
> Sure thing! CI Bug Log is your best place to get this information (just
> click on the reproduction rate link). However, the filing is just terrible
> for this bug and it catches a lot of unrelated issues (no idea how it came
> to that state :o).
> 
> I'll work on it next week to sort this mess :o In the mean time, I will
> close it as INVALID because it is just worthless in this state.

Oopsie, never got to do it, but it looks fixed anyway :D


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.