Bug 106145 - 8064px Max OpenGL window resolution i965
Summary: 8064px Max OpenGL window resolution i965
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.0
Hardware: Other All
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-20 08:16 UTC by Inad
Modified: 2019-09-25 19:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
glxinfo (36.71 KB, text/plain)
2018-04-24 07:12 UTC, Inad
Details
cpuinfo (10.95 KB, text/plain)
2018-04-24 07:13 UTC, Inad
Details
xrand (2.26 KB, text/plain)
2018-04-24 07:13 UTC, Inad
Details
xorglog (41.22 KB, text/plain)
2018-04-24 07:13 UTC, Inad
Details
dmesg (47.00 KB, text/plain)
2018-04-24 07:14 UTC, Inad
Details
Image (153.54 KB, image/jpeg)
2018-04-24 07:20 UTC, Inad
Details
Ubuntu 17.10 (709.29 KB, image/jpeg)
2018-04-24 11:54 UTC, Inad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Inad 2018-04-20 08:16:32 UTC
Hello,

I have a problem creating an OpenGL window greater than 8064 with DRI / i965

glxgears -geometry 8064x2160 with Intel DRI works fine
glxgears -geometry 8065x2160 with Intel DRI causes corruption in the image

With the classic swrast it works correctly.

I think that with Mesa 13 versions it worked with intel well

Thank you
Comment 1 Tapani Pälli 2018-04-23 05:26:37 UTC
I cannot reproduce this. Can you please include some information about your system? Please include the output given by glxinfo.
Comment 2 Inad 2018-04-24 07:12:29 UTC
Created attachment 139039 [details]
glxinfo
Comment 3 Inad 2018-04-24 07:13:06 UTC
Created attachment 139040 [details]
cpuinfo
Comment 4 Inad 2018-04-24 07:13:21 UTC
Created attachment 139041 [details]
xrand
Comment 5 Inad 2018-04-24 07:13:39 UTC
Created attachment 139042 [details]
xorglog
Comment 6 Inad 2018-04-24 07:14:00 UTC
Created attachment 139043 [details]
dmesg
Comment 7 Inad 2018-04-24 07:20:40 UTC
Created attachment 139044 [details]
Image
Comment 8 Inad 2018-04-24 07:21:37 UTC
With the final table version 18 also happens
I'm going to try other distributions
Comment 9 Inad 2018-04-24 11:54:02 UTC
Created attachment 139051 [details]
Ubuntu 17.10

In ubuntu glxgears it works fine, but when you connect the third 4K monitor you see the same corruption in the background (trash image)
Comment 10 Tapani Pälli 2018-04-25 05:10:43 UTC
(In reply to Inad from comment #9)
> Created attachment 139051 [details]
> Ubuntu 17.10
> 
> In ubuntu glxgears it works fine, but when you connect the third 4K monitor
> you see the same corruption in the background (trash image)

You did not mention multimonitor setup before, was this also the case when testing on gentoo? I think your bug might be somewhere else than Mesa, probably X driver (?) Did you try if using modesetting makes difference?
Comment 11 Inad 2018-04-25 05:38:40 UTC
modesetting has a maximum resolution of 8xxx.  I do not remember it now exactly

With the intel driver yes that allows me these resolutions.
I think it's the mesa driver because the error only happens with an OpenGL window.
With a gtk2 window with a simple button there is no problem, with the basic example of OpenGL triangle causes corruption.

With LIBGL_ALWAYS_SOFTWARE = 1 both with LLVMpipe and with swrast it works fine
LLVMpipe max 9664 px for limits
Comment 12 Tapani Pälli 2018-04-25 11:38:53 UTC
(In reply to Inad from comment #11)
> modesetting has a maximum resolution of 8xxx.  I do not remember it now
> exactly
> 
> With the intel driver yes that allows me these resolutions.
> I think it's the mesa driver because the error only happens with an OpenGL
> window.
> With a gtk2 window with a simple button there is no problem, with the basic
> example of OpenGL triangle causes corruption.
> 
> With LIBGL_ALWAYS_SOFTWARE = 1 both with LLVMpipe and with swrast it works
> fine
> LLVMpipe max 9664 px for limits

Does it work with only single or dual monitor setup? If it does, then the bug is in whatever X does in displaying image within multiple monitors.
Comment 13 Illia Iorin 2018-08-03 09:35:09 UTC
I can`t reproduce this issue on my laptop  with those configuration of displays:
Base:  1920x1080 VGA: 1920x1080 Displayport: 3840x2160
Other configuration of my system:
Kernel: 4.16.13-041613-generic
mesa: Mesa 18.0.0-rc5 
GPU:  Intel(R) HD Graphics 620 (Kaby Lake GT2) 
Xserver-xorg Version: 1:7.7+19ubuntu7
OS: Ubuntu 18.04
Comment 14 Illia Iorin 2018-08-03 14:44:21 UTC
I ran glxgears with these resolutions:  7681x2160, 7681x1080, 8065x2160.
Comment 15 Illia Iorin 2018-08-09 11:20:12 UTC
Hello Inad,
Please, provide additional information about your system. This  bug looks similar to https://bugs.freedesktop.org/show_bug.cgi?id=98297. 
In that post reporter used "modesetting driver", which does not support target resolution. Please send output of this command "inxi -Gxx". If you use modesetting try to reproduce this issue  with xf86-video-intel DDX driver.
Comment 16 GitLab Migration User 2019-09-25 19:10:46 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1717.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.