Bug 106146 - tigervnc (rarely) blocks on exit, presumably due to an invalid free (according to valgrind) in CloseDownDevices .
Summary: tigervnc (rarely) blocks on exit, presumably due to an invalid free (accordin...
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.7 (2012.06)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-20 11:06 UTC by Stef Van Vlierberghe
Modified: 2018-12-13 22:39 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stef Van Vlierberghe 2018-04-20 11:06:53 UTC
I'm not familiar with the Xserver code but get regularly issues with tigervnc (a patched X server) getting stuck on exit and this prevents a new one from being started in the same display nr (manual intervention required to kill -9 the Xvnc process that is stuck).

After reporting and discussing the issue with the maintainers, I got informed that the root cause is in the X server, see :

https://github.com/TigerVNC/tigervnc/issues/532

As this is probably a heap corruption combined with a race condition, there is no way to systematically reproduce the effect.

If nothing else can be done, maybe you could advice if there are ways to avoid the free() calls on process exit (as they are completely useless, the kernel will reclaim this memory anyway).
Comment 1 GitLab Migration User 2018-12-13 22:39:17 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/xserver/issues/534.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.