Bug 106160 - MacBook 2,1 hangs during boot
Summary: MacBook 2,1 hangs during boot
Status: CLOSED DUPLICATE of bug 105637
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lakshmi
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2018-04-20 20:43 UTC by Nicholas Bishop
Modified: 2018-10-13 13:35 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Picture of screen corruption (402.66 KB, image/jpeg)
2018-04-20 21:17 UTC, Nicholas Bishop
no flags Details
dmesg booting without i915, then modprobing it (68.31 KB, text/plain)
2018-04-23 03:17 UTC, Nicholas Bishop
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Bishop 2018-04-20 20:43:20 UTC
The machine hangs early in the boot process with some screen corruption (usually horizontal white lines), no kernel messages are visible.

I bisected this in the stable kernel to this commit:

50018d09843cc4813f1c2b89ff8fbcdf883ab0a3
drm/i915: Redo plane sanitation during readout

The preceeding commit works fine:

19d8e5122fefc3e424050a78063f0d385433e191
drm/i915: Add .get_hw_state() method for planes
Comment 1 Nicholas Bishop 2018-04-20 21:17:27 UTC
Created attachment 138963 [details]
Picture of screen corruption
Comment 2 Nicholas Bishop 2018-04-20 21:25:42 UTC
I tried capturing messages through serial but it ends before anything interesting happens:

[    0.000000] Linux version 4.14.31.never-debug+ (nbishop@jordan) (gcc version 4.9.x 20150123 (prerelease) (4.9.2_cos_gg_4.9.2
-r172-0c5a656a1322e137fa4a251f2ccc6c4022918c0a_4.9.2-r172)) #15 SMP Fri Apr 20 16:07:05 EDT 2018                                      
[    0.000000] Command line: BOOT_IMAGE=/syslinux/vmlinuz.A init=/sbin/init boot=local rootwait ro noresume noswap loglevel=7 noinitrd 
console=ttyUSB0 i915.modeset=1 cros_efi cros_debug root=PARTUUID=A2A66D1F-BC89-7744-A650-AABFAA256C03                                 
[    0.000000] x86/fpu: x87 FPU will use FXSAVE                                                      
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000008efff] usable
[    0.000000] BIOS-e820: [mem 0x000000000008f000-0x000000000008ffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x0000000000090000-0x000000000009ffff] usable  
[    0.000000] BIOS-e820: [mem 0x00000000000a0000-0x00000000000bffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000007e0f7fff] usable  
[    0.000000] BIOS-e820: [mem 0x000000007e0f8000-0x000000007e2f8fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000007e2f9000-0x000000007ee4afff] usable  
[    0.000000] BIOS-e820: [mem 0x000000007ee4b000-0x000000007ee70fff] reserved
[    0.000000] BIOS-e820: [mem 0x000000007ee71000-0x000000007ee7ffff] usable  
[    0.000000] BIOS-e820: [mem 0x000000007ee80000-0x000000007eeaafff] reserved
[    0.000000] BIOS-e820: [mem 0x000000007eeab000-0x000000007eeb6fff] usable  
[    0.000000] BIOS-e820: [mem 0x000000007eeb7000-0x000000007eebbfff] A

The output ends there.
Comment 3 Nicholas Bishop 2018-04-23 03:17:13 UTC
Created attachment 138990 [details]
dmesg booting without i915, then modprobing it
Comment 4 Jani Saarinen 2018-04-25 14:42:52 UTC
Ville, seems to be your commit.
Comment 5 Lakshmi 2018-09-11 09:07:28 UTC
Reporter, do you still have the issue?
Comment 6 Lakshmi 2018-09-12 07:30:39 UTC
Nicholas, Please try to reproduce the error using drm-tip (https://cgit.freedesktop.org/drm-tip) and kernel parameters drm.debug=0x1e log_buf_len=4M, and if the problem persists attach the full dmesg from boot.
Comment 7 Peter Nowee 2018-09-21 14:28:29 UTC

*** This bug has been marked as a duplicate of bug 105637 ***
Comment 8 Lakshmi 2018-10-13 13:35:46 UTC
Nicholas, I assume this issue has been fixed in latest drm-tip.
PLease reopen the issue if your MacBook still hangs with latest drm-tip.

If this happens to occur with latest drm-tip, send dmesg log from boot with kernel parameters drm.debug=0x1e log_buf_len=4M and reboot.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.