Bug 106245 - Raven ridge (2400g) fails to start (swiotlb buffer is full) with IOMMU disabled
Summary: Raven ridge (2400g) fails to start (swiotlb buffer is full) with IOMMU disabled
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 106496 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-04-26 08:46 UTC by ojab
Modified: 2018-05-14 10:24 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
full dmesg, kernel 4.16.4 (86.54 KB, text/plain)
2018-04-26 08:46 UTC, ojab
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ojab 2018-04-26 08:46:10 UTC
Created attachment 139123 [details]
full dmesg, kernel 4.16.4

Ryzen 2400g
ASUS A320M-K with IOMMU disabled (either in BIOS/EFI or using amd_iommu=off)
kernels 4.16.4 & 4.17-rc2 (haven't this hardware before yesterday, so haven't tested with older kernels)
 
amdgpu fails to load:

Apr 25 23:39:36 ojab kernel: [    1.886215] amdgpu 0000:08:00.0: swiotlb buffer is full (sz: 262152 bytes)
Apr 25 23:39:36 ojab kernel: [    1.886315] amdgpu 0000:08:00.0: swiotlb: coherent allocation failed, size=262152
Apr 25 23:39:36 ojab kernel: [    1.886429] CPU: 7 PID: 263 Comm: udevd Not tainted 4.16.4-ojab #3
Apr 25 23:39:36 ojab kernel: [    1.886524] Call Trace:
Apr 25 23:39:36 ojab kernel: [    1.887060]  dump_stack+0x67/0x93
Apr 25 23:39:36 ojab kernel: [    1.887130]  swiotlb_alloc_coherent+0x1da/0x1f0
Apr 25 23:39:36 ojab kernel: [    1.887237]  amdgpu_ih_ring_init+0x1fc/0x2c0 [amdgpu]
Apr 25 23:39:36 ojab kernel: [    1.887339]  vega10_ih_sw_init+0x18/0xb0 [amdgpu]
Apr 25 23:39:36 ojab kernel: [    1.887430]  amdgpu_device_init+0xa35/0x11f0 [amdgpu]
Apr 25 23:39:36 ojab kernel: [    1.887523]  amdgpu_driver_load_kms+0x56/0x170 [amdgpu]
Apr 25 23:39:36 ojab kernel: [    1.887605]  drm_dev_register+0x166/0x1f0 [drm]
Apr 25 23:39:36 ojab kernel: [    1.887695]  amdgpu_pci_probe+0x113/0x1a0 [amdgpu]
Apr 25 23:39:36 ojab kernel: [    1.887770]  pci_device_probe+0xc9/0x140
Apr 25 23:39:36 ojab kernel: [    1.887842]  driver_probe_device+0x281/0x370
Apr 25 23:39:36 ojab kernel: [    1.887916]  __driver_attach+0xa9/0xb0
Apr 25 23:39:36 ojab kernel: [    1.887986]  ? driver_probe_device+0x370/0x370
Apr 25 23:39:36 ojab kernel: [    1.888072]  bus_for_each_dev+0x88/0xd0
Apr 25 23:39:36 ojab kernel: [    1.888143]  bus_add_driver+0x1b4/0x230
Apr 25 23:39:36 ojab kernel: [    1.888215]  ? 0xffffffffc1127000
Apr 25 23:39:36 ojab kernel: [    1.888284]  driver_register+0x57/0xc0
Apr 25 23:39:36 ojab kernel: [    1.888355]  ? 0xffffffffc1127000
Apr 25 23:39:36 ojab kernel: [    1.888425]  do_one_initcall+0x5c/0x1c0
Apr 25 23:39:36 ojab kernel: [    1.888496]  do_init_module+0x5e/0x20d
Apr 25 23:39:36 ojab kernel: [    1.888576]  load_module+0x137f/0x19b0
Apr 25 23:39:36 ojab kernel: [    1.888656]  ? m_show+0x1e0/0x1e0
Apr 25 23:39:36 ojab kernel: [    1.888735]  SYSC_init_module+0x102/0x150
Apr 25 23:39:36 ojab kernel: [    1.888818]  do_syscall_64+0x69/0x120
Apr 25 23:39:36 ojab kernel: [    1.888899]  entry_SYSCALL_64_after_hwframe+0x42/0xb7
Apr 25 23:39:36 ojab kernel: [    1.888988] RIP: 0033:0x7f1eae06551a
Apr 25 23:39:36 ojab kernel: [    1.889079] RSP: 002b:00007ffcce027138 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
Apr 25 23:39:36 ojab kernel: [    1.889194] RAX: ffffffffffffffda RBX: 00000000025ab5a0 RCX: 00007f1eae06551a
Apr 25 23:39:36 ojab kernel: [    1.889290] RDX: 00007f1eaec96e9d RSI: 0000000000465290 RDI: 0000000002719670
Apr 25 23:39:36 ojab kernel: [    1.889386] RBP: 00007f1eaec96e9d R08: 00000000ffffffff R09: 00000000025af020
Apr 25 23:39:36 ojab kernel: [    1.889483] R10: 0000000000000000 R11: 0000000000000246 R12: 0000000002719670
Apr 25 23:39:36 ojab kernel: [    1.889579] R13: 00000000025ab7f0 R14: 0000000000020000 R15: 0000000001c9c380
Apr 25 23:39:36 ojab kernel: [    1.889694] [drm:amdgpu_device_init [amdgpu]] *ERROR* sw_init of IP block <vega10_ih> failed -12
Apr 25 23:39:36 ojab kernel: [    1.889815] amdgpu 0000:08:00.0: amdgpu_device_ip_init failed
Comment 1 Michel Dänzer 2018-05-01 16:38:44 UTC
Does it work if you disable SME? amdgpu doesn't actually work yet with SME enabled anyway.

It's odd that SWIOTLB fails allocating 256KB this early, but it might be due to SME creating pressure on SWIOTLB.
Comment 2 ojab 2018-05-03 17:33:30 UTC
Yep, works fine with `mem_encrypt=off amd_iommu=off`
Comment 3 Michel Dänzer 2018-05-14 10:24:44 UTC
*** Bug 106496 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.