Bug 106248 - [CI] igt@drv_module_reload@basic-reload - WARNING at drivers/gpu/drm/drm_mode_config.c:439 drm_mode_config_cleanup
Summary: [CI] igt@drv_module_reload@basic-reload - WARNING at drivers/gpu/drm/drm_mode...
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-26 08:58 UTC by Martin Peres
Modified: 2019-03-08 16:24 UTC (History)
2 users (show)

See Also:
i915 platform: GLK
i915 features: display/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-04-26 08:58:45 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/IGT_4449/fi-glk-j4005/igt@drv_module_reload@basic-reload.html

[  511.096475] WARNING: CPU: 1 PID: 3977 at drivers/gpu/drm/drm_mode_config.c:439 drm_mode_config_cleanup+0x27a/0x2d0
[  511.096479] Modules linked in: vgem snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic i915(-) x86_pkg_temp_thermal intel_powerclamp coretemp crct10dif_pclmul crc32_pclmul btusb btrtl ghash_clmulni_intel btbcm btintel bluetooth snd_hda_codec snd_hwdep snd_hda_core ecdh_generic r8169 mii snd_pcm mei_me prime_numbers mei i2c_hid pinctrl_geminilake pinctrl_intel [last unloaded: snd_hda_intel]
[  511.096562] CPU: 1 PID: 3977 Comm: drv_module_relo Tainted: G     U            4.17.0-rc2-CI-CI_DRM_4096+ #1
[  511.096565] Hardware name: Intel Corporation NUC7CJYH/NUC7JYB, BIOS JYGLKCPX.86A.0027.2018.0125.1347 01/25/2018
[  511.096569] RIP: 0010:drm_mode_config_cleanup+0x27a/0x2d0
[  511.096572] RSP: 0018:ffffc90000047d80 EFLAGS: 00010287
[  511.096577] RAX: ffff8802662ba560 RBX: ffff88025fbc0840 RCX: 0000000000000000
[  511.096579] RDX: ffff88025fbc07e8 RSI: ffffffff82121491 RDI: 00000000ffffffff
[  511.096582] RBP: ffff88025fbc0000 R08: 0000000092ddfed8 R09: 0000000000000000
[  511.096584] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88025fbc0848
[  511.096587] R13: ffffffffa048c870 R14: ffff880275d94ae8 R15: ffffffffa048c8f0
[  511.096590] FS:  00007f5cca3e6980(0000) GS:ffff88027fc80000(0000) knlGS:0000000000000000
[  511.096592] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  511.096595] CR2: 00005602e9360528 CR3: 0000000272e0e000 CR4: 0000000000340ee0
[  511.096598] Call Trace:
[  511.096683]  intel_modeset_cleanup+0xb3/0x130 [i915]
[  511.096728]  i915_driver_unload+0x98/0x110 [i915]
[  511.096772]  i915_pci_remove+0x10/0x20 [i915]
[  511.096778]  pci_device_remove+0x36/0xb0
[  511.096784]  device_release_driver_internal+0x15d/0x220
[  511.096790]  driver_detach+0x35/0x70
[  511.096794]  bus_remove_driver+0x53/0xd0
[  511.096800]  pci_unregister_driver+0x25/0xa0
[  511.096808]  __se_sys_delete_module+0x162/0x210
[  511.096814]  ? do_syscall_64+0xd/0x190
[  511.096820]  do_syscall_64+0x55/0x190
[  511.096826]  entry_SYSCALL_64_after_hwframe+0x49/0xbe
[  511.096829] RIP: 0033:0x7f5cc9a9f1b7
[  511.096832] RSP: 002b:00007ffc5ce33e08 EFLAGS: 00000206 ORIG_RAX: 00000000000000b0
[  511.096837] RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007f5cc9a9f1b7
[  511.096839] RDX: 0000000000000000 RSI: 0000000000000800 RDI: 00005646b7ddb178
[  511.096842] RBP: 00005646b7ddb110 R08: 00005646b7ddb17c R09: 00007f5cc9aebb40
[  511.096844] R10: 00007ffc5ce32e04 R11: 0000000000000206 R12: 00005646b75f42f0
[  511.096847] R13: 00007ffc5ce34020 R14: 0000000000000000 R15: 0000000000000000
[  511.096859] Code: 42 30 00 48 8b 45 00 48 39 c5 75 62 48 8b 44 24 28 65 48 33 04 25 28 00 00 00 75 56 48 83 c4 30 5b 5d 41 5c 41 5d 41 5e 41 5f c3 <0f> 0b 48 89 e6 48 89 ef 48 c7 c3 3a 8d 0f 82 e8 52 96 ff ff eb 
[  511.096997] irq event stamp: 140486
[  511.097002] hardirqs last  enabled at (140485): [<ffffffff8192e8dc>] _raw_spin_unlock_irqrestore+0x4c/0x60
[  511.097006] hardirqs last disabled at (140486): [<ffffffff81a0111c>] error_entry+0x7c/0x100
[  511.097010] softirqs last  enabled at (139944): [<ffffffff81c0032b>] __do_softirq+0x32b/0x4e1
[  511.097014] softirqs last disabled at (139921): [<ffffffff8108b884>] irq_exit+0xa4/0xb0
[  511.097018] WARNING: CPU: 1 PID: 3977 at drivers/gpu/drm/drm_mode_config.c:439 drm_mode_config_cleanup+0x27a/0x2d0
[  511.097021] ---[ end trace 8ae4bcd075178608 ]---
[  511.097076] [drm:drm_mode_config_cleanup] *ERROR* connector HDMI-A-1 leaked!
Comment 2 James Ausmus 2018-10-24 16:49:17 UTC
Seems to be a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=106725 ?
Comment 3 Martin Peres 2019-03-08 16:19:04 UTC
(In reply to James Ausmus from comment #2)
> Seems to be a duplicate of
> https://bugs.freedesktop.org/show_bug.cgi?id=106725 ?

Yep, definitely looks like the same bug, and it also looks they are both fixed (used to happen every week, then nothing for over 4 months). Closing!
Comment 4 CI Bug Log 2019-03-08 16:24:19 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.