Bug 106370 - /bin/sh: BYPRODUCTS: command not found
Summary: /bin/sh: BYPRODUCTS: command not found
Status: RESOLVED FIXED
Alias: None
Product: piglit
Classification: Unclassified
Component: infrastructure (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Dylan Baker
QA Contact: Piglit Mailing List
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2018-05-03 06:00 UTC by Vinson Lee
Modified: 2018-06-04 21:34 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
attachment-6921-0.html (2.86 KB, text/html)
2018-05-03 15:29 UTC, Dylan Baker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2018-05-03 06:00:31 UTC
Build error with older cmake.

[  1%] Built target gen-gl-tests
/bin/sh: BYPRODUCTS: command not found
make[2]: *** [target_api/no_api/tests/CMakeFiles/static-shader-tests] Error 127
Comment 1 Dylan Baker 2018-05-03 15:29:05 UTC
Created attachment 139315 [details]
attachment-6921-0.html

What version of cmake are you using?

I'm on mobile, please excuse autocorrect fail.

On Wed, May 2, 2018, 23:01 <bugzilla-daemon@freedesktop.org> wrote:

> Bug ID 106370 <https://bugs.freedesktop.org/show_bug.cgi?id=106370>
> Summary /bin/sh: BYPRODUCTS: command not found
> Product piglit
> Version unspecified
> Hardware x86-64 (AMD64)
> OS All
> Status NEW
> Keywords regression
> Severity normal
> Priority medium
> Component infrastructure
> Assignee baker.dylan.c@gmail.com
> Reporter vlee@freedesktop.org
> QA Contact piglit@lists.freedesktop.org
>
> Build error with older cmake.
>
> [  1%] Built target gen-gl-tests
> /bin/sh: BYPRODUCTS: command not found
> make[2]: *** [target_api/no_api/tests/CMakeFiles/static-shader-tests] Error 127
>
> ------------------------------
> You are receiving this mail because:
>
>    - You are the assignee for the bug.
>
>
Comment 2 Vinson Lee 2018-05-03 20:42:52 UTC
(In reply to Dylan Baker from comment #1)
> 
> What version of cmake are you using?
> 

2.8.12.2
Comment 3 Vinson Lee 2018-05-07 01:47:11 UTC
Build error introduced with this commit.

commit 2f02cf0d4c2d7e901415d2325200deccc4230123
Author: Dylan Baker <dylan@pnwbakers.com>
Date:   Wed Mar 28 14:50:31 2018 -0700

    Generate xml for builtin profiles
    
    This creates and installs xml for all builtin profiles. Using these
    profiles I see startup times of ~1 second as opposed to more than 10
    with current master, and runtimes that drop by ~1 minute.
    
    v2: - Fix compilation with make. v1 only worked with ninja.
    
    Tested-by: Rafael Antognolli <rafael.antognolli@intel.com>
Comment 4 Vinson Lee 2018-06-04 21:34:26 UTC
commit fdc5a4ca11124ab8413c7988896eec4c97336694
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Thu May 17 11:29:53 2018 -0700

    cmake: Bump minimum version to 3.2.
    
    This build error occurs with cmake 2.8.12.
    /bin/sh: BYPRODUCTS: command not found
    
    BYPRODUCTS is not available until cmake 3.2.
    https://cmake.org/cmake/help/v3.2/release/3.2.html
    
    Fixes: 2f02cf0d4c2d ("Generate xml for builtin profiles")
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106370
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Dylan Baker <dylan@pnwbakers.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.