Bug 106372 - Infinite client hang in xcb_wait_for_special_event() - xserver 1.20rcX
Summary: Infinite client hang in xcb_wait_for_special_event() - xserver 1.20rcX
Status: RESOLVED DUPLICATE of bug 106351
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/modesetting (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 12:02 UTC by Tobias Klausmann
Modified: 2018-05-16 06:57 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
gdb backtrace of hanging plasmashell thread (3.48 KB, text/plain)
2018-05-03 12:02 UTC, Tobias Klausmann
no flags Details
Disable new code (1.58 KB, patch)
2018-05-03 15:02 UTC, Michel Dänzer
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann 2018-05-03 12:02:53 UTC
Created attachment 139302 [details]
gdb backtrace of hanging plasmashell thread

Starting with bisected commit 44d5f2eb8a2f92571698adec39ac569b71da5a1b - "xf86-video-modesetting: Support new vblank kernel API [v2]" Clients seem to miss events, here plasmashell [1]. This is easily reproduced by opening and closing the menu until plasmashell hangs. It seems to me that the server/driver does not properly report all vblank events.

Working around by calling xcb_poll_for_special_event() instead of xcb_wait_for_special_event() in the client call path "resolves" the issue in a dirty way on the client side.

Just to collect a bit more info:
HW: VGA compatible controller: Intel Corporation Device 591b (rev 04)
tested kernel: 4.16.x & 4.17rc

If you need more info, please let me know!
Comment 1 Michel Dänzer 2018-05-03 15:02:38 UTC
Created attachment 139311 [details] [review]
Disable new code

Does this patch on top of current xserver Git master still prevent the problem?
Comment 2 Tobias Klausmann 2018-05-03 15:48:09 UTC
(In reply to Michel Dänzer from comment #1)
> Created attachment 139311 [details] [review] [review]
> Disable new code
> 
> Does this patch on top of current xserver Git master still prevent the
> problem?

Yes the old code/interfaces does still work fine on top of latest master.
Comment 3 Tobias Klausmann 2018-05-03 22:05:22 UTC
This might actually be a duplicate of bug #106351 which i haven't checked :/. Yet we already made a bit of progress on this bugreport with bisecting and testing old & new code, leaving this one open for now seems reasonable...
Comment 4 Michel Dänzer 2018-05-16 06:57:45 UTC

*** This bug has been marked as a duplicate of bug 106351 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.