Bug 106380 - [CI] igt@gem_eio@in-flight-suspend - fail - Failed assertion: !wedged
Summary: [CI] igt@gem_eio@in-flight-suspend - fail - Failed assertion: !wedged
Status: CLOSED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 14:35 UTC by Martin Peres
Modified: 2019-01-09 09:17 UTC (History)
1 user (show)

See Also:
i915 platform: KBL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Peres 2018-05-03 14:35:35 UTC
https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_29/fi-kbl-r/igt@gem_eio@in-flight-suspend.html

(gem_eio:3905) igt_gt-CRITICAL: Test assertion failure function igt_force_gpu_reset, file ../lib/igt_gt.c:415:
(gem_eio:3905) igt_gt-CRITICAL: Failed assertion: !wedged
Subtest in-flight-suspend failed.

I made a different bug from https://bugs.freedesktop.org/show_bug.cgi?id=106064 / https://bugs.freedesktop.org/show_bug.cgi?id=106065 because 106064 was not reproduced on this run and there was no mention of failing to reset the GPU.
Comment 1 Chris Wilson 2018-05-03 14:50:39 UTC
<3>[  527.688990] i915 0000:00:02.0: GPU recovery failed

So on reset we saw the same request as for the previous attempt. Quite often in igt this is due to a timing error in that we haven't given the system long enough to execute said request, i.e. no time to recover. Could be?
Comment 2 Martin Peres 2018-06-15 09:06:26 UTC
Not seen since drmtip_29 (1 month, 2 weeks / 33 runs ago) and many improvements related to this area landed. Closing!
Comment 3 Francesco Balestrieri 2019-01-09 09:16:59 UTC
Looks like Martin forgot to close this :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.