Bug 106396 - [WAYLAND] Glitch with last Intel Vulkan driver
Summary: [WAYLAND] Glitch with last Intel Vulkan driver
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Vulkan/intel (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: highest blocker
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-04 06:59 UTC by Jean-Sebastien B.
Modified: 2019-09-18 19:48 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Expected result (2.13 KB, image/png)
2018-05-04 06:59 UTC, Jean-Sebastien B.
Details
Current result (2.59 KB, image/png)
2018-05-04 06:59 UTC, Jean-Sebastien B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sebastien B. 2018-05-04 06:59:24 UTC
Created attachment 139329 [details]
Expected result

Hello,
I found a bug in the last Intel Vulkan drivers.

With this test: https://github.com/realitix/vulkan/blob/master/example/example_wayland.py

I put in attachment the expected result and the current result.
I did a bisection and here the result:

17.3.9 -> OK
18.0.0 -> OK
18.0.2 -> OK
18.1.0-rc1 -> KO
18.1.0-rc2 -> KO
master -> KO

So this bug has been introduced with the version 18.1.0-rc1.

Thanks,
Jean-Sébastien BEVILACQUA
Comment 1 Jean-Sebastien B. 2018-05-04 06:59:49 UTC
Created attachment 139330 [details]
Current result
Comment 2 Jean-Sebastien B. 2018-05-04 07:16:15 UTC
Commits between these two versions:

git ll mesa-18.0.2 mesa-18.1.0-rc1 src/vulkan/ | grep wayland

| * a58fdc61e9 - vulkan/wsi/wayland: fix leaks (il y a 4 semaines) <James Legg>
| * ee2b943fa8 - wayland-drm: do not distribute generated sources (il y a 6 semaines) <Juan A. Suarez Romero>
| * 678ba53240 - vulkan: autotools: do not redirect stdin/stdout for wayland-scanner (il y a 8 semaines) <Emil Velikov>
| * d8f19d9aa0 - vulkan/wsi/wayland: Move Wayland protocol from BUILT_SOURCES (il y a 10 semaines) <Daniel Stone>
| * bfa22266cd - vulkan/wsi/wayland: Add support for zwp_dmabuf (il y a 2 mois) <Daniel Stone>
* ddf06a05ad - meson: move wayland_drm_protocol generation to wayland-drm (il y a 7 mois) <Dylan Baker>
* 4fe3913b96 - vulkan/wsi/wayland: Return better error messages (il y a 7 mois) <Jason Ekstrand>
* 537b9bc3e4 - vulkan/wsi/wayland: Copy wl_proxy objects from oldSwapchain if available (il y a 7 mois) <Jason Ekstrand>
* 4369102498 - vulkan/wsi/wayland: Stop caching Wayland displays (il y a 7 mois) <Jason Ekstrand>
* 77181d9580 - vulkan/wsi/wayland: Refactor wsi_wl_display code (il y a 7 mois) <Jason Ekstrand>
* 016de7e155 - vulkan/wsi/wayland: Stop printing out the DRM device (il y a 7 mois) <Jason Ekstrand>
* 2785090a2a - configure.ac: split the wayland client/server confusion (il y a 8 mois) <Emil Velikov>
* 1586768e74 - vulkan/wsi/wayland: Fix proxy wrappers for swapchain recreation (il y a 12 mois) <Philipp Zabel>
* 5034c61558 - vulkan/wsi/wayland: Use proxy wrappers for swapchain (il y a 12 mois) <Daniel Stone>
* c902a1957d - vulkan/wsi/wayland: Use per-display event queue (il y a 12 mois) <Daniel Stone>
* afe8c8a299 - vulkan/wsi/wayland: Remove roundtrip when creating image (il y a 12 mois) <Daniel Stone>
* 59f75dc2a4 - vulkan/wsi/wayland: Add support for VK_KHR_get_surface_capabilities2 (il y a 12 mois) <Jason Ekstrand>
* be1ecd8c6e - vulkan/wsi/wayland: Pass damage through to the compositor (il y a 1 an et 1 mois) <Jason Ekstrand>
* 12f348bc98 - vulkan/wsi: Generate wayland protocol headers separately from EGL (il y a 1 an et 2 mois) <Jason Ekstrand>
* 659edd9f5c - vulkan/wsi/wayland: Handle VK_INCOMPLETE for GetPresentModes (il y a 1 an et 3 mois) <Jason Ekstrand>
* dc578ef060 - vulkan/wsi/wayland: Handle VK_INCOMPLETE for GetFormats (il y a 1 an et 3 mois) <Jason Ekstrand>
* 302f641d14 - vulkan/wsi/wayland: Clean up some error handling paths (il y a 1 an et 6 mois) <Jason Ekstrand>
* 3b6abfc69a - vulkan/wsi/wayland: Include pthread.h (il y a 1 an et 6 mois) <Jason Ekstrand>
* 68db0fe034 - vulkan/wsi/wayland: fix ARGB window support (il y a 1 an et 6 mois) <Fredrik Höglund>
* 8bf7717e1f - wsi/wayland: fix error path (il y a 1 an et 6 mois) <Eric Engestrom>
Comment 3 Jason Ekstrand 2018-05-04 07:31:39 UTC
Could you please provide a bit more information such as what compositor you're using and what version of mesa is being used by your compositor (if different from the one you're testing with your app)?
Comment 4 Jean-Sebastien B. 2018-05-04 07:38:58 UTC
Indeed, I am using Ubuntu 17.10, so the compositor is Gnome Shell.
And the mesa version installed on my system is the 17.2.8.

Do you need more info ?
Comment 5 Lionel Landwerlin 2018-05-04 10:25:53 UTC
I've installed your repository and gave it a try on master at this commit :

commit 9a21c96126d6a13e7b472ec622c517c0d0285ba8 
Author: Deepak Rawat <drawat@vmware.com>
Date:   Tue Apr 24 11:50:59 2018 -0700

    egl/x11: Send invalidate to driver on copy_region path in swap_buffer


It works for me. I'm running gnome-shell 3.28.0 on Debian sid.
Comment 6 Jean-Sebastien B. 2018-05-04 11:00:26 UTC
I tried on your commit 9a21c96126d6a13e7b472ec622c517c0d0285ba8.
I got the same error.

Do you know what can influence this bug ?
Comment 7 Lionel Landwerlin 2018-05-04 11:14:54 UTC
It looks like a stride or tiling setting is wrong.
Comment 8 Lionel Landwerlin 2018-05-04 11:17:41 UTC
Can you run this application under a different window manager/compositor?
Is this just failing on your wayland example?

Are glfw/sdl2 failing too? Can you try those with their wayland backend?

Thanks!
Comment 9 Jean-Sebastien B. 2018-05-04 11:22:18 UTC
Actually I don't know very well how wayland works.
Can you tell me the way to test with another compositor ?
Comment 10 Lionel Landwerlin 2018-05-04 11:47:43 UTC
I guess you can try with glfw first to try to narrow down where the problem is.

I assume you have installed the libglfw3 package on ubuntu.
This package uses X11.

If you don't see any issue with the example_glfw.py then try to install libglfw3-wayland and run the example_glfw.py again.
If both work, then I guess this is a problem is likely to be somewhere in the example_wayland.py.
Comment 11 Jean-Sebastien B. 2018-05-04 11:57:16 UTC
I will try that.
I don't think it's my code because I got no warning or errors from my Vulkan Layers.
Comment 12 Paul 2019-06-07 11:15:00 UTC
Hi Jean.
I've tried to reproduce the issue on my KBL machine (Intel® UHD Graphics 620) on Ubuntu 18.04 and 5.1.2 version of the Kernel.
Unfortunately, I can't reproduce it.
Could you please provide information about your GPU - it could be helpful.
Also, could you provide info about flags which you use at compiling the mesa?
Comment 13 GitLab Migration User 2019-09-18 19:48:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/836.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.