Bug 106400 - [CI][SNB] glsl-1.40 and 1.50 texturesize / geometry tests failing
Summary: [CI][SNB] glsl-1.40 and 1.50 texturesize / geometry tests failing
Status: CLOSED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 18.0
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-04 08:18 UTC by Tomi Sarvela
Modified: 2019-09-09 06:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomi Sarvela 2018-05-04 08:18:29 UTC
Intel-GFX-CI has new (old) Dell XPS 8300 (SNB-2600) host running piglit for Intel-GFX and IGT regression testing. Environment is Ubuntu 18.04 LTS with no monitor attached, and testsuite is piglit with Mesa_CI and Mesa_Jenkins blacklists followed.

$ uname -a
Linux snb-2600 4.17.0-rc3-CI-CI_DRM_4143+ #1 SMP PREEMPT Fri May 4 10:50:21 EEST 2018 x86_64 x86_64 x86_64 GNU/Linux

$ wflinfo -p gbm -a gl
Waffle platform: gbm
Waffle api: gl
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Desktop 
OpenGL version string: 3.0 Mesa 18.0.0-rc5

The following tests seem to fail on this particular host:

spec@glsl-1.40@execution@texturesize@vs-texturesize-samplerbuffer
spec@glsl-1.40@execution@texturesize@vs-texturesize-isamplerbuffer
spec@glsl-1.40@execution@texturesize@vs-texturesize-usamplerbuffer
spec@glsl-1.50@execution@texturesize@gs-texturesize-samplerbuffer
spec@glsl-1.50@execution@texturesize@gs-texturesize-isamplerbuffer
spec@glsl-1.50@execution@texturesize@gs-texturesize-usamplerbuffer
spec@glsl-1.40@execution@texturesize@fs-texturesize-samplerbuffer
spec@glsl-1.40@execution@texturesize@fs-texturesize-isamplerbuffer
spec@glsl-1.40@execution@texturesize@fs-texturesize-usamplerbuffer
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_points other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_line_loop ffs
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_line_loop other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_line_strip other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_lines other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_triangles other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_triangle_strip other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_triangle_fan ffs
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_triangle_fan other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_lines_adjacency other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_line_strip_adjacency other
spec@glsl-1.50@execution@geometry@primitive-id-restart gl_triangles_adjacency other
spec@glsl-1.50@execution@geometry@tri-strip-ordering-with-prim-restart gl_triangle_strip ffs
spec@glsl-1.50@execution@geometry@tri-strip-ordering-with-prim-restart gl_triangle_strip other

A view to the runs can be seen at
https://intel-gfx-ci.01.org/tree/drm-tip/piglit-issues.html

Note that these are the first runs with this host, and issue might be with our environment and/or Ubuntu compilation of Mesa. This bug is created for CI Bug Log issue tracking.
Comment 1 Kenneth Graunke 2018-05-04 08:36:52 UTC
Yes, those are known failures on Sandybridge.  We mark those as expected failures in the Mesa CI:

https://github.com/janesma/mesa_jenkins/blob/master/piglit-test/snb.conf

The texture size issue is https://bugs.freedesktop.org/show_bug.cgi?id=57439 (circa 2012).  I'm not sure about the other one.
Comment 2 Tomi Sarvela 2018-05-04 11:27:55 UTC
Thanks,

It seems that there is some issue with blacklisting. From runlog, it seems that these tests should be excluded (line beginning with Options)

https://intel-gfx-ci.01.org/tree/drm-tip/CI_DRM_4143/pig-snb-2600/run0.log

So the problem is in our execution environment.
Comment 3 Tomi Sarvela 2018-05-07 10:49:49 UTC
Adding to the list: failing on SNB

spec@!opengl 1.0@gl-1.0-edgeflag-quads	
spec@!opengl 3.2@gl-3.2-adj-prims pv-first	
spec@!opengl 3.2@gl-3.2-adj-prims pv-last	
spec@!opengl 3.2@gl-3.2-adj-prims cull-front pv-first	
spec@!opengl 3.2@gl-3.2-adj-prims cull-front pv-last	
spec@!opengl 3.2@gl-3.2-adj-prims cull-back pv-first	
spec@!opengl 3.2@gl-3.2-adj-prims cull-back pv-last	
spec@!opengl 3.2@gl-3.2-adj-prims line cull-front pv-first	
spec@!opengl 3.2@gl-3.2-adj-prims line cull-front pv-last	
spec@!opengl 3.2@gl-3.2-adj-prims line cull-back pv-first	
spec@!opengl 3.2@gl-3.2-adj-prims line cull-back pv-last	
spec@!opengl es 3.0@gles-3.0-transform-feedback-uniform-buffer-object
Comment 4 Tomi Sarvela 2018-05-08 08:57:09 UTC
Adding to the lists: sometimes failing on SNB
spec@arb_texture_multisample@texelfetch@4-gs-isampler2dms
spec@arb_texture_multisample@texelfetch@2-gs-usampler2dms
spec@arb_texture_multisample@texelfetch@4-gs-usampler2dms
spec@arb_texture_multisample@texelfetch@2-gs-sampler2dmsarray
spec@arb_texture_multisample@texelfetch@4-gs-sampler2dmsarray
Comment 5 Martin Peres 2018-09-04 10:21:58 UTC
(In reply to Tomi Sarvela from comment #4)
> Adding to the lists: sometimes failing on SNB
> spec@arb_texture_multisample@texelfetch@4-gs-isampler2dms
> spec@arb_texture_multisample@texelfetch@2-gs-usampler2dms
> spec@arb_texture_multisample@texelfetch@4-gs-usampler2dms
> spec@arb_texture_multisample@texelfetch@2-gs-sampler2dmsarray
> spec@arb_texture_multisample@texelfetch@4-gs-sampler2dmsarray

No problems seen on 3+ months with this blacklist. Let's close the bug since these issues are we can't fix.
Comment 6 CI Bug Log 2019-09-09 06:36:45 UTC
The CI Bug Log issue associated to this bug has been restored.

All the previous filters are now active.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.