Bug 106489 - 'Apple touchpad bcm5974' unresponsive after "palm: touch size exceeded" on 'Apple MacBookPro5,4 (mid 2009)' with 1.10.4 (Ubuntu 18.04), worked fine with 1.8.2 (Ubuntu 17.10)
Summary: 'Apple touchpad bcm5974' unresponsive after "palm: touch size exceeded" on 'A...
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Wayland bug list
QA Contact:
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-12 16:13 UTC by mario.vukelic
Modified: 2018-05-15 06:51 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Output of sudo libinput-list-devices (3.38 KB, text/plain)
2018-05-12 16:13 UTC, mario.vukelic
Details
UdevDB.txt as produced by Ubuntu (153.82 KB, text/plain)
2018-05-12 16:51 UTC, mario.vukelic
Details

Description mario.vukelic 2018-05-12 16:13:41 UTC
Created attachment 139525 [details]
Output of sudo libinput-list-devices

Touchpad worked perfectly with libinput 1.8.2 on Ubuntu 17.10.
With 1.10.4 on Ubuntu 18.04, touchpad becomes temporarily unresponsive during normal use.

The most reliable reproduction seems to perform a circular motion for a couple of seconds. The pointer will stop moving and the touchpad will stop responding to further input. Lifting the finger from the trackpad makes it work again until problem is triggered next time (which usually only takes a few seconds during use). 

Running "sudo libinput debug-events --verbose" results in:

 event6   POINTER_MOTION   +11.04s	  5.07/ -9.23
 event6   POINTER_MOTION   +11.05s	 16.95/ -2.91
 event6   POINTER_MOTION   +11.06s	 13.15/ -4.05
event6  - palm: touch size exceeded
event6  - palm: palm detected (touch size)
event6  - touch-size: end touch
event6  - button state: from BUTTON_STATE_AREA, event BUTTON_EVENT_UP to BUTTON_STATE_NONE

Most likely the same issue was filed for Fedora and the apparent fix was to set
LIBINPUT_ATTR_PALM_SIZE_THRESHOLD=1000
See https://bugzilla.redhat.com/show_bug.cgi?id=1575260

I also filed a bug in Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/libinput/+bug/1764097
Comment 1 mario.vukelic 2018-05-12 16:30:57 UTC
Running "sudo libinput measure touch-size" gives, for a single finger, max sizes between 580 (finger tip) and 1900 (when I deliberately put the first phalanx down flat). 

"Normal" finger placement size is approx 850 to 950.
It seems to detect a palm event above 800, and this reliably reproduces the problem.
Comment 2 mario.vukelic 2018-05-12 16:51:41 UTC
Created attachment 139526 [details]
UdevDB.txt as produced by Ubuntu

Let me know if you need anything else
Comment 3 Peter Hutterer 2018-05-14 23:19:40 UTC
Should be fixed now with

commit d7ff5a8f0d876b3125978fd357716ac0f5619de0
Author: Veli-Jussi Raitila <>
Date:   Fri May 11 12:26:16 2018 +0300

     Add quirk to fix spurious palm detections on MacBook Pro (13-inch, Mid 2009)
Comment 4 mario.vukelic 2018-05-15 06:14:45 UTC
Thank you very much.

In case it matters, the MacBookPro5,4 in this report is the 15" model, the MacBookPro5,5 in the Fedora bug report is the 13" model. They are both from the same mid-2009 generation.
Comment 5 Peter Hutterer 2018-05-15 06:51:16 UTC
thanks! shouldn't matter because they appear to have the same vid/pid for the touchpad (0x0237), so yours is captured by that match rule.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.