Bug 106502 - Running game with wine fullscreen freezes the system when missing xf86-video-amdgpu
Summary: Running game with wine fullscreen freezes the system when missing xf86-video-...
Status: RESOLVED DUPLICATE of bug 106351
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: mesa-dev
QA Contact: mesa-dev
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-13 15:25 UTC by Fabian Maurer
Modified: 2018-05-15 07:31 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg log when freeze occurs (41.25 KB, text/plain)
2018-05-14 19:27 UTC, Fabian Maurer
Details
Xorg log when it works (30.49 KB, text/plain)
2018-05-14 19:27 UTC, Fabian Maurer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Maurer 2018-05-13 15:25:16 UTC
I don't know where to put this bug, because I don't know the category.
When running a specific game with wine in fullscreen, it freezes the system until I reboot. windowed works, but switching to fullscreen causes a freeze.

It used to work, I tried downgrading mesa, linux and wine, but I can't get it to work anymore. I really don't know what causes this.

Only relevant output I see in dmesg logs is
> Mai 13 17:08:23 arch kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:43:crtc-0] flip_done timed out
But I don't know if that's really the problem here.

What kind of logs/debugging would help figure out the problem?

System info:
- Using Mesa 18.2.0-devel (git-26ddc4f9e1) / 18.0.3
- Linux 4.16.8 / 4.16.3
- plasma-desktop 5.12.5
- Arch Linux x64
- Radeon R9 285
Comment 1 Fabian Maurer 2018-05-13 17:41:20 UTC
Okay, I figured out what causes it: It's due to a corrupt installation of xf86-video-amdgpu. When this package is not installed, I get the freeze. However, this is nothing that should happen.


I think this package is part of mesa, but I'm not sure. So feel free to point me to another bugtracker if I'm mistaken.
Comment 2 Michel Dänzer 2018-05-14 10:10:53 UTC
What does "corrupt installation of xf86-video-amdgpu" mean exactly?

Please attach the Xorg logs corresponding to the working and broken case.
Comment 3 Fabian Maurer 2018-05-14 19:27:14 UTC
Created attachment 139564 [details]
Xorg log when freeze occurs

> What does "corrupt installation of xf86-video-amdgpu" mean exactly?

The package wasn't installed completely (missing files), probably due to a reboot during a freeze. I installed the package (but xorg was already running) and then ran into the freeze, so the package needed to be force-reinstalled-
Comment 4 Fabian Maurer 2018-05-14 19:27:28 UTC
Created attachment 139565 [details]
Xorg log when it works
Comment 5 Michel Dänzer 2018-05-15 07:31:56 UTC
Please try the Mesa patch I referenced in bug 106351.

*** This bug has been marked as a duplicate of bug 106351 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.