Bug 10658 - 3dsmax-04 and ugnx-01 of SPECViewPerf 9.0 cause Segmentation fault
Summary: 3dsmax-04 and ugnx-01 of SPECViewPerf 9.0 cause Segmentation fault
Status: VERIFIED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: libGL (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-16 23:25 UTC by Wei Tang
Modified: 2008-10-12 19:00 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.97 KB, text/plain)
2007-04-16 23:29 UTC, Wei Tang
no flags Details
Xorg.0.log (206.96 KB, text/plain)
2007-04-16 23:30 UTC, Wei Tang
no flags Details
viewperf.log (21.48 KB, text/plain)
2007-04-16 23:30 UTC, Wei Tang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wei Tang 2007-04-16 23:25:30 UTC
System Enviroment:
--------------------------
Arch:           945g x86_64
OSD:            Fedora Core release 5 (Bordeaux)
Kernel:         2.6.20
Drm:            ddcb994c3eac97e153922e2a4c71384404f68597 (32bit),  (64bit)
Mesa:           7eba12edce871c3db835decbf1a0271acfd3eb68 (32bit),  (64bit)

Bug detailed description:
--------------------------
Running: 3dsmax-04.csh
Writing PNG file '../results/3dsmax/3dsmax01.png'...done.
Writing PNG file '../results/3dsmax/3dsmax01-depth.png'...done.
Writing PNG file '../results/3dsmax/3dsmax01Full.png'...done.
Writing PNG file '../results/3dsmax/3dsmax01Full-depth.png'...done.
Writing PNG file '../results/3dsmax/3dsmax02.png'...done.
Writing PNG file '../results/3dsmax/3dsmax02-depth.png'...done.
Writing PNG file '../results/3dsmax/3dsmax02Full.png'...done.
Writing PNG file '../results/3dsmax/3dsmax02Full-depth.png'...done.
Segmentation fault
Comment 1 Wei Tang 2007-04-16 23:29:24 UTC
Created attachment 9624 [details]
xorg.conf
Comment 2 Wei Tang 2007-04-16 23:30:04 UTC
Created attachment 9625 [details]
Xorg.0.log
Comment 3 Wei Tang 2007-04-16 23:30:31 UTC
Created attachment 9626 [details]
viewperf.log
Comment 4 haihao 2007-04-28 02:28:22 UTC
The segfault caused by SPECViewPerf/3dsmax is fixed by commit 565cd49b5fc7a5bd1e533542888bf322b83b8e56.

The segfault casued by SPECViewPerf/ugnx on 64bits system is a case issue (glXGetProcAddressARB isn't declared explicitly in viewperf.c)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.