Bug 106650 - [CI] igt@gem_render_copy_redux@.* - incomplete - No logs
Summary: [CI] igt@gem_render_copy_redux@.* - incomplete - No logs
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: ReadyForDev
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-25 13:04 UTC by Martin Peres
Modified: 2019-03-08 15:30 UTC (History)
2 users (show)

See Also:
i915 platform: CFL, KBL, SKL
i915 features: GEM/Other


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Chris Wilson 2018-05-25 13:08:58 UTC
ickle@kabylake:~$ sudo ./intel-gpu-tools/tests/gem_render_copy_redux 
IGT-Version: 1.22-g54cc50b0 (x86_64) (Linux: 4.17.0-rc6+ x86_64)
Subtest normal: SUCCESS (0.150s)
Subtest interruptible: SUCCESS (0.109s)
Subtest flink: SUCCESS (0.152s)
Subtest flink-interruptible: SUCCESS (0.154s)

Odd.
Comment 2 Martin Peres 2018-05-25 13:24:34 UTC
(In reply to Chris Wilson from comment #1)
> ickle@kabylake:~$ sudo ./intel-gpu-tools/tests/gem_render_copy_redux 
> IGT-Version: 1.22-g54cc50b0 (x86_64) (Linux: 4.17.0-rc6+ x86_64)
> Subtest normal: SUCCESS (0.150s)
> Subtest interruptible: SUCCESS (0.109s)
> Subtest flink: SUCCESS (0.152s)
> Subtest flink-interruptible: SUCCESS (0.154s)
> 
> Odd.

Try running it in a loop :) But maybe it has been fixed already... I am just catching up with the old drmtip runs (from two weeks ago).
Comment 3 Francesco Balestrieri 2018-07-02 11:26:02 UTC
Still seen on drmtip runs (latest was drmtip_71 a week ago)
Comment 4 Rodrigo Vivi 2018-07-17 20:50:28 UTC
Where exactly Francesco? 

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_71/fi-cfl-s3/igt%40gem_render_copy_redux%40normal.html

I got gem_render_copy_redux running here in constant loop (while true; do; test; done) and the uptime is more than 20 thousand minutes running with no failure.
real 20027m5.300s
user 9228m1.143s
sys 5044m18.306
Comment 5 Chris Wilson 2018-07-17 21:19:28 UTC
It's unlikely to be a bug in rendercopy per se, but another instance of the random logless incomplete we see in the shards.
Comment 6 Francesco Balestrieri 2019-01-09 08:56:22 UTC
Last occurrence on SKL a month ago: 

https://intel-gfx-ci.01.org/tree/drm-tip/drmtip_150/fi-skl-6700k2/igt@gem_render_copy_redux@normal.html
Comment 7 Francesco Balestrieri 2019-02-12 10:59:04 UTC
Last happened 2 months, 2 weeks / 1477 runs ago, but the last interval before that was ~150 runs. Let's keep it open for a while still.
Comment 8 Francesco Balestrieri 2019-03-01 12:43:25 UTC
Still nothing. Out of sight, out of mind.
Comment 9 Martin Peres 2019-03-08 15:30:15 UTC
Used to happen pretty much every drmtip run, and now not seen for 80. Closing!
Comment 10 CI Bug Log 2019-03-08 15:30:30 UTC
The CI Bug Log issue associated to this bug has been archived.

New failures matching the above filters will not be associated to this bug anymore.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.