Bug 106658 - 2500u HP Envy x360 Hangs randomly
Summary: 2500u HP Envy x360 Hangs randomly
Status: NEW
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/AMDgpu (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-25 19:38 UTC by Justin Mitzel
Modified: 2018-07-24 22:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Journalctl -k output (80.46 KB, text/plain)
2018-05-25 19:54 UTC, Justin Mitzel
no flags Details
Journalctl -k -b 2 output (118.71 KB, text/plain)
2018-05-25 19:55 UTC, Justin Mitzel
no flags Details
Current Xorg log (31.23 KB, text/plain)
2018-05-25 19:59 UTC, Justin Mitzel
no flags Details
dmesg (63.34 KB, text/plain)
2018-05-25 20:02 UTC, Justin Mitzel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Mitzel 2018-05-25 19:38:57 UTC
With a 2500U, on any linux kernel (including drm-next) every few minutes/hours the system completely hangs, forcing a hard restart. The system throws me a ton of APCI errors after I tried updating the bios, but it still hung before this BIOS update. I will post journalctl -k output, Xorg log, and dmesg output. Let me know if you need more information, i'm willing to turn on debugging outputs.
Comment 1 Justin Mitzel 2018-05-25 19:54:11 UTC
Created attachment 139773 [details]
Journalctl -k output

I've disabled the PCI errors in the past, it does not stop the hangs.
Comment 2 Justin Mitzel 2018-05-25 19:55:09 UTC
Created attachment 139774 [details]
Journalctl -k -b 2 output
Comment 3 Justin Mitzel 2018-05-25 19:59:55 UTC
Created attachment 139775 [details]
Current Xorg log

for some reason xorg.log.1 is empty, I will have to post it some other time
Comment 4 Justin Mitzel 2018-05-25 20:02:31 UTC
Created attachment 139776 [details]
dmesg
Comment 5 Tim Carr 2018-07-24 22:34:19 UTC
Have you tried booting with the 'idle=nomwait' kernel option? This worked for the submitter of similar bug #106670, and so far seems to have worked for me as well.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.