Bug 106675 - [drm] HPD interrupt storm detected on connector HDMI-A-1 : switching from hotplug detection to polling
Summary: [drm] HPD interrupt storm detected on connector HDMI-A-1 : switching from hot...
Status: CLOSED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL:
Whiteboard: Triaged
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-28 06:32 UTC by aether
Modified: 2018-06-04 14:35 UTC (History)
3 users (show)

See Also:
i915 platform: GM45
i915 features: display/Other


Attachments
Logs added (dmesg, lspci, mkinitpcio...) (75.25 KB, text/plain)
2018-05-28 09:50 UTC, aether
no flags Details
Log (dmesg) from remote console SSH after display is fully freezed (10.86 KB, text/plain)
2018-05-28 09:58 UTC, aether
no flags Details
dmesg log (4.17 drm-tip : drm.debug=0x1e log_buf_len=4M) (830.48 KB, text/plain)
2018-05-28 21:43 UTC, aether
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description aether 2018-05-28 06:32:07 UTC
Bug description: After X starts, this message apepars randomly in dmesg :

[drm] HPD interrupt storm detected on connector HDMI-A-1 : switching from hotplug detection to polling

When it happens, the display freezes (including sound) for a few seconds, sometimes more (to the point I'm forced to hard shutdown)

System environment:
-- chipset: GM45
-- system architecture: 64-bit
-- xf86-video-intel: 1:2.99.917-1 
-- xserver: 1.19.3
-- mesa: 2.1 Mesa 17.0.5
-- kernel: 4.9.102
-- Linux distribution: Hyperbola GNU/Linux
-- Machine or mobo model: Thinkpad T400 R8KMZN2
-- Display connector: Internal (LVDS) 1440x900

Reproducing steps: Start X, after a few seconds (or minutes), the display freezes, when it happens, this message appears in dmesg :

[drm] HPD interrupt storm detected on connector HDMI-A-1 : switching from hotplug detection to polling

Additional info: 

- T400 is running Libreboot bios, the issue happens with late KMS and early KMS.

->>> Issue is not present with 4.16.12 kernel <<<-
Comment 1 aether 2018-05-28 09:50:41 UTC
Created attachment 139810 [details]
Logs added (dmesg, lspci, mkinitpcio...)

Logs added (dmesg, lspci, mkinitpcio...)
Comment 2 aether 2018-05-28 09:58:18 UTC
Created attachment 139811 [details]
Log (dmesg) from remote console SSH after display is fully freezed

Log (dmesg) from remote console SSH after display is fully freezed
Comment 3 aether 2018-05-28 10:00:12 UTC
If you need more info or logs, let me know, it is the first time I report a bug.
Comment 4 Jani Saarinen 2018-05-28 11:14:33 UTC
Can you try with latest drm-tip: https://cgit.freedesktop.org/drm-tip and send dmesg with drm.debug=0x1e log_buf_len=4M?.

drm-tip currently on Linux version 4.17.0-rc6. 

Do not cut (no greps etc) logs but keep them intact.
Comment 5 Jani Saarinen 2018-05-28 11:18:01 UTC
reference to build kernel: https://01.org/linuxgraphics/documentation/build-guide-0 (drm-tip part only)
Comment 6 aether 2018-05-28 21:43:52 UTC
Created attachment 139818 [details]
dmesg log (4.17 drm-tip : drm.debug=0x1e log_buf_len=4M)

dmesg log (4.17 drm-tip : drm.debug=0x1e log_buf_len=4M)
Comment 7 aether 2018-05-28 21:45:30 UTC
(In reply to Jani Saarinen from comment #4)
> Can you try with latest drm-tip: https://cgit.freedesktop.org/drm-tip and
> send dmesg with drm.debug=0x1e log_buf_len=4M?.
> 
> drm-tip currently on Linux version 4.17.0-rc6. 
> 
> Do not cut (no greps etc) logs but keep them intact.

Hello,
Sorry, it took me a while to clone (slow network) & compile.
I added the dmesg log with 4.17 drm-tip
Comment 8 aether 2018-05-28 21:48:19 UTC
The issue is not present with drm-tip as well. No freeze.
Comment 9 Jani Saarinen 2018-05-29 06:24:14 UTC
based on this resolving as works in upstream. Hopefully these got in to 4.18 kernel.
Comment 10 aether 2018-05-29 06:39:30 UTC
The issue is that the distro I use only package 4.9.x kernel. (LTS)
I don't understand much how drm fixes are handled for LTS kernels. Will 4.9.x LTS kernel receive a patch for i915 drm ?
Sorry if it sounds dumb, I don't have much experience with that. I can certainly compile a kernel from 4.16 branch until then though.
Thanks for your help.
Comment 11 Jani Saarinen 2018-05-29 06:46:04 UTC
Jani, can you comment how this goes?
Comment 12 Jani Nikula 2018-05-30 07:58:32 UTC
(In reply to aether from comment #10)
> The issue is that the distro I use only package 4.9.x kernel. (LTS)
> I don't understand much how drm fixes are handled for LTS kernels. Will
> 4.9.x LTS kernel receive a patch for i915 drm ?
> Sorry if it sounds dumb, I don't have much experience with that. I can
> certainly compile a kernel from 4.16 branch until then though.
> Thanks for your help.

This is the upstream bugzilla, the issue is fixed upstream, case closed.

For backports, we'd need to know *which* commit fixed the issue. Here we have no clue. If you come up with a reverse bisect indicating which commit fixed the issue upstream, and if the fix is small enough, we can request the stable kernel maintainers to backport the fix.

Otherwise, you can file a bug against your distro.
Comment 13 aether 2018-05-30 09:34:27 UTC
(In reply to Jani Nikula from comment #12)
> (In reply to aether from comment #10)
> > The issue is that the distro I use only package 4.9.x kernel. (LTS)
> > I don't understand much how drm fixes are handled for LTS kernels. Will
> > 4.9.x LTS kernel receive a patch for i915 drm ?
> > Sorry if it sounds dumb, I don't have much experience with that. I can
> > certainly compile a kernel from 4.16 branch until then though.
> > Thanks for your help.
> 
> This is the upstream bugzilla, the issue is fixed upstream, case closed.
> 
> For backports, we'd need to know *which* commit fixed the issue. Here we
> have no clue. If you come up with a reverse bisect indicating which commit
> fixed the issue upstream, and if the fix is small enough, we can request the
> stable kernel maintainers to backport the fix.
> 
> Otherwise, you can file a bug against your distro.

Alright, thanks for the complementary information.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.