Bug 106720 - Logitech K400+ double tap on touchpad is problematic
Summary: Logitech K400+ double tap on touchpad is problematic
Status: RESOLVED FIXED
Alias: None
Product: Wayland
Classification: Unclassified
Component: libinput (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-30 10:38 UTC by errolbury
Modified: 2018-06-07 22:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
some system outputs (8.24 KB, text/plain)
2018-05-30 10:38 UTC, errolbury
Details

Note You need to log in before you can comment on or make changes to this bug.
Description errolbury 2018-05-30 10:38:04 UTC
Created attachment 139846 [details]
some system outputs

I have a Logitech K400 Plus
https://assets.logitech.com/assets/54246/wireless-touch-keyboard-k400-plus.png
It was previously working as expected on KDE neon 5.12
(which is currently based on Ubuntu 16.04 LTS)
Prior to neon I was using Xubuntu 17.04 and then moved to Kubuntu 17.04
(again, this device was working on those distros as expected)

On Kubuntu 18.04 however on the touchpad...
I noted that a double tap results in a single click
attempting to select a portion of text--obviously--does not do as expected
attempting to click an item on System Settings does nothing; have to use the Enter or button key

However, the left-click and right-click button keys work as expected
so currently there are workarounds and ways to compensate...

Possible duplicates
https://bugs.launchpad.net/ubuntu/+source/libinput/+bug/1762536
https://bugs.freedesktop.org/show_bug.cgi?id=105974
https://bugs.freedesktop.org/show_bug.cgi?id=106534
Comment 1 Peter Hutterer 2018-05-30 22:50:37 UTC

*** This bug has been marked as a duplicate of bug 105974 ***
Comment 2 Daniel van Vugt 2018-05-31 01:40:09 UTC
This might not be a duplicate, and was specifically opened because the fix for bug 105974 doesn't work for this user.

See comment 12 in https://bugs.launchpad.net/ubuntu/+source/libinput/+bug/1762536
Comment 3 Peter Hutterer 2018-05-31 02:44:21 UTC
are you shipping 6dcdfdd513fd8158bc7bacbad8c5c8ba987565a0 in the ubuntu package?
Comment 4 errolbury 2018-05-31 07:31:42 UTC
looking at this record...
https://bugs.freedesktop.org/show_bug.cgi?id=106534
it would seem that it only resolved in part 'cos of the three listed devices
the k400+ was not affected by whatever was done to libinput-model-quirks.hwdb
as I said elsewhere, it appears that the specific tag 
LIBINPUT_MODEL_LOGITECH_K400+
was not been added to that hwdb
Comment 5 Peter Hutterer 2018-05-31 08:14:17 UTC
what's the product ID of the K400+? 0x404D? If so, it's in the list of devices added in 6dcdfd.

https://wayland.freedesktop.org/libinput/doc/latest/udev_config.html#hwdb

has instructions for checking whether LIBINPUT_MODEL_BOUNCING_KEYS is set on your device. If not, then either you have  different product ID (check evemu-record's first lines) or there's a typo somewhere in the hwdb.

> LIBINPUT_MODEL_LOGITECH_K400+ 

That tag never existed, at least not upstream and unfortunately bug 106534 is full of noise.
Comment 6 errolbury 2018-05-31 12:16:03 UTC
From my attachment:
  Device Product ID (264):        1133, 16461

Otherwise, how do I get that detail for you?
Comment 7 errolbury 2018-05-31 12:52:30 UTC
And I see this--in my attachment--as well:

  idProduct          0xc52b Unifying Receiver
ID 046d:c52b Logitech, Inc. Unifying Receiver

Your udev link re determining bouncing keys, unfortunately doesn't make sense to me (*above my pay grade*). I tried some of that syntax there. All I could get was an event node name for the K400+ but I couldn't see any reference to "bouncing" on that page to take that discovery any further...

PS. In all previous Ubuntu releases, this keyboard never had problem with whatever distro flavor; something changed with 18.04. Is it gonna be easier just to buy another keyboard?
Comment 8 errolbury 2018-05-31 13:09:51 UTC
Sorry for these replies in drips and drabs
I since discovered this:

[    4.889018] logitech-djreceiver 0003:046D:C52B.0003: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:14.0-4/input2
[    5.017526] input: Logitech K400 Plus as /devices/pci0000:00/0000:00:14.0/usb2/2-4/2-4:1.2/0003:046D:C52B.0003/0003:046D:404D.0004/input/input3
[    5.017694] logitech-hidpp-device 0003:046D:404D.0004: input,hidraw1: USB HID v1.11 Keyboard [Logitech K400 Plus] on usb-0000:00:14.0-4:1
Comment 9 Peter Hutterer 2018-05-31 22:06:43 UTC
> how do I get that detail for you?

From comment 5:
> (check evemu-record's first lines)

anyway, 16461 in hex is 0x404d, so it was part of the commit listed above. The udevadm info output should list LIBINPUT_MODEL_BOUNCING_KEYS if everything is set up correctly.

But we don't seem to be getting anywhere. As said twice above, the 6dcdfd commit is part of git master but not yet in 1.10.x.

https://launchpad.net/ubuntu/+source/libinput/1.10.7-1 suggests that ubuntu doesn't ship any extra patches on top of 1.10.7. Which means *this patch is not in Ubuntu*. So it won't yet be fixed on your distribution.

I'm closing this bug again because unless someone verifies that it's broken on *git master* this is still considered fixed. Note that this is the upstream bug reporting tool, not Ubuntu's bug reporting tool. And unless Ubuntu starts shipping git master, there will be bugs that are fixed here but still broken in Ubuntu.

https://wayland.freedesktop.org/libinput/doc/latest/reporting_bugs.html#fixed_bugs
Comment 10 errolbury 2018-06-01 05:37:16 UTC
Thank you very much!
Comment 11 errolbury 2018-06-07 14:10:13 UTC
Re Comment 9 and a FYI:

Noted that with Fedora 28 (kernel version 4.16.3-301.fc28.x86_64)
this K400+ does kinda the same thing
I say kinda because (a) while the double-tap behaves the same in both distros (b) selecting text does work with Fedora but not in Ubuntu 18.n

Seems it may require more than merely Ubuntu intervention...
Comment 12 Peter Hutterer 2018-06-07 22:24:52 UTC
Please update to libinput 1.11 in f28 updates-testing, any version before
that won't have the required patches. If it's broken with that version, then
we should probably start a new bug because it's likely the issue is
elsewhere.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.